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Interferometry Tutorial 
The goal of this tutorial is to provide novice and experienced remote sensing users with step-by-step 
instructions on interferometric processing with Sentinel-1 Interferometric Wide Swath products.  

Background 

What is Interferometry? 

Interferometric synthetic aperture radar (InSAR) exploits the phase difference between two complex radar 
SAR observations taken from slightly different sensor positions and extracts information about the earth’s 
surface. 
 
A SAR signal contains amplitude and phase information. The amplitude is the strength of the radar 
response and the phase is the fraction of one complete sine wave cycle (a single SAR wavelength). The 
phase of the SAR image is determined primarily by the distance between the satellite antenna and the 
ground targets. 
 
By combining the phase of these two images after coregistration, an interferogram can be generated whose 
phase is highly correlated to the terrain topography. In the case of differential interferometry (DInSAR), this 
topographic phase contribution is removed using a digital elevation model (DEM). The remaining variation 
in the interferogram can be attributed to surface changes which occurred between the two image acquisition 
dates, as well as unwanted atmospheric effects.  
 
For an introduction to interferometric concepts, please see ESA’s InSAR Principles: Guidelines for SAR 
Interferometry Processing and Interpretation (ESA TM-19). 
 

Sentinel-1 Interferometric Wide Swath Products 

The Interferometric Wide (IW) swath mode is the main acquisition mode over land for Sentinel-1. It acquires 
data with a 250 km swath at 5 m by 20 m spatial resolution (single look). IW mode captures three sub-
swaths using Terrain Observation with Progressive Scans SAR (TOPSAR). With the TOPSAR technique, 
in addition to steering the beam in range as in ScanSAR, the beam is also electronically steered from 
backward to forward in the azimuth direction for each burst, avoiding scalloping and resulting in 
homogeneous image quality throughout the swath. 
 
TOPSAR mode replaces the conventional ScanSAR mode, achieving the same coverage and resolution 
as ScanSAR, but with a nearly uniform SNR (Signal-to-Noise Ratio) and DTAR (Distributed Target 
Ambiguity Ratio). 
 
IW SLC products consist of three sub-swaths (Figure 1, red labels) image per polarization channel, for a 
total of three (single polarizations) or six (dual polarization) images in an IW product. Each sub-swath image 
consists of a series of bursts (Figure 1, white labels), where each burst has been processed as a separate 
SLC image. The individually focused complex burst images are included, in azimuth-time order, into a single 
sub-swath image with black-fill demarcation in between, similar to ENVISAT ASAR Wide ScanSAR SLC 
products. 
 
More information on Sentinel-1 IW products is provided here: https://sentinel.esa.int/web/sentinel/user-
guides/sentinel-1-sar/acquisition-modes/interferometric-wide-swath. 
 
The data used in this tutorial includes the metropolitan area around Katowice, Poland. It is part of the Upper 
Silesian Coal Basin where surface subsidence is reported for a considerable number of small depressions 
as a result of the long-year coal mining and the subsequent flooding of the mines. Figure 2 shows the extent 
of the Sentinel-1 data (red) and of the subset used in this tutorial (blue).  

http://www.esa.int/esaMI/ESA_Publications/SEM867MJC0F_0.html
http://www.esa.int/esaMI/ESA_Publications/SEM867MJC0F_0.html
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/acquisition-modes/interferometric-wide-swath
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/acquisition-modes/interferometric-wide-swath
http://www.pjoes.com/Mine-Subsidence-as-a-Post-Mining-Effect-in-the-Upper-Silesia-Coal-Basin,61117,0,2.html
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Figure 1: Sub-swaths (red) and bursts (white) of S1 IW products (blue area is used in this tutorial) 
 

 

 

Figure 2: Extent and location of the data  
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Preparation 

Download the Data 

The data used in this tutorial can be downloaded from the Copernicus Open Access Hub at:  
https://scihub.copernicus.eu/dhus (login required, registration is free) 
 
Search for the two product IDs and download them:  
S1B_IW_SLC__1SDV_20191208T163422_20191208T163449_019276_024651_E2F6 
S1B_IW_SLC__1SDV_20191220T163421_20191220T163448_019451_024BE6_79C7 
 
As some of the required steps are computationally intensive, it is good to store the data at a location which 
offers good reading and writing speed. If your computer has an internal SSD, processing should be done 
there to ensure best performance. Network drives or external storage devices are not recommended. Also, 
paths which include special characters should be avoided. In this tutorial, the data is stored under 
C:\Temp\S1_InSAR\. 

Install snaphu 

This tutorial can entirely be done within SNAP. Yet, as an external software package, snaphu (statistical-
cost network-flow algorithm for phase unwrapping) has to be installed separately. For more information on 
this tool, please visit https://web.stanford.edu/group/radar/softwareandlinks/sw/snaphu/. 
 
To install the plugin in SNAP, go to Plugins (under the Tools menu, Figure 3) and search for “SNAPHU 
Unwrapping” in the Available Plugins tab. Select it and click Install. 
 

 

Figure 3: The Plugins interface 

 
You will be asked to proceed with “Next” and restart SNAP (Figure 4). This creates a menu entry for snaphu 
unwrapping in the Interferometry menu. 

https://scihub.copernicus.eu/dhus
https://en.wikipedia.org/wiki/Solid-state_drive
https://web.stanford.edu/group/radar/softwareandlinks/sw/snaphu/
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Figure 4: Installation of the snaphu plugin 

 
After you have restarted SNAP, you need to install the snaphu bundles as well. Go to Manage External 

Tools in the Tools menu. Select “Snaphu-unwrapping” and click Edit the selected operator   to open 
the configuration (Figure 5). Select a suitable Target Folder (here C:\GIS) where snaphu will be installed 

and proceed with Download and Install Now. You will then get a confirmation “Bundle was installed in 
location C:\GIS\snaphu-v1.4.2_win64” (this may differ according to version, path and operating system).  
 

 

Figure 5: Installation of the snaphu bundles  
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Open the Products 

Use the Open Product button in the top 
toolbar and browse for the location of the 
downloaded data. Select the two zip files and 
press Open Product.  
 
In the Products View you will see the opened 
products. Each Sentinel-1 product consists of 
Metadata, Vector Data, Tie-Point Grids, 
Quicklooks and Bands (which contains the actual 
raster data, organized by polarization and sub-
swath as demonstrated in Figure 1).  
 
As the data is still compressed in the zip file and 
each sub-swath covers a large area, it is not 
advised to open the bands in their current state, 
because it takes a considerable time until SNAP 
loads the raster. If you still want to check the data 
before proceeding double-click on the 
Intensity_IW1_VV band to view the raster data.  
 
Another way to identify the location of your study 
area within the product (required for the next 
step), you can use the World View or World Map 
(to see its full extent on a base map) or open the 
Quicklook for a preview of the dataset in an RGB 
color representation. 
 
Note: If you miss any items in your user interface 
you can activate them in the menu under View 
and Tool Windows.  
 
The World View or World Map menus are also a 
good way to check if your image belong to the 
same relative orbit (required for interferometry) 
and if they are shifted along-track. The latter is 
allowed for interferometry but needs to be taken 
into account in the next step (TOPS Split).  

 

Figure 6: Product Explorer and World Map 

 
 

Coregistration 
To exploit the phase difference of the acquisitions, a stack containing both products must be created first. 
Coregistration makes use of image statistics to align both products at sub-pixel accuracy. While 
conventional Stripmap radar products can be coregistered within one step, S1 TOPSAR products require 
a series of steps, because of their special form of acquisition (Figure 1).  
 
SNAP offers to combine all these steps within the S-1 TOPS Coregistration with ESD operator, but this 
processing chain consumes a lot of memory. In this tutorial, the single steps to correctly coregister the 
products are performed individually and successively.  
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TOPS Split 

S-1 TOPS Split is applied to the data to select only those bursts which are required for the analysis. They 
are marked in blue in Figure 1. Currently, each Sub-Swath is processed separately. Note: If the area of 
interest covers several Sub-Swaths, they have to be merged with the S-1 TOPS Merge operator after the 
Sub-Swaths were debursted.  
 
To reduce the loaded data to the area of interest, open the S-1 TOPS Split operator (under Radar > 
Sentinel-1 TOPS) and select sub-swath IW2 and VV polarization in the Processing Parameters. Then 
reduce the bursts to 6 to 7 by dragging the grey triangles towards the middle. Use the preview to check the 
location of the selected area (Figure 7). Confirm with Run and repeat the step for the second S1 image.  
 
Note: If you want to combine images Sentinel-1A and Sentinel-1B be aware that the extents of the products 
can be shifted along-track and different bursts must be selected for the same area.  
 

 

Figure 7: TOPS Split 

 

Applying Orbit Information 

Orbit auxiliary data contain information about the position of the satellite during the acquisition of SAR 
data. They are automatically downloaded for Sentinel-1 products by SNAP and added to its metadata with 
the Apply Orbit File (under the menu point Radar) operator. 
 
The Precise Orbit Determination (POD) service for Sentinel-1 provides restituted orbit files and precise 
Orbit Ephemerides (POE) orbit files. POE files cover ca. 28 hours and contain orbit state vectors at intervals 
of 10 seconds intervals. Files are generated one file per day and are delivered within 20 days after data 
acquisition. 
 
If precise orbits are not yet available for your product, restituted orbits can be selected which may not be 
as accurate as the Precise orbits but will be better than the predicted orbits available within the product. 
 
Execute the operator for both split products as generated in the previous step (Figure 8).  
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Figure 8: Apply Orbit File 

 

Back Geocoding and Enhanced Spectral Diversity 

The S-1 Back Geocoding operator (under Radar > Coregistration > Sentinel-1 TOPS Coregistration) 
coregisters the two split products based on the orbit information added in the previous step and information 
from a digital elevation model (DEM) which is downloaded by SNAP.  
 
Add the products of the two dates (ending with “_split_Orb”) to the file list in the ProductSet-Reader tab and 
select SRTM 1Sec HGT (AutoDownload) in the Back-Geocoding tab (Figure 9).  
 
Please be aware that SRTM is only available between 60° North and 54° South. If your area lies outside 
this coverage (https://www2.jpl.nasa.gov/srtm/coverage.html), you can use one of the other DEMs with 
AutoDownload option or use an external DEM (just make sure it stored as a GeoTiff and projected in 
geographic coordinates / WGS84).  
 

 

Figure 9: Back Geocoding 

 
To increase the quality of the coregistration you apply the S-1 Enhanced Spectal Diversity (ESD) operator 
(under Radar > Coregistration > Sentinel-1 TOPS Coregistration) on the stack generated by the Back 
Geocoding. It applies range and azimuth shift corrections to the secondary image. 
  
Note: This operator is only needed when you select more than one burst. If you only selected one burst in 
the TOPS Split step, you do not need the ESD operator.  

https://www2.jpl.nasa.gov/srtm/coverage.html
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After the coregistration is completed, it is advisable to visually check the quality of the stack. This can be 
done by an RGB representation of the reference and secondary1 product which shows if the images are 
correctly aligned. Select the reference for red and green and the secondary for blue (Figure 10) 2.  
 

  

Figure 10: Generation of an RGB image 

 
Zoom in to an area with distinct surfaces, for example the border between land and water. The RGB image 
should be clear and sharp and not be dominated by one of the images (yellow [red+green] for the reference 
or blue for the secondary image). The only exception are changes in landcover or scattering mechanisms 
which occurred in the time between the first and the second image acquisition (Figure 11).  
 
 

 
 

 

Figure 11: Successful (top) vs. failed (bottom) coregistration in an RGB image 

 
 

  

 
1 We support the statement of the executive committees of WInSAR and COMET to exchange the inappropriate terminology in all 

InSAR-related fields. Accordingly, the former "master/slave" will be replaced by "reference/secondary" in future versions of SNAP. 
2 https://www.scientificamerican.com/article/end-of-the-rainbow-new-map-scale-is-more-readable-by-people-who-are-color-blind/  

https://comet.nerc.ac.uk/about-comet/insar-terminology/
https://www.scientificamerican.com/article/end-of-the-rainbow-new-map-scale-is-more-readable-by-people-who-are-color-blind/
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Interferogram Formation and Coherence Estimation 
An interferogram is formed by cross multiplying the reference image with the complex conjugate of the 
secondary image. The amplitude of both images is multiplied while the phase represents the phase 
difference between the two images. 
 
The interferometric phase of each SAR image pixel would depend only on the difference in the travel paths 
from each of the two SARs to the considered resolution cell. Accordingly, the computed interferogram 
contains phase variation ϕ from several contributing factors, most importantly the flat-earth phase ϕflat (earth 
curvature), the topographic phase ϕDEM (topographic surface of the earth), atmospheric conditions ϕatm 
(humidity, temperature and pressure change between the two acquisitions), and other noise ϕnoise (change 
of the scatterers, different look angle, and volume scattering ), and lastly the eventual surface deformation 
ϕdisp which occurred between the two acquisitions (Equation 1).  
 
A more detailed explanation is given by Roca et al. (1997), and in the documents compiled by ESA: InSAR 
Principles: Guidelines for SAR Interferometry Processing and Interpretation (ESA TM-19). 
 
 

 ϕ = ϕDEM + ϕflat + ϕdisp + ϕatm + ϕnoise  (1) 

 
 

 

Figure 12: Contributors to SAR interferometric phase 

 
 
Differential SAR interferometry tries to estimate the contribution from the earth’s surface (ϕflat and ϕDEM) 
which is considered equal for both image acquisitions and remove them from the interferogram so that the 
remaining phase variation can be attributed to surface elevation changes between both image acquisitions 
(Equation 2; ESA TM-19A, chapter 2.3). This works best if atmospheric contributions and other noise is 
kept as small as possible because they are hard to model. It is therefore advisable to use images from the 
dry season and with small perpendicular baseline. More hints on the selection of suitable image pairs are 
given in ESA TM-19B, chapter 1.4) 
 

 

 ϕdisp + ϕatm + ϕnoise = ϕ - ϕDEM - ϕflat (2) 

 
 

Besides the interferometric phase, the coherence between the reference and the secondary image is 
estimated as an indicator for the quality of the phase information. Basically, it shows if the images have 
strong similarities and are therefore usable for interferometric processing. Loss of coherence can produce 
poor interferometric results and is caused by temporal (over vegetation and water bodies), geometric (errors 
or inaccuracies in the orbit metadata) and volumetric decorrelation (potential scattering mechanisms of 
voluminous structures, such as complex vegetation or dry surfaces).  
 

Accordingly, repeat-pass interferometry (phase difference of images of two different 
acquisition dates) will rarely lead to usable results over dense vegetation, especially with  
C-band SAR data of Sentinel-1 which has a wavelength of around 5.5 cm). 

https://earth.esa.int/workshops/ers97/program-details/speeches/rocca-et-al/
http://www.esa.int/esaMI/ESA_Publications/SEM867MJC0F_0.html
http://www.esa.int/esaMI/ESA_Publications/SEM867MJC0F_0.html
http://www.esa.int/esapub/tm/tm19/TM-19_ptA.pdf
http://www.esa.int/esapub/tm/tm19/TM-19_ptB.pdf
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Coherence is calculated as a separate raster band and shows how similar each pixel is between the 
secondary and reference images in a scale from 0 to 1. Areas of high coherence will appear bright. Areas 
with poor coherence will be dark. In the image, vegetation is shown as having poor coherence and buildings 
have very high coherence. 
 
To compute the interferogram and the coherence bands, apply the Interferogram Formation operator (under 
Radar > Interferometric > Products). Select the stack you generated after Back Geocoding and ESD as an 
input and make sure to check the boxes: 
 

▪ Subtract flat-earth phase: The flat-earth phase is the phase present in the interferometric signal 
due to the curvature of the reference surface. The flat-earth phase is estimated using the orbital 
metadata information and subtracted from the complex interferogram. 

 
▪ Subtract topographic phase: Flat terrain should produce a series of regularly spaced, parallel 

fringes. Any deviation from a parallel fringe pattern can be interpreted as topographic variation. If 
you want this topographic variation (e.g. for the derivation of a digital elevation model), you do not 
subtract the topographic phase. As this workflow is interested in the surface displacement 
(Equation 2), topographic phase removal is applied by selecting the SRTM 1Sec HGT (Auto 
Download). 

  
▪ Include coherence estimation: This produces a coherence band in the output calculated based 

on a window of 10x3 pixels in range/azimuth direction based on equation 1.13 in ESA TM-19C.  
 

 

Figure 13: Interferogram Formation 

 
 
The resulting product will contain the interferogram (Phase_ifg_IW…) and the coherence (coh_IW_...) 

as separate bands (Figure 14). Double click them to check for their quality. Both products still contain the 
black seamlines separating the single bursts. They will be removed in the following step. 
 

https://www.esa.int/esapub/tm/tm19/TM-19_ptC.pdf
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As topographic phase removal was applied, the interferogram should now only contain variations from 
displacement, atmosphere and noise. It is displayed in a rainbow color scale ranging from -π to +π. The 
patterns, also called “fringes” represent a full 2π cycle and appear in an interferogram as cycles of arbitrary 
colors, with each cycle representing half the sensor’s wavelength. Relative ground movement between two 
points is later derived by counting the fringes and multiplying by half of the wavelength. The closer the 
fringes are together, the greater the strain on the ground.  
 
The coherence shows the areas where the phase information is coherent, which means that it can be used 
to measure deformation (as in this tutorial) or topography (without removing the topographic phase). While 
urban areas and agricultural land are displayed in white and show high coherence values (above 0.6), forest 
areas are dark and have low coherence (below 0.3). Accordingly, phase information over forest areas is 
not usable here. If low coherence areas are too dominant in the image, the later unwrapping will fail and 
produce faulty or random results.  
 
 

 

Figure 14: Interferogram (top) and coherence (bottom) 

 
 

  

Figure 15: Histogram of interferogram (left) and coherence (right)  
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TOPS Deburst 
To remove the seamlines between the single bursts, the S-1 TOPS Deburst operator (under Radar > 
Sentinel-1 TOPS) is applied to the interferogram product. It does not require any user input (Figure 16). 
The output contains the same bands as the input, but with merged bursts according to their zero Doppler 
time. More information on this step is provided in the Sentinel-1 User Guide.  
 

 

Figure 16: TOPS Deburst (left) and Goldstein phase filtering (right) 

 

Goldstein Phase Filtering 
Interferometric phase can be corrupted by noise from temporal and geometric decorrelation, volume 
scattering, and other processing errors. Phase information in decorrelated areas cannot be restored, but 
the quality of the fringes existing in the interferogram can be increased by applying specialized phase filters, 
such as the Goldstein filter which uses a Fast Fourier Transformation (FFT) to enhance the signal-to-noise 
ratio of the image. This is required for a proper unwrapping in the subsequent step. A detailed description 
of this filter and its parameters is given in the publication of Goldstein & Werner (1998).  
 
Apply the Goldstein Phase Filtering (under Radar > Interferometric > Filtering) to the debursted image. The 
output is a filtered phase image, the coherence is not affected.  
 

 

Figure 17: Interferogram before (left) and after (right) Goldstein phase filtering 

(50° 03’ 28” N, 18° 34’ 19” E)  

https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/acquisition-modes/interferometric-wide-swath
https://agupubs.onlinelibrary.wiley.com/doi/abs/10.1029/1998GL900033
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Subset 
As the selected bursts cover a larger area than required for this analysis, a subset can be generated. Please 
note that the subset should only be applied on a S1 SLC product after TOPS Deburst. Technically, the 
subset could have been applied before the phase filtering, but sometimes patterns become visible after 
applying the filter and it is good to have a look at the filtered result before selecting the area of interest.  
Furthermore, the subset allows to get rid of the green areas at the edges of the image which were introduced 
during the processing.  
 
To create a subset, select the filtered product in the Product Explorer and select Subset (under Raster). 
Enter the following Pixel coordinates 
 

▪ Scene start X:   8958 
▪ Scene start Y:  50 
▪ Scene end X:  17250 
▪ Scene end Y:  2800 

 
 

 

Figure 18: Subset 

 
It is also possible to enter geographic coordinates, but as the product is still stored in slant range geometry, 
these are not very precise. Furthermore, it is possible to draw a rectangle in the image preview.  
 

A new product is show in the Product Explorer, starting with subset_0_of_. This product is only of 

temporary nature and lost if SNAP is closed. To permanently store it, right-click on the product and select 

Save Product As… and save it in BEAM DIMAP format under the name 

20191208_20191220_split_Orb_Stack_esd_ifg_deb_flt_subset.dim  

Note: for reasons of consistency, the suffix subset is placed at the end of the filename.   
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Phase Unwrapping 
In the interferogram, the interferometric phase is ambiguous and only known within the scale of 2π. To be 
able to relate the interferometric phase to the topographic height, the phase must first be unwrapped. The 
altitude of ambiguity is defined as the altitude difference that generates an interferometric phase change of 
2π after interferogram flattening. 
 
Phase unwrapping solves this ambiguity by integrating phase difference between neighboring pixels. After 
deleting any integer number of altitudes of ambiguity (equivalent to an integer number of 2π phase cycles), 
the phase variation between two points on the flattened interferogram provides a measurement of the actual 
altitude variation (Figure 19). Accordingly, unwrapped results should be interpreted as a relative 
height/displacement between pixels of two images.  
 
 
 

 

Figure 19: Principle of phase unwrapping 

 
 
For optimal unwrapping results it is recommended to filter the interferogram as done in the previous step 
and eventually apply multi-looking (under Raster > SAR Utilities). As the fringe patterns of the surface 
displacement are quite fine scaled (Figure 17), no multi-looking is applied in this case. For the derivation of 
large-scale displacement maps, multi-looking to a spatial resolution of 20 meters or lower should be 
considered.  
 
The quality and reliability of unwrapped results very much depends on the input coherence. Reliable results 
can only be expected in areas of high coherence. Although no definite threshold exists, a minimum 
coherence of 0.3 is suggested.  
 
Unwrapping in SNAP follows three distinct steps:  
 

1. Export of the wrapped phase (and definition of the parameters)  
2. Unwrapping of the phase (performed outside SNAP by snaphu) 
3. Import of the unwrapped phase back into SNAP 

 
Because snaphu is an independent software (see under the section “Install snaphu” at the beginning of this 
document), the unwrapping is executed outside SNAP, but the plugin allows to call this execution, so no 
command line processing is required any longer.  
 
Depending on the capabilities of the system, the unwrapping can take a considerable amount of time. 
However, snaphu supports multi-threading which means that the computation can be distributed over 
multiple processor cores. This has to be defined during the export.  
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Export 

The Export operator (under Radar > Interferometric > Unwrapping) converts the interferogram (as the 
wrapped phase) into a format which can be read by snaphu. Furthermore, a couple of parameters can be 
selected which affect the unwrapping process and stored in a configuration file which is accessed by 
snaphu.  
 
The source product is the subset created in the previous step. In the SnaphuExport tab, select your working 
directory as the target folder (here: C:\Temp\S1_InSAR). If the selection of the directory does not work, 

simply copy and paste the path of your working directory into the text field. Select DEFO as Statistical-cost 
mode and select 200 pixels for Row Overlap and Column Overlap. Depending on the number of processors 
of your computer, you can also increase the Number of Processors variable.  
 
Note: You can neglect the eventual error message (Error: [NodeId: SnaphuExport Please add a target 

folder]. It will go away once you switch tabs or hit Run, as long as you have entered a valid target folder.  

 
To learn about the meaning and impact of all parameters, please consult the official documentation.  
 
 

 

Figure 20: Snaphu export 

 
Hit Run to start the export. A directory is created in your working directory with the same name as the 
product you selected as an input (here: 20191208_20191220_split_Orb_Stack_esd_ifg_deb_flt_subset). 

Inside this folder, you find:  
 

▪ the coherence: image (*.img) and metadata (*.hdr) 

▪ the wrapped phase: image (*.img) and metadata (*.hdr) 

▪ the unwrapped phase: only the metadata (*.hdr), because the image (*.img) is first to be created 

by snaphu in the next step.  
▪ a configuration file (snaphu.conf) containing the parameters defined in the export operator 

https://web.stanford.edu/group/radar/softwareandlinks/sw/snaphu/snaphu_man1.html
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Unwrapping with snaphu 

Once the product is exported correctly, the unwrapping can be started from within SNAP, by calling the 
Snaphu-unwrapping operator (under Radar > Interferometric > Unwrapping). As an input product, select 
the subset which was created before the export from the drop-down menu. For the output folder in the 
Processing Parameters tab you can activate Display execution output and select the folder which was 
created during the export (here: 20191208_20191220_split_Orb_Stack_esd_ifg_deb_flt_subset). To start the 

unwrapping, click Run. SNAP then sends the command stored in snaphu.conf to the snaphu.exe which 
creates the raster image belonging to the unwrapped phase metadata.  
 

 

Figure 21: Unwrapping with the snaphu plugin 

 
Note: If the tool is not executed by clicking Run, go to Manage External Tools in the Tools menu. Select 

“Snaphu-unwrapping” and click Edit the selected operator   to open the configuration and enter the 
export directory in the variable USERPROFILE under the System Variables tab. Confirm with OK and start 
the Snaphu-unwrapping operator again.  
 

 

Figure 22: System variables of the snaphu plugin  
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Note that unwrapping can take a considerable amount of time. To break the raster into smaller chunks, 
snaphu divides it by standard into 10 rows and 10 columns, leading to a total of 100 tiles to be unwrapped. 
These tiles are merged afterwards based on the selected pixel overlap (here 200 pixels). A progress bar 
will inform you about the remaining time (Figure 23). The calculation is completed when the progress 
reaches 100% and the output states “Finished tool execution in … seconds”. You can then close the 
operator.  
 

 

Figure 23: Progress of the unwrapping 

 
 
Alternative option: If the unwrapping does not work with the plugin from within SNAP, snaphu can also be 
started from the command line. It can be downloaded from the following page which also contains 
instruction for its manual execution: https://step.esa.int/main/third-party-plugins-2/snaphu/  
 

Import 

The opened unwrapped phase does not have any metadata or geocoding. The Snaphu import (under Radar 
> Interferometric > Unwrapping) converts the it back into the BEAM DIMAP format and adds the required 
metadata from on the wrapped phase product as they have the same geometry. The Snaphu import needs 
the following tabs:  
 

▪ 1-Read-Phase: Here, you select the subset of the interferogram (before the export) from the drop-
down menu. 

▪ 2-Read-Unwrapped-Phase: Select the  icon to open a file menu and navigate to the export 
directory. Select the *.hdr file of the unwrapped phase (here UnwPhase_ifg_[…].hdr). Note: 

The error message will then vanish if you proceed to the next tab.  
▪ 3-SnaphuImport: Leave the option “Do NOT save Wrapped interferogram in the target product” 

unchecked, because it is required in the later step.  
4-Write: To store the imported unwrapped band in a separate product (recommended), add ‘_unw’ 
to the output name (here: 20191208_20191220_split_Orb_Stack_esd_ifg_deb_flt_subset_unw) and 

click Run. 
 
A new product is added to the Product Explorer which contains the wrapped interferogram 
(Phase_ifg_IW…), the coherence (coh_IW_...) and the unwrapped phase generated with snaphu (here: 

Unw_Phase_ifg_08Dec2019_20Dec2019)  

 
Double click on the unwrapped phase to see if the unwrapping was successful. It should be a smooth raster 
with little variation except for the areas of expected deformation (Figure 24). All fringe patterns are 
summarized to absolute changes (Figure 19). Unwrapping errors can occur in areas of low coherence and 
in urban areas with many vertical objects.  
 
If you notice strange grid-like patterns in your unwrapped results, you can change the amount of tile columns 
and rows in the export (or directly in the snaphu.conf file) and run the unwrapping again. Just make sure 

https://step.esa.int/main/third-party-plugins-2/snaphu/
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you delete the unwrapped phase (UnwPhase_ifg_[…].img) and the temporary files in the export 

directory before you restart the unwrapping. Sometimes it is also favorable to switch the statistical cost-
mode from DEFO to SMOOTH or the initial method from MCF to MST and compare the outputs.  
 

 

Figure 24: Phase before (top) and after (bottom) unwrapping 

 

Phase to Displacement 
The unwrapped phase is now a continuous raster but not yet a metric measure. To convert the radian units 
into absolute displacements, the Phase to Displacement operator (under Radar > Interferometric > 
Products) is applied. It translates the phase into surface changes along the line-of-sight (LOS) in meters. 
The LOS is the line between the sensor and a pixel. Accordingly, positive values mean uplift and negative 
values mean subsidence of the surface (if the reference image has the earlier acquisition date).  
 
The Phase to Displacement operator has no parameters and is applied to the unwrapped phase which was 
imported in the last step. It produces an output which looks similar to the unwrapped phase (slightly different 
predefined color ramp), but now each pixel has a metric value indicating its displacement 
 

 

Figure 25: Histogram of unwrapped phase (left) and LOS displacement (right)  
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You can digitize a line and use the Profile Plot tool   to visualize single displacement patterns and their 
ranges (Figure 26). This is also a good way to check also the amount of noise in the lower coherence areas. 
In this case, local craters with diameters of up to 100 meters become visible in the unwrapped phase which 
indicate subsidence of up to 8 cm (-0.08 m), but this has to be validated by field measurements or external 
data. A suggestion on how to make the values more stable by multi-temporal averaging is given at the end 
of the document.  
 
 

 

Figure 26: Profile plot for the displacement band across two subsidence craters 

 
 
Note: The original phase and coherence bands are not automatically copied into the resulting raster of the 
Phase to Displacement operator. If they are needed in the final product, they can be added via the Band 
Maths operator (right-click on the displacement product and select Band Maths).  
 
Call the new raster which is to be generated coherence and uncheck the “Virtual” option (Figure 27, left). 

Open the Band Maths Expression Editor by clicking Edit Expression. You can now switch between 
products which have the same dimensions (rows and columns) in the Band Maths Expression Editor and 
double-clicking the coherence band of a previous product to add it to the expression window. Confirm with 
OK (twice) to apply the calculation.  
 
The coherence band is now part of the displacement product. Save it by selecting File > Save Product in 
the menu.  
 
 

 

Figure 27: Transfer of bands between products 
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Terrain Correction 
Terrain Correction will geocode the image by correcting SAR geometric distortions using a digital elevation 
model (DEM) and producing a map projected product. 
 
Geocoding converts an image from slant range or ground range geometry into a map coordinate system. 
Terrain geocoding involves using a Digital Elevation Model (DEM) to correct for inherent geometric 
distortions, such as foreshortening, layover and shadow (Figure 28). More information on these effects is 
given in the ESA radar course materials.  
 
 

 

Figure 28: Geometric distortions in radar images (Braun 2019) 

 
Open the Range Doppler Terrain Correction operator 
(under Radar > Geometric > Terrain Correction). Select 
the displacement product as an input in the first tab.  
 
In the Processing Parameters tab, select SRTM 1Sec 
HGT (AutoDownload) as input DEM.  
 
If you want to export the data as a KMZ file to view it in 
Google Earth WGS84 must be selected as Map 
Projection. It is based on geographic coordinates 
(latitude and longitude). For the later use in a geographic 
information system (GIS) a metric map projection, such 
as UTM (Automatic) could be selected as well.  
 
If no Source Band is selected, all bands of the input 
product are geometrically corrected.  
 
Click on Run to start the terrain correction. SNAP now 
establishes a connection to an external elevation 
database to download all SRTM tiles required to fully 
cover the input dataset.  
 
Double click on the output to view the geocoded 
displacement raster (Figure 30).  

 

Figure 29: Range Doppler Terrain Correction 

https://earth.esa.int/web/guest/missions/esa-operational-eo-missions/ers/instruments/sar/applications/radar-courses/content-3/-/asset_publisher/mQ9R7ZVkKg5P/content/radar-course-3-slant-range-ground-range
hdl.handle.net/10900/91317
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Figure 30: Terrain corrected and geocoded displacement raster 

 
 

Mask out low coherence pixels  

Sometimes it is good to mask out image parts with 
low coherence to prevent misinterpretation of 
patterns which resulted from phase decorrelation. 
This is why the coherence was transferred into the 
displacement product in the previous step. To 
mask them out, right-click on the geocoded 
displacement band and select Properties.  
 
In the Valid-Pixel Expression, enter the term 
coherence_VV > 0.6 (Figure 31).  

 
All pixels with a coherence value below 0.6 are 
now made transparent in SNAP. 
 

Export to Google Earth 

All geocoded products (projected to WGS84) can 
be exported as a KMZ file to view them in Google 
Earth.  
 
Select a suitable color scale and color ramp in the 
Color Manipulation tab and then chose File > 
Export > Other > View As Google Earth KMZ. 

 

Figure 31: Masking out areas of  
low coherence 

 
Select an output directory and a suitable filename and confirm with Safe.  Open the kmz file in Google 
Earth to view the location of the displacement patterns on the satellite image base map (Figure 32).  
 
 

https://www.google.com/earth/download/gep/agree.html
https://www.google.com/earth/download/gep/agree.html
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Figure 32: Result exported to Google Earth 

 

Suggestions for further analyses 
This tutorial showed how to derive surface displacement from a single image pair of SLC radar data. 
However, it remains unclear how well the result represents the real conditions. This can only be achieved 
by external reference data.  
 
However, to minimize the impact of atmospheric phase disturbances and unwrapping errors, a series of 
images can be analyzed to get a more reliable result. For this, the following products were downloaded, all 
belonging to the same relative orbit (175) at a temporal interval of 12 days: 
 

1. S1B_IW_SLC__1SDV_20191009T163423_20191009T163449_018401_022AA1_F8D3 
2. S1B_IW_SLC__1SDV_20191021T163423_20191021T163450_018576_022FFE_581D 
3. S1B_IW_SLC__1SDV_20191102T163423_20191102T163449_018751_02357D_5396 
4. S1B_IW_SLC__1SDV_20191114T163423_20191114T163450_018926_023B27_3BDF 
5. S1B_IW_SLC__1SDV_20191126T163422_20191126T163449_019101_0240C7_98AB 
6. S1B_IW_SLC__1SDV_20191208T163422_20191208T163449_019276_024651_E2F6 
7. S1B_IW_SLC__1SDV_20191220T163421_20191220T163448_019451_024BE6_79C7 
8. S1B_IW_SLC__1SDV_20200101T163421_20200101T163448_019626_02517E_73AC 

 
All steps in this tutorial were repeated for each consecutive image pair, for instance 1+2, 2+3, 3+4, and so 
on, resulting in a total of 7 geocoded displacement products between 09.10.2019 and 01.01.2020 (Figure 
33). 
 
The single products were stacked in chronological order (Radar > Coregistration > Stack Tools > Create 
Stack, using Geolocation as initial offset method). 
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One average displacement was then calculated in the Band Maths by adding raster of all dates and dividing 
the result by 7: 
 
(displacement_VV_mst +  

displacement_VV_slv1_21Oct2019 +  

displacement_VV_slv3_02Nov2019 +  

displacement_VV_slv5_14Nov2019 +  

displacement_VV_slv7_26Nov2019 +  

displacement_VV_slv9_08Dec2019 +  

displacement_VV_slv11_20Dec2019) / 7 

 

The same was calculated for the coherence. A new valid pixel expression can be entered in the properties 
of the averaged displacement band (for instance coherence_avg > 0.4). By averaging displacements 

of several dates, the impact of atmospheric disturbances and unwrapping errors is reduced, and actual 
displacement patterns become more evident (Figure 33). However, this assumes that deformation trend is 
linear between the first and the last image pair.  
 

The Profile Plot tool  can then be used to plot the average LOS displacement rates between October 
and December 2019. As shown in the image, the rate is about 4 to 5 cm per 12 days.  
 
 

 

Figure 33: Multi-temporal averaging of displacement 
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For more tutorials visit the Sentinel Toolboxes website 
 

http://step.esa.int/main/doc/tutorials/ 
 
 

 
 

Send comments to the SNAP Forum 
 

http://forum.step.esa.int/ 
 

http://step.esa.int/main/doc/tutorials/
http://forum.step.esa.int/

