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Interferometry Tutorial 
The goal of this tutorial is to provide novice and experienced remote sensing users with step-by-step 
instructions on interferometric processing of Radarsat-2 products to generate a digital elevation model 
(DEM).  
 

Background 

What is Interferometry? 

Interferometric synthetic aperture radar (InSAR) exploits the phase difference between two complex radar 
SAR observations taken from slightly different sensor positions and extracts information about the earth’s 
surface. 
 
A SAR signal contains amplitude and phase information. The amplitude is the strength of the radar 
response and the phase is the fraction of one complete sine wave cycle (a single SAR wavelength). The 
phase of the SAR image is determined primarily by the distance between the satellite antenna and the 
ground targets. 
 
By combining the phase of these two images after coregistration, an interferogram can be generated whose 
phase is highly correlated to the terrain topography. The remaining variation in the interferogram can be 
attributed to surface changes which occurred between the two image acquisition dates, as well as unwanted 
atmospheric effects. In this tutorial, surface heights and landforms are derived from an image pair of two 
Radarsat-2 products. 
 
For an introduction to interferometric concepts, please see ESA’s InSAR Principles: Guidelines for SAR 
Interferometry Processing and Interpretation (ESA TM-19). 
 
 

Preparation 

Download the Data 

The data used in this tutorial is provided by MDA and can be downloaded from this page: 
https://mdacorporation.com/geospatial/international/satellites/RADARSAT-2/sample-data  
 
You find download links of two Radarsat-2 UltraFine products (located in Phoenix, USA; Figure 1) at the 
bottom of the page under “Interferometric Ultra-Fine Pair”: 
 

▪ Phoenix_RS2_UltraFine12_20080528_HH_SLC ZIP 279.66 MB 

▪ Phoenix_RS2_UltraFine12_20080504_HH_SLC ZIP 278.73 MB 

 
As some of the required steps are computationally intensive, it is good to store the data at a location which 
offers good reading and writing speed. If your computer has an internal SSD, processing should be done 
there to ensure best performance. Network drives or external storage devices are not recommended. Also, 
paths which include special characters should be avoided. In this tutorial, the data is stored under 
C:\Temp\R2_InSAR\. 

 
Please extract the data and have a look at the License Agreement (PDF) inside the extracted folder.  
 
The data has a spatial resolution of 1.8 x 2.6 meter and covers an area of 22 x 23.5 kilometers. More 
information on product characteristics of Radarsat-2 is given here. 

http://www.esa.int/esaMI/ESA_Publications/SEM867MJC0F_0.html
http://www.esa.int/esaMI/ESA_Publications/SEM867MJC0F_0.html
https://mdacorporation.com/geospatial/international/satellites/RADARSAT-2/sample-data
https://en.wikipedia.org/wiki/Solid-state_drive
https://www.pcigeomatics.com/geomatica-help/references/gdb_r/RADARSAT-2.html
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Figure 1: Location and extent of the Radarsat-2 data used in this tutorial 

 

Notes on Data Ordering 

Radarsat-2 data is commercial and can be ordered via the 
Earth Observation Data Management System  of the CSA. 
Also, MDA is an official distributor.  
 
When ordering interferometric pairs of Radarsat-2, make 
sure to select Single Look Complex (SLC) data products of 
the same track with minimal temporal difference between 
their acquisition times and with the definitive orbit data. 

 

Figure 2: Check "Definitive Orbit Data" 

 
The definitive orbit data is required to obtain accurate enough results for interferometry. Definitive orbits 
are made available 3 - 5 days after the image acquisition. 
 

Install snaphu 

This tutorial can entirely be done within SNAP. Yet, as an external software package, snaphu (statistical-
cost network-flow algorithm for phase unwrapping) has to be installed separately. For more information on 
this tool, please visit https://web.stanford.edu/group/radar/softwareandlinks/sw/snaphu/. 
 
To install the plugin in SNAP, go to Plugins (under the Tools menu, Figure 3) and search for “SNAPHU 
Unwrapping” und the Available Plugins tab. Select it and click Install. 
 

https://www.asc-csa.gc.ca/eng/satellites/radarsat2/order-contact.asp
https://gsiportal.mdacorporation.com/gc_cp/#/map
https://web.stanford.edu/group/radar/softwareandlinks/sw/snaphu/
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Figure 3: The Plugins interface 

 
You will be asked to proceed with “Next” and restart SNAP. This creates a menu entry for snaphu 
unwrapping in the Interferometry menu. 
 
After you have restarted SNAP, you need to install the snaphu bundles as well. Go to Manage External 

Tools in the Tools menu. Select “Snaphu-unwrapping” and click Edit the selected operator   to open 
the configuration (Figure 4). Select a suitable Target Folder (here C:\GIS) where snaphu will be installed 

and proceed with Download and Install Now. You will then get a confirmation “Bundle was installed in 
location C:\GIS\snaphu-v1.4.2_win64” (this may differ according to version, path and operating system).  
 

 

Figure 4: Installation of the snaphu bundles  



Radarsat-2 Interferometry Tutorial

  

5 

Open the Products 
Use File > Import > SAR sensors > RADARSAT-2 
to open the dialogue for file selection. Navigate to 
the extracted folders and select the product.xml 

file and confirm with Import Product.  
 
In the Products View you will see the opened 
products. Each Radarsat-2 product consists of 
Metadata, Vector Data, Tie-Point Grids, Quicklooks 
and Bands (which contains the actual raster data, 
represented by i_HH, q_HH as the real and 

imaginary parts of the complex radar product and 
the resulting intensity as demonstrated in Figure 5).  
 
Double-click on the Intensity_HH band to view 

the raster data (Figure 6). Depending on the 
capabilities of your computer, this might take a 
while.  
 
To identify the location of the area of interest within 
the entire product, you can use the World View or 
World Map (to see its full extent on a base map) or 
open the Quicklook for a preview of the dataset. 
 
The World View or World Map menus are also a 
good way to check if your image belong to the same 
relative orbit (required for interferometry).  
 
Note: If you miss any items in your user interface 
you can activate them in the menu under View and 
Tool Windows.   

Figure 5:  Product Explorer and World Map 

 
 

 

Figure 6: Preview of the R2 SM product  



Radarsat-2 Interferometry Tutorial

  

6 

Coregistration 
To exploit the phase difference of the acquisitions, a stack containing both products must be created first. 
Coregistration makes use of image statistics to align both products at sub-pixel accuracy. Conventional 
Stripmap radar products can be coregistered the Coregistration operator (under Radar > Coregistration).  
 
Load the two R2 products to the ProductSet-Reader tab (Figure 7, left) and increase the Number of GCPs 
to 4000 in the Cross-Correlation tab (Figure 7, right). Furthermore, select Show Residuals in the Warp tab 
and click Run to start the coregistration. Depending on the size of the products and the number of GCPs, 
this can take a while. In this tutorial, the output product is called R2_Stack.dim. 

 

  

Figure 7: Coregistration of Radarsat-2 products 

 
After the coregistration is completed, it is advisable to visually check the quality of the stack. This can be 
done by an RGB representation of the reference and secondary1 product which shows if the images are 
correctly aligned. Select the reference for red and green and the secondary image for blue (Figure 8) 2.  
 
 

  

Figure 8: Generation of an RGB image 

 

 
1 We support the statement of the executive committees of WInSAR and COMET to exchange the inappropriate terminology in all 

InSAR-related fields. Accordingly, the former "master/slave" will be replaced by "reference/secondary" in future versions of SNAP. 
2 https://www.scientificamerican.com/article/end-of-the-rainbow-new-map-scale-is-more-readable-by-people-who-are-color-blind/  

https://comet.nerc.ac.uk/about-comet/insar-terminology/
https://www.scientificamerican.com/article/end-of-the-rainbow-new-map-scale-is-more-readable-by-people-who-are-color-blind/
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Zoom in to an area with distinct surfaces, for example the border between agricultural fields. The RGB 
image should be clear and sharp and not be dominated by one of the images (yellow [red+green] for the 
reference or blue for the secondary image). The only exception are changes in landcover or scattering 
mechanisms which occurred in the time between the first and the second image acquisition (Figure 9).  
 

 

Figure 9: RGB of a successful (top) vs. failed (bottom, empty secondary image) coregistration 

 

To check the perpendicular baseline, select the coregistered stack, open the InSAR Stack   tool and 
switch to the Baselines tab (Figure 10). As shown, the perpendicular baseline is 439.80 meters.  
 

 

Figure 10: InSAR Stack tool 

 

Interferogram Formation and Coherence Estimation 
An interferogram is formed by cross multiplying the reference image with the complex conjugate of the 
secondary image. The amplitude of both images is multiplied while the phase represents the phase 
difference between the two images. 
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The interferometric phase of each SAR image pixel would depend only on the difference in the travel paths 
from each of the two SARs to the considered resolution cell. Accordingly, the computed interferogram 
contains phase variation ϕ from several contributing factors, most importantly the flat-earth phase ϕflat (earth 
curvature), the topographic phase ϕDEM (topographic surface of the earth), atmospheric conditions ϕatm 
(humidity, temperature and pressure change between the two acquisitions), and other noise ϕnoise (change 
of the scatterers, different look angle, and volume scattering ), and lastly the eventual surface deformation 
occurred between the two acquisitions ϕdisp (Equation 1).  
 
A more detailed explanation is given by Roca et al. (1997), and in the documents compiled by ESA: InSAR 
Principles: Guidelines for SAR Interferometry Processing and Interpretation (ESA TM-19). 
 
 

 ϕ = ϕDEM + ϕflat + ϕdisp + ϕatm + ϕnoise  (1) 

 
 

 

Figure 11: Contributors to SAR interferometric phase 

 
 
Traditional SAR interferometry tries to estimate the contribution from the earth’s surface (ϕflat and ϕDEM) 
which is considered equal for both image acquisitions and derive the heights of the topography (Equation 
2; ESA TM-19A, chapter 2.2; ESA TM-19B, chapter 3).  
 

 

 ϕDEM = ϕ - ϕflat - ϕdisp + ϕatm + ϕnoise  (2) 

 
 

This works best if atmospheric contributions and other noise is kept as small as possible because they are 
hard to estimate and if there is no elevation change ϕdisp between the two image acquisitions. It is therefore 
advisable to use images from the dry season and with a suitable perpendicular baseline. More hints on the 
selection of suitable image pairs for InSAR DEM generation are given in ESA TM-19B, chapter 1.3). This 
source names an optimum perpendicular baseline of 150 - 300 m.  
 
Besides the interferometric phase, the coherence between the reference and the secondary image is 
estimated as an indicator for the quality of the phase information. Basically, it shows if the images have 
strong similarities and are therefore usable for interferometric processing. Loss of coherence can produce 
poor interferometric results and is caused by temporal (over vegetation and water bodies), geometric (errors 
or inaccuracies in the orbit metadata) and volumetric decorrelation (potential scattering mechanisms of 
voluminous structures, such as complex vegetation or dry surfaces).  
 
Coherence is calculated as a separate raster band and shows how similar each pixel is between the 
secondary and reference images in a scale from 0 to 1. Areas of high coherence will appear bright. Areas 
with poor coherence will be dark. In the image, vegetation is shown as having poor coherence and buildings 
have very high coherence. 
 
  

https://earth.esa.int/workshops/ers97/program-details/speeches/rocca-et-al/
http://www.esa.int/esaMI/ESA_Publications/SEM867MJC0F_0.html
http://www.esa.int/esaMI/ESA_Publications/SEM867MJC0F_0.html
http://www.esa.int/esapub/tm/tm19/TM-19_ptA.pdf
http://www.esa.int/esapub/tm/tm19/TM-19_ptB.pdf
http://www.esa.int/esapub/tm/tm19/TM-19_ptB.pdf
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To compute the interferogram and the coherence bands, apply the Interferogram Formation operator (under 
Radar > Interferometric > Products). Select the coregistered stack you generated in the previous step as 
an input and make sure to check the boxes: 
 

▪ Subtract flat-earth phase: The flat-earth phase is the phase present in the interferometric signal 
due to the curvature of the reference surface. The flat-earth phase is estimated using the orbital 
metadata information and subtracted from the complex interferogram. 

▪ Include coherence estimation: This produces a coherence band in the output calculated based 
on a window of 10 x 3 pixels in range/azimuth direction based on equation 1.13 in ESA TM-19C. 

 
Please do not check “Subtract topographic phase”, because this is the information if interest.    
 
 

 

Figure 12: Interferogram Formation 

 

The resulting product will contain the interferogram (Phase_ifg_IW…) and the coherence (coh_IW_...) 

as separate bands (Figure 13). Double click them to check for their quality.  
 
The interferogram is displayed in a rainbow color scale ranging from -π to +π and contains variations from 
topography, atmosphere and potential surface deformation (considered zero). The patterns, also called 
fringes” represent a full 2π cycle and appear in an interferogram as cycles of arbitrary colors, with each 
cycle representing half the sensor’s wavelength (Figure 13).  
 
The coherence shows the areas where the phase information is coherent, which means that it can be used 
to measure topography (as in this tutorial) or deformation (includes removing the topographic phase). While 
large areas show coherence values above 0.5, agricultural areas are dark and have low coherence (below 
0.3). Accordingly, phase information over agricultural areas is not usable here. If low coherence areas are 
too dominant in the image, the later unwrapping will fail and produce faulty or random results.  
 

https://www.esa.int/esapub/tm/tm19/TM-19_ptC.pdf
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Figure 13: Interferogram (top) and coherence (bottom) 

 

Multilooking 
Multilooking allows to decrease the spatial 
resolution of SAR data without losing the 
complex information contained in the 
interferogram. It is not a mandatory step but 
helps to reduce the size of the processed 
data while increasing the quality of the data 
because noise is reduced. The number of 
looks has to be decided according to the level 
of noise, the extent of the dataset and the 
scale of the patterns of interest.   
 
Select the interferogram product and open 
the Multilooking operator (under Radar > 
Utilities). The only thing to adjust is the 
Number of Range Looks to 2. The Number of 
Azimuth Looks will automatically be updated 
accordingly (as long as GR Square Pixel is 
checked, both numbers are equally 
increased). The resulting ground range 
resolution will be 4.17 meters in the bottom 
field (Figure 14).  
 

 

Figure 14: Multilooking of the interferogram 
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Goldstein Phase Filtering 
Interferometric phase can be corrupted by noise from temporal and geometric decorrelation, volume 
scattering, and other processing errors. Phase information in decorrelated areas cannot be restored, but 
the quality of the fringes existing in the interferogram can be increased by applying specialized phase filters, 
such as the Goldstein filter which uses a Fast Fourier Transformation (FFT) to enhance the signal-to-noise 
ratio of the image.  
 
A filtered phase image is required for a proper unwrapping in the subsequent step. A detailed description 
of this filter and its parameters is given in the publication of Goldstein & Werner (1998).  
 
Apply the Goldstein Phase Filtering (under Radar > Interferometric > Filtering) to the multilooked image. If 
many artificial objects are in the image, you can reduce the Adaptive Filter Exponent. The output is a filtered 
phase image (Figure 15), the coherence is not affected.  
 

 

Figure 15: Interferogram before (left) and after (right) Multilooking and Goldstein phase filtering 

 

Phase Unwrapping 
In the interferogram, the interferometric phase is ambiguous and only known within the scale of 2π. To be 
able to relate the interferometric phase to the topographic height, the phase must first be unwrapped. The 
altitude of ambiguity is defined as the altitude difference that generates an interferometric phase change of 
2π after interferogram flattening. 
 
Phase unwrapping solves this ambiguity by integrating phase difference between neighboring pixels. After 
deleting any integer number of altitudes of ambiguity (equivalent to an integer number of 2π phase cycles), 
the phase variation between two points on the flattened interferogram provides a measurement of the actual 
altitude variation (Figure 16). Accordingly, unwrapped results should be interpreted as a relative 
height/displacement between pixels of two images.  

https://agupubs.onlinelibrary.wiley.com/doi/abs/10.1029/1998GL900033
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Figure 16: Principle of phase unwrapping 

 
 
The quality and reliability of unwrapped results very much depends on the input coherence. Reliable results 
can only be expected in areas of high coherence. Although no definite threshold exists, a minimum 
coherence of 0.3 is suggested.  
 
Unwrapping in SNAP follows three distinct steps:  
 

1. Export of the wrapped phase (and definition of the parameters)  
2. Unwrapping of the phase (performed outside SNAP by snaphu) 
3. Import of the unwrapped phase back into SNAP 

 
Because snaphu is an independent software (see under “Preparation” > “Install snaphu”), the unwrapping 
is executed outside SNAP, but the plugin allows to call this execution, so no command line processing is 
required any longer.  
 
Depending on the capabilities of the system, the unwrapping can take a considerable amount of time. 
However, snaphu supports multi-threading which means that the computation can be distributed over 
multiple processor cores. This has to be defined during the export.  
 

Export 

The Export operator (under Radar > Interferometric > Unwrapping) converts the interferogram (as the 
wrapped phase) into a format which can be read by snaphu. Furthermore, a couple of parameters can be 
selected which affect the unwrapping process and stored in a configuration file which is accessed by 
snaphu.  
 
The source product is the filtered product created in the previous step. In the SnaphuExport tab, select your 
working directory as the target folder (here: C:\Temp\R2_InSAR). If the selection of the directory does not 

work, simply copy and paste the path of your working directory into the text field. Select TOPO as Statistical-
cost mode and select 200 pixels for Row Overlap and Column Overlap (Figure 17). Depending on the 
number of processors of your computer, you can also increase the Number of Processors variable.  
 
Note: You can neglect the eventual error message (Error: [NodeId: SnaphuExport Please add a target 

folder]. It will go away once you switch tabs or hit Run, as long as you have entered a valid target folder.  

 
To learn about the meaning and impact of all parameters, please consult the official documentation.  
 
 

https://web.stanford.edu/group/radar/softwareandlinks/sw/snaphu/snaphu_man1.html
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Figure 17: Snaphu export 

 
 
Hit Run to start the export. A directory is created in your working directory with the same name as the 
product you selected as an input (here: 20181227_20190108_Orb_Stack_ifg_ML_flt). Inside this folder, you 

find:  
 

▪ the coherence: image (*.img) and metadata (*.hdr) 

▪ the wrapped phase: image (*.img) and metadata (*.hdr) 

▪ the unwrapped phase: only the metadata (*.hdr), because the image (*.img) is first to be created 

by snaphu in the next step.  
▪ a configuration file (snaphu.conf) containing the parameters defined in the export operator 

 

Unwrapping with snaphu 

Once the product is exported correctly, the unwrapping can be started from within SNAP, by calling the 
Snaphu-unwrapping operator (under Radar > Interferometric > Unwrapping). As an input product, select 
the filtered product which was created before the export from the drop-down menu.  
 
For the output folder in the Processing Parameters tab you can activate Display execution output and 
select the folder which was created during the export (here: R2_Stack_ifg_ML_flt). To start the 

unwrapping, click Run. SNAP then sends the command stored in snaphu.conf to the snaphu.exe which 
creates the raster image belonging to the unwrapped phase metadata.  
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Note: If the tool is not executed by clicking 
Run, go to Manage External Tools in the 
Tools menu. Select “Snaphu-unwrapping” 

and click Edit the selected operator   
to open the configuration and enter the 
export directory in the variable 
USERPROFILE under the System 
Variables tab. Confirm with OK and start 
the Snaphu-unwrapping operator again.  
 
Note that unwrapping can take a 
considerable amount of time. To break the 
raster into smaller chunks, snaphu divides 
it by standard into 10 rows and 10 
columns, leading to a total of 100 tiles to 
be unwrapped. These tiles are merged 
afterwards based on the selected pixel 
overlap (here 200 pixels).  
 
A progress bar will inform you about the 
remaining time ( 
Figure 18). The calculation is completed 
when the progress reaches 100% and the 
output states “Finished tool execution in … 
seconds”. You can then close the 
operator.  
 

 

Figure 18: Unwrapping with the snaphu plugin 

 
  

 

Figure 19: System variables of the snaphu plugin 

 
Alternative option: If the unwrapping does not work with the plugin from within SNAP, snaphu can also be 
started from the command line. It can be downloaded from the following page which also contains 
instruction for its manual execution: https://step.esa.int/main/third-party-plugins-2/snaphu/  
 

https://step.esa.int/main/third-party-plugins-2/snaphu/
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Import 

The opened unwrapped phase does not have any metadata or geocoding. The Snaphu import (under Radar 
> Interferometric > Unwrapping) converts the it back into the BEAM DIMAP format and adds the required 
metadata from on the wrapped phase product as they have the same geometry. The Snaphu import needs 
the following tabs:  
 

▪ 1-Read-Phase: Here, you select the filtered interferogram (before the export) from the drop-down 
menu. 

▪ 2-Read-Unwrapped-Phase: Select the  icon to open a file menu and navigate to the export 
directory. Select the *.hdr file of the unwrapped phase (here UnwPhase_ifg_[…].hdr). Note: 

The error message will then vanish if you proceed to the next tab.  
▪ 3-SnaphuImport: Leave the option “Do NOT save Wrapped interferogram in the target product” 

unchecked, because it is required in the later step.  
4-Write: To store the imported unwrapped band in a separate product (recommended), add ‘_unw’ 
to the output name (here: R2_Stack_ifg_ML_flt) and click Run. 

 
A new product is added to the Product Explorer which contains the wrapped interferogram 
(Phase_ifg_IW…), the coherence (coh_IW_...) and the unwrapped phase generated with snaphu (here: 

R2_Stack_ifg_ML_flt).  

 
Double click on the unwrapped phase to see if the unwrapping was successful. It should be a smooth raster 
with little variation except for the areas of expected deformation (Figure 20). All fringe patterns are 
summarized to absolute changes (Figure 16). Unwrapping errors can occur in areas of low coherence and 
in urban areas with many vertical objects.  
 
If you notice strange grid-like patterns in your unwrapped results, you can change the amount of tile columns 
and rows in the export (or directly in the snaphu.conf file) and run the unwrapping again. Just make sure 

you delete the unwrapped phase (UnwPhase_ifg […].img) and the temporary files in the export directory 

before you restart the unwrapping. Sometimes it is also favorable to switch the statistical cost-mode from 
DEFO to SMOOTH or the initial method from MCF to MST and compare the outputs.  
 

 

Figure 20: Phase before (top) and after (bottom) unwrapping  
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Phase to Elevation 
The unwrapped phase is now a continuous 
raster but not yet a metric measure. To convert 
the radian units into absolute heights, the Phase 
to Elevation operator (under Radar > 
Interferometric > Products) is applied. It 
translates the phase into surface heights along 
the line-of-sight (LOS) in meters. The LOS is the 
line between the sensor and a pixel. A DEM is 
used to put the elevation values in the correct 
level.   
 
In the Processing Parameters tab, select SRTM 
1Sec HGT (AutoDownload) as input DEM.  
 
The operator is applied to the unwrapped phase 
which was imported in the last step. It produces 
an output which looks similar to the unwrapped 
phase (slightly different predefined color ramp), 
but now each pixel has a metric value indicating 
its height above sea level.  
 

You can plot a Histogram  to check the 
frequency distribution of the values (Figure 22).  

 

Figure 21: Phase to Elevation 

 
 

 

Figure 22: Histogram of the elevation raster 
 
 
Note: The original phase and coherence bands are not automatically copied into the resulting raster of the 
Phase to Elevation operator. If they are needed in the final product, they can be added via the Band Maths 
operator (right-click on the elevation product and select Band Maths).  
 
Call the new raster which is to be generated coherence and uncheck the “Virtual” option (Figure 23, left). 

Open the Band Maths Expression Editor by clicking Edit Expression. You can now switch between 
products which have the same dimensions (rows and columns) in the Band Maths Expression Editor and 
double-clicking the coherence band of a previous product to add it to the expression window (Figure 23, 
right). Confirm with OK (twice) to apply the calculation.  
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The coherence band is now part of the elevation product. Save it by selecting File > Save Product in the 
menu.  
 
 

 

Figure 23: Transfer of bands between products 

 

Terrain Correction 
Terrain Correction will geocode the image by correcting SAR geometric distortions using a digital elevation 
model (DEM) and producing a map projected product. 
 
Geocoding converts an image from slant range or ground range geometry into a map coordinate system. 
Terrain geocoding involves using a Digital Elevation Model (DEM) to correct for inherent geometric 
distortions, such as foreshortening, layover and shadow (Figure 24). More information on these effects is 
given in the ESA radar course materials.  
 
 

 

Figure 24: Geometric distortions in radar images (Braun 2019)  

https://earth.esa.int/web/guest/missions/esa-operational-eo-missions/ers/instruments/sar/applications/radar-courses/content-3/-/asset_publisher/mQ9R7ZVkKg5P/content/radar-course-3-slant-range-ground-range
hdl.handle.net/10900/91317
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Open the Range Doppler Terrain Correction operator (under Radar > Geometric > Terrain Correction). 
Select the elevation product as an input in the first tab.  
 
In the Processing Parameters tab, select SRTM 1Sec HGT (AutoDownload) as input DEM.  
 
Please be aware that SRTM is only available between 60° North and 54° South. If your area lies outside 
this coverage (https://www2.jpl.nasa.gov/srtm/coverage.html), you can use one of the other DEMs with 
AutoDownload option or use an external DEM (just make sure it stored as a GeoTiff and projected in 
geographic coordinates / WGS84).  
 
If you want to export the data as a KMZ file to view it in Google Earth WGS84 must be selected as Map 
Projection. It is based on geographic coordinates (latitude and longitude). For the later use in a geographic 
information system (GIS) a metric map projection, such as UTM (Automatic) could be selected as well.  
 
If no Source Band is selected, all bands of the input product are geometrically corrected.  
 
If you want to compare the quality of the InSAR DEM, you can select DEM as a further output. This writes 
the SRTM data used for Terrain Correction to a separate elevation band. The R2 DEM will then be named 
elevation_HH and the SRTM data is named elevation. This option is, however, just for comparison 

and not mandatory.  
 
Click on Run to start the terrain correction. SNAP now establishes a connection to an external elevation 
database to download all SRTM tiles required to fully cover the input dataset.   
 

 

Figure 25: Range Doppler Terrain Correction  

https://www2.jpl.nasa.gov/srtm/coverage.html
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Figure 26: Geocoded elevation of SRTM (left) and Radarsat-2 DEM (right) 

 

Suggestions for further analyses 

Difference layer 

To assess the quality of your DEM, you can calculate a difference between the generated R2 InSAR DEM 
and the SRTM in the Band Maths with the expression elevation_HH – elevation (Figure 27). 

 

 

Figure 27: Difference between R2 DEM and SRTM 
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Profile Plot 

can digitize a line and use the Profile Plot tool   to visualize selected landforms (Figure 28). This is also 
a good way to check also the amount of noise in the lower coherence areas. 
Once the profile line is displayed you can select different bands from the same product and update the plot, 
for example to check how well SRTM and R2 DEM are aligned.  
 
 

 

Figure 28: Profile plot for the R2 elevation 

 

The data behind the plot (elevations along the profile line) can be exported via the Table View  by right-
clicking > Copy Data To Clipboard. By doing this, elevations of both raster products can be extracted and 
compared, for example in MS Excel.  
 

 

Figure 29: Comparison between SRTM and R2 elevations along the digitized profile  
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Compare Hillshades 

Open the file elevation_HH.img (inside the .data folder) into a GIS (e.g. QGIS) and compute a 

hillshade representation. You might need to set the z-value to 0.000015 (because data projected in WGS84 
is based on degrees and the height is given in meters). The coherence layer will give you an indication on 
where your data is of good quality and where there can be phase errors (mainly within agricultural areas) 
of radar shadow (Figure 24).  
 

 

 
 

Figure 30: Hillshade of SRTM (top) and R2 DEM (middle) elevation; and coherence (bottom)  

https://www.qgis.org/
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Scatter plot 

The Scatter Plot  tool can be used to compare the values of both DEMs pixel-wise. Select 
elevation_HH for the first raster and elevation for the second raster and confirm with Refresh View 

. The plot shows in which value ranges the raster products are alike. The spikes are caused by the 
artefacts at the left edge of the image (Figure 32) and could be removed with by the Subset operator after 
the Phase to Elevation step.  
 

 

Figure 31: Elevation of SRTM (y) vs elevation from R2 (x) 

 

Export to Google Earth 

All geocoded products (projected to WGS84) can be exported as a KMZ file to view them in Google 
Earth. Select a suitable color scale and color ramp in the Color Manipulation tab and then chose File > 
Export > Other > View As Google Earth KMZ. Select an output directory and a suitable filename and 
confirm with Save. Open the kmz file in Google Earth to view the location of the elevation raster on the 
satellite image base map (Figure 32).  
 

 

Figure 32: Result exported to Google Earth 

  

https://www.google.com/earth/download/gep/agree.html
https://www.google.com/earth/download/gep/agree.html
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For more tutorials visit the Sentinel Toolboxes website 
 

http://step.esa.int/main/doc/tutorials/ 
 
 

 
 

Send comments to the SNAP Forum 
 

http://forum.step.esa.int/ 
 

http://step.esa.int/main/doc/tutorials/
http://forum.step.esa.int/

