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Import of data into SNAP 
 
The goal of this document is to demonstrate how data collected, prepared or processed outside SNAP can 
be imported correctly. As there are many supported input data formats, this tutorial is not meant to be 
complete, but rather gives some advice on selected data types. It is possible that this tutorial will be 
extended by further input formats in the future.  
 

General notes on loading data 
 
There are two main ways of loading data into SNAP 
 

1. File > Open (Figure 1 blue): You can use this to load products which were already processed in 
SNAP and stored in BEAM DIMAP format. This format is recommended during the processing of 
data in SNAP because it conserves all metadata of the original product which might be needed by 
the different tools. Furthermore, it stores a processing graph which lists all operations and their 
parameters which have been applied to a dataset as a kind of internal processing history.  
You can also open original or raw datasets with this option when you use the filter option to 
predefine the type of data you want to load (Figure 1 green box). However, this filter does not cover 
all data types which are supported by SNAP, so the second option is recommended for raw data. 
 

2. File > Import (Figure 1 red): Depending on your choice a window will be opened which predefines 
the filet type which is required to load a certain data format (for example .xml, .hdr, .safe, or .zip). 
In many cases it is possible to load the data as a subset, both spatially or by selecting a reduced 
number of bands (Figure 2 and Figure 3) to reduce the amount of data to be processed from the 
very beginning.  
Loading data via File > Import is recommended, because it grants that the correct file is selected 
during the import so that all metadata of the input are interpreted correctly by SNAP.  

 
 

 

Figure 1: Ways to load raster data into SNAP 
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Figure 2: Loading a subset (here: Sentinel-1 GRD product) 

 
 

 

Figure 3: Spatial (left) and band subset (right) 
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Importing vector data 
 
There are many purposes of adding vector data into SNAP: 

• Location of specific features in raster bands (e.g. polygon of a forest area) 

• Import of lines for the Profile Plot  tool 

• Definition of a region of interest (ROI). Among others, polygons can be used to limit the analysis to 
a selection of pixels in the following tools and operators 
 

 Histogram 

 Profile Plot 

 Scatter Plot (example in Figure 10) 

 Correlative Plot 

 Statistics tool 

 Classifications 

 Principal component analysis 

and many others. The principle is shortly explained in the following chapter. Please see the tutorial 
on Synergetic use of S1 (SAR) and S2 (optical) data and use of analysis tools for a detailed 
explanation of many of these tools.  

 

• Import vectors to use them as masks in the Mask Manager  

• As training data for supervised classification or for the accuracy assessment (Examples are given 
in this tutorial Land cover classification with Sentinel-1 GRD) 

 
Important: To load vector data, a raster product must be opened in SNAP where the vector can be 
inserted. They are then displayed under Vector Data and stored as WKT files in the .data folder of the 
BEAM DIMAP product after you save the file (File > Save product).  
 

 

Figure 4: Storage of vectors in SNAP 

 
 
The following methods of importing vector data will be shortly introduced in the following 

• ESRI Shapefiles as ROIs 

• ESRI Shapefiles as training data for supervised classification 

• CSV data  
  

http://step.esa.int/docs/tutorials/S1TBX%20Synergetic%20use%20of%20S1%20(SAR)%20and%20S2%20(optical)%20data%20Tutorial.pdf
http://step.esa.int/docs/tutorials/S1TBX%20Landcover%20classification%20with%20Sentinel-1%20GRD.pdf
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ESRI Shapefiles as region of interest (ROI) 

 
In the following example, a Sentinel-1 radar image (calibrated, speckle filtered, and terrain corrected), and 
a Sentinel-2 image of the island of Tenerife provided within the Copernicus Programme are used. 
Additionally, forest cover retrieved from CLC 2018 is used as a polygon. 
 
Important: Shapefiles imported into SNAP should be 
stored in the same coordinate reference system as 
the raster product. Otherwise, you might get an error 
message stating that the data was imported, but it is not 
spatially covering the raster data (Figure 5). 
 
You can check the coordinate reference system which 
the raster was projected into by using the Geo-Coding 
tool (under Menu > Analysis; Figure 6, here: WGS84 
[EPSG:4326] with latitudes and longitudes).  
 

 

Figure 5: Error message when projections  
of vector and raster data differ 

 

 

Figure 6: Loaded raster data and its projection displayed in the Geo-Coding window 

 
Once you have opened a raster which matches 
with the spatial extent and the projection of the 
vector data, you can select from the Menu > 
Vector > Import > ESRI Shapefile (Figure 7). 
 
Note: This option is greyed out when no raster 
products are loaded in SNAP.  

 
A file dialogue will open which lets you select  
the *.shp file. Confirm with Open.  

 

Figure 7: Loading ESRI Shapefiles 

https://land.copernicus.eu/pan-european/corine-land-cover/clc2018
https://epsg.io/4326
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In case that the vector data consists of several 
polygons, another dialogue will pop up and ask 
you if you want to import them separately or as a 
single dataset (Figure 8). If you select Yes, the 
polygons will be grouped by an attribute and each 
group is added separately. If you select No all 
polygons will belong to the same group.  
 
Note: This dialogue will only be displayed if the vector 
data consists of several parts.  

 

Figure 8: Import of multiple features 

 
After confirmation with No, the data will be displayed on top of the raster (partially transparent) in a random 

color (Figure 9). You can use the Layer Manager  to turn it on or off, and to change its style using the 

Layer Editor . If you want to keep the vector data permanently, select File > Save Product.  
 

 

Figure 9: Polygon shapefile imported into SNAP 

 

Once you have imported a polygon you can use it 
as Region of Interest (ROI) in several tools. As 
shown in Figure 10, the scatter plot was created 
based on the bands Sigma0_VV and Sigma0_VH 
but limited to the pixels covered by the imported 
vector CLC_forest (red rectangle).  

 
This allows to analyze certain parts of the image 
without the need for clipping. 
 
Also, the area of each imported vector can be used 

as a mask in the Mask Manager for more 
advanced expressions.  

 

Figure 10: Scatter plot using a ROI 
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ESRI Shapefiles as training data 

 
To use external vector data for the training of supervised classification purposes in SNAP, an ESRI 
Shapefile is needed which contains a text attribute determining the class of a polygon. In the following 
example, this attribute is a string stored in the column LC_name (Figure 11). The attribute table may contain 

additional columns, SNAP will ask for the one which is used in the import.  
However, it is important that each class (e.g. forest) is only represented by one line in the attribute table, 
even if it consists of several polygons. This can be achieved by a dissolve operation. Otherwise, each 
polygon will be imported as a single class (e.g. forest_1, forest_2) in the next step. 
 

  

Figure 11: Training polygons in QGIS 

Once the vector dataset is prepared, to load vectors into SNAP, a raster product has to be opened and 
selected in the Product Explorer. Then, you can navigate via the Menu > Vector > Import > ESRI Shapefile 
and select the shapefile (in this case it is named CLC_2018_polygons_dissolve.shp).  

 
In this example, the shapefile consists of 15 classes (Figure 11). Upon selection of the file, SNAP opens a 
dialogue which asks if these classes should be imported as a single polygon or split by a text attribute. The 
drop-down menu (Figure 12, red box) allows you to select the correct attribute column (only text attributes 
can be used). We select LC_Name and confirm with Yes.  

 

 

Figure 12: Import of classified polygons 

 
 
The imported polygons will now be loaded into the raster product with each class belonging to a different 
entry in the Vector Data folder and each displayed in a different random color (Figure 13).  

https://gis.stackexchange.com/questions/73519/merging-dissolving-polygons-by-common-attribute-field-in-qgis
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Figure 13: Imported classified polygons 

 
In this format the imported class 
vectors can be used for training 
supervised classifiers as shown in 
Figure 14. They are found under 
Menu > Raster > Classification > 
Supervised Classification.  
 
 
Note: Please be aware that a high 
number of classes also requires a 
large number of feature bands. It is 
not feasible (as shown in this 
example) to predict 15 classes based 
on two input bands (here: Sigma0_VV 
and Sigma0_VH). Especially the 
Random Forest classifier requires 
large numbers of both training vectors 
and feature bands to become 
effective.   
 
To increase the number of raster 
features, you can calculate image 
textures or use images of different 
dates (e.g. images from the dry and 
wet season [tutorial]), or sensors (e.g. 
optical and SAR data [tutorial]).  

 
 

 

Figure 14: Usage of imported shapefiles for supervised 
classification 

 
  

http://step.esa.int/docs/tutorials/S1TBX%20Landcover%20classification%20with%20Sentinel-1%20GRD.pdf
http://step.esa.int/docs/tutorials/S1TBX%20Synergetic%20use%20of%20S1%20(SAR)%20and%20S2%20(optical)%20data%20Tutorial.pdf
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CSV files 

 
CSV stands for comma separated value and is a common format for tabular data. It is a suitable format to 
store a series of points (including their attributes). However, csv data containing spatial information loaded 
into SNAP must fulfill certain conventions on content and formatting: 
 

• Tab separation: The columns should be separated by a tabulator character (not a comma or 
semicolon). You can prepare your data in freely available programs, such as Notepad++ and 
replace all commas by tabulators (search for , and replace by \t).  

• Header line: The first line of the table should contain the names of the attributes. Two columns on 
the coordinates of the point must exist and be named lon and lat, longitude and latitude.  

• Number of columns: The header line and the data below must have the same number of columns. 
Please check the data for invisible tabulators which might indicate the presence of another column.  

• Geometry (optional): Advanced definitions of geometry types as used in databases are possible 
(e.g. 'geometry:Point', 'geometry:LineString', 'geometry:Polygon'). Examples are 

given in the Help section of SNAP under Import and Export > Import Vector Data > CSV.  
 
An example of a simple CSV structure which can be imported into SNAP is given below.  
 
 
 
# optional description  

Point Longitude Latitude Name 

pt_1 9.943068 43.09783 first 

pt_2 10.458842 42.990147 second 

pt_3 10.553919 42.664112 third 

pt_4 10.302726 42.470406 fourth 

pt_5 9.838505 42.601866 fifth 

pt_6 9.656987 42.87649 sixth 

pt_7 9.943068 43.09783 seventh 

… 

 
In this tutorial, data on trees from the administration of Tenerife is used. The first lines are shown below. 
Please note that because of the length of the coordinate attributes, the header descriptions are not 
horizontally aligned with the data columns (type is not above ABC, ABL...). This does not look nice but it is 

necessary so that each column is separated by exactly one tabulator. 
 
lon lat type 

-16.1536680930129 28.5252989881192 ABC 

-16.1558792651145 28.5262766246275 ABC 

-16.1553564297368 28.5255941346835 ABC 

-16.1556519623649 28.5277503535452 ABL 

-16.1556256702465 28.5276822534990 ABL 

-16.1555989656586 28.5275229352706 ABL 

-16.2723564024984 28.4844696842436 ABP 

-16.2723604681660 28.4845284739826 ABP 

… 

 
The data is loaded via the Menu > Vector > Import > Vector from CSV and select the csv file (in this case 
it is named trees_table.csv). Upon confirmation, you will be asked about the reference system of the 

coordinates (Figure 15, left). As these are given in geographic coordinates, WGS84 is the correct choice. 
This step is especially crucial when your raster data was stored in UTM coordinates which are suggested 
as target CRS (but not correct). Confirm with OK. A second dialogue will ask you about the type of 
information where you can merge the points to lines, polygons or tracks (Figure 15, right). If you only want 
to import the data as points, select Leave imported data unchanged and confirm with OK. The data will 
be displayed on top of the raster (Figure 16). Depending on the number of points, this can take a while. The 
imported points can again be used in combination with analysis tools, e.g. the Statistics tool (Figure 17). 

https://notepad-plus-plus.org/downloads/
https://www.santacruzdetenerife.es/opendata/en
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Figure 15: Import of CSV files  

 

 

Figure 16: Points imported from CSV files 

 

 

Figure 17: Statistics for the imported points  
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Spectral Signatures 
 
A spectral signature is a tabular form of the reflectance of a certain material or surface over various 
wavelengths. It is mostly displayed as a line graph connecting the reflectivity values of single bands for a 

single pixel. It can be displayed interactively with the Spectrum View . Spectral signatures of various 
materials or surfaces are often collected in spectral libraries. 
 
Such signatures can be used as training data for the Spectral Unmixing tool which assigns a relative value 
of class abundance to each pixel based on the information of the input signatures [reference]. However, 
the training signatures have to follow a specific formatting: The first column is named wavelength and 
contain the wavelength in nanometers. All other columns are separated by tabulators and contain the name 
and the reflectivity [0 – 1] of several surfaces at the corresponding wavelengths. An example is given in 
Figure 18. Again, the constant separation by tabulator characters might lead to visually misaligned columns, 
but this is not a problem.  
The number and bandwidth of wavelengths depends on the source of the spectral signatures, but it should 
at least contain the bandwidths covered by the satellite (13 bands of Sentinel-2 in this example). This file 
structure can be saved as a .txt or .csv file and then loaded into the Spectral Unmixing tool (found under 

Menu > Optical > Spectral Unmixing) by the  button under Endmembers. Their signature is then shown 
in the plot on the bottom right as shown in Figure 19.  
 
 

 

Figure 18: Spectral signature file 

 

Figure 19: Spectral Unmixing  
with imported signatures 

 
 
Hint: If you don’t find the spectral signatures in open libraries or if you cannot measure them yourself using 

spectrometer devices, you can place pins  on representative pixels with large class probabilities (e.g. 

consisting of 100 % forest, water, or bare soil) using the Pin Manager and then export the reflectance 

of these classes  to a .txt file. This txt file is ready to be used as endmember reference in the Spectral 
Unmixing tool.  
 

https://en.wikipedia.org/wiki/Spectral_signature
https://www.usgs.gov/energy-and-minerals/mineral-resources-program/science/usgs-high-resolution-spectral-library?qt-science_center_objects=0#qt-science_center_objects
https://archive.ll.mit.edu/publications/journal/pdf/vol14_no1/14_1survey.pdf
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Importing digital elevation and landcover data 
 
Digital elevation models are used at many stages of geospatial analysis. They can be loaded into SNAP by 
right-clicking on a loaded product and selecting Add Elevation Band or Add Land Cover Band. This will 
open a list with datasets to chose from (Figure 20). Please note that not all datasets cover the entire world 
(e.g. SRTM does not cover high latitudes; AAFC only covers the state of Canada). As shown in the figure, 
a resampling method has to be selected which determines how the spatial resolution of the integrated data 
is adjusted to the one of the loaded raster (here: 10 m of Sentinel-1). Categorial data (land cover) require 
NEAREST_NEIGHBOR resampling while continuous data (elevation) can be resampled using 
BILINEAR_INTERPOLATION. After confirmation with OK the data is added to the list of bands, but only 
downloaded after the raster is displayed or used by another tool. Since SNAP version 8, the computation 
of slope and aspect (under Menu > Raster > DEM Tools) is also possible.  
 

 

Figure 20: Automated download of DEM (left) and land cover data (right) 

 

 

Figure 21: Radar data, DEM, land cover and slope  
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Importing Web Map Services 
 
A Web Map Service (WMS) is a raster map (often computed from vector data) which can be loaded from a 
server and integrated into a software for spatial data. It is accessed using a service URL which denotes its 
location. Web Map Services are stored at servers by different providers. SNAP allows to integrate WMS as 
long as they are based on a common coordinate reference system and covering the area of a loaded data 
set. Some examples on working WMS: 
 
Open Street Map data by Terrestris:  

• Color: https://ows.terrestris.de/osm/service? 

• Grayscale: https://ows.terrestris.de/osm-gray/service? 
 
A large range of base maps by the German Aerospace Center 
https://geoservice.dlr.de/eoc/basemap/wfs?  

• Base Map 

• EU DEM 

• Litem ap 

• Bathymetry 

• and many others, including most layers by NaturalEarth 
 
Copernicus Marine Service 

• Waves: http://nrt.cmems-du.eu/thredds/wms/global-analysis-forecast-wav-001-027  

• Ocean Physics: http://nrt.cmems-du.eu/thredds/wms/global-analysis-forecast-phy-001-024  

• Biogeochemical: http://nrt.cmems-du.eu/thredds/wms/global-analysis-forecast-bio-001-028-daily  
 
 
Besides that, there are many Web Map Services with limited spatial coverage provided by local authorities, 
and also sites for the search for WMS exist, such as GeoSeer, Spatineo, or data.gov.  
 
We use a simple OpenStreetMap WMS for the example. First, a raster product has to be loaded and 

displayed. Then, the WMS can be added via the e Layer Manager  by clicking on the  button. A new 
window will open where you select Image from Web Map Server (WMS) and confirm with Next (Figure 
22). Enter the service URL (usually ending with ?, Figure 23, left) and hit Enter to confirm, then proceed 

with Next. Depending on the contents, you will be given a list of layers to chose from (Figure 23, right). 
Select one and confirm with Finish.  
 

 

Figure 22: Adding a WMS via the Layer Manager 

 

https://en.wikipedia.org/wiki/Web_Map_Service
https://www.terrestris.de/en/openstreetmap-wms/
https://ows.terrestris.de/osm/service?
https://ows.terrestris.de/osm-gray/service?
https://geoservice.dlr.de/web/services
https://geoservice.dlr.de/eoc/basemap/wfs
https://www.naturalearthdata.com/
http://nrt.cmems-du.eu/thredds/wms/global-analysis-forecast-wav-001-027
http://nrt.cmems-du.eu/thredds/wms/global-analysis-forecast-phy-001-024
http://nrt.cmems-du.eu/thredds/wms/global-analysis-forecast-bio-001-028-daily
https://www.geoseer.net/
https://directory.spatineo.com/
https://www.data.gov/
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Figure 23: Specification of the WMS 

 
SNAP will now establish a connection to the server and download the data as a raster. It will be then 
displayed in the main view and also added to the list of layers in the Layer Manager (Figure 24). Unlike 
WMS loaded into a Geographic Information System, the view will not update when you zoom in or navigate, 
so the loaded content is rather static. To visually combine or compare it with the underlying raster data, you 
can use the sliders at the bottom of the Layer Manager which allow you to swipe between both layers and 
define their transparency.  
 
 

 

Figure 24: Open Street Map WMS loaded into SNAP 

 
Note: All successfully loaded WMS will remain in the dropdown menu (Figure 23, left). This allows to quickly 
access them at later times without having to enter the service URL again.  
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For more tutorials visit the Sentinel Toolboxes website 
 

http://step.esa.int/main/doc/tutorials/ 
 
 
 
 
 
 
 
 

 
 

Send comments to the SNAP Forum 
 

http://forum.step.esa.int/ 
 
 

http://step.esa.int/main/doc/tutorials/
http://forum.step.esa.int/

