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About this Tutorial 
The goal of this tutorial is to provide a workflow for the combination of radar imagery from Sentinel-1 and 
multispectral imagery from Sentinel-2 to demonstrate their synergetic use and complementary information 
content for landcover analysis.  
 
It furthermore highlights potential error sources and challenges and demonstrates the use of analysis tools 
to be applied on the merged product.  
 

Background and Preparation 

Why merge radar and optical data? 

 
Sentinel-1 is a radar satellite launched by the European Space Agency (ESA) operating at C-band (5.7 cm, 
Figure 1 red). It measures the intensity of the returned signal which was actively sent to the earth’s surface. 
This allows to map physical characteristics, such as roughness, moisture and structure of the surfaces. 
Furthermore, radar images can also be acquired through cloud cover and independently of daylight. This 
makes them a valuable source of information for all regular monitoring activities.  
 
Sentinel-2 is a multispectral satellite operating in the visible and infra-red spectrum (nanometer scale, 
Figure 1 green). It is a passive sensor which measures the energy emitted from the earth’s surface in 13 
separate bands at three different resolutions (more information).  
 
Fusion techniques exist which combine information of different sensors to exploit their complementary 
information content, mostly at the pixel level (Ghassemian 2016, Pandit & Bhiwani 2015). In an ideal case, 
the images of both sensors are acquired at the same time. At least, the time between both image products 
should be minimized to grant that the information of each pixel refers to the same condition of the earth’s 
surface.  In this tutorial, images of both Sentinel-1 and Sentinel-2 were acquired on 18.08.2019.  
 
 

 

Figure 1: Electromagnetic spectrum and S1 / S2 satellites (Ronan 2013, CC BY SA 3.0) 

 

https://sentinel.esa.int/web/sentinel/missions/sentinel-1
https://sentinel.esa.int/web/sentinel/missions/sentinel-2
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-2-msi/resolutions/spatial
https://www.sciencedirect.com/science/article/abs/pii/S1566253516300173
https://pdfs.semanticscholar.org/09b2/7909c747b2012ab42e3ae91b715875780a9a.pdf
https://commons.wikimedia.org/wiki/File:EM_spectrumrevised.png
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Download the Data 

 
The data used in this tutorial can be downloaded from the Copernicus Open Access Hub at:  
https://scihub.copernicus.eu/dhus (login required, registration is free) 
 
Search for the two product IDs and download them:  
SAR:  S1B_IW_GRDH_1SDV_20190818T170708_20190818T170733_017643_02130B_9E0C 
optical:  S2A_MSIL2A_20190818T103031_N0213_R108_T32UNV_20190818T135455 
 
As some of the required steps are computationally intensive, it is good to store the data at a location which 
offers good reading and writing speed. If your computer has an internal SSD, processing should be done 
there to ensure best performance. Network drives or external storage devices are not recommended. Also, 
paths which include special characters should be avoided. In this tutorial, the data is stored under 
C:\Temp\S1S2\. 

 

Location of the Data 

 
The data used in this tutorial lies in eastern Turkey and includes the city of Erzincan and its surrounding 
landscapes. Figure 2 shows the extent of the Sentinel-1 data (red) and of the subset used in this tutorial 
(blue).  

  

 
Figure 2: Extent and location of the data 

https://scihub.copernicus.eu/dhus
https://en.wikipedia.org/wiki/Solid-state_drive
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Workflow chart 
 
Figure 3 summarizes the steps to merge images products of Sentinel-1 with Sentinel-2 (or any other 
combination of radar and optical data) as presented in this tutorial.  
 

 

Figure 3: Systematic workflow for the merge of Sentinel-1 and Sentinel-2 images  
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Preprocessing by a Graph 
 
Users with less experience are recommended to follow the steps outlined in the subsequent chapters 
(Preprocessing of Sentinel-1, Preprocessing of Sentinel-2, and Merge the Products) and skip the 
preprocessing by a graph.  
 
Advanced users can use the Graph Builder of SNAP to preprocess the data. It automates the merge of 
both Sentinel-1 and Sentinel-2 by a predefined XML script. However, all settings (especially the subset by 
WKT coordinates) have to be adjusted carefully. Also, finding the reasons for failed processing in graphs 
can be hard.  
 

The graph can be found in the Graph Builder  under: 
Graphs > Radar > SAR Optical Graphs > S1-S2-Collocation 

 
 

 

Figure 4: Graph to collocate Sentinel-1 and Sentinel-2 data in SNAP  
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Open the Products 

Use the Open Product button in the top 
toolbar and browse for the location of the 
downloaded data. Select the two downloaded zip 
files and press Open Product.  
 
In the Products View you will see the opened 
products. Sentinel-1 products consist of Metadata, 
Vector Data, Tie-Point Grids, Quicklooks and 
Bands (which contains the actual raster data, 
represented by Amplitude and Intensity 
(=Amplitude²) in VV and VH polarization, as 
demonstrated in Figure 5).  
 
Sentinel-2 (Level 2A) products are calibrated to 
Bottom of Atmosphere reflectance (BoA) and 
consist of Metadata, Index Codings, Vector Data, 
Bands, and Masks. Note: If no L2A products are 
available for your area, you can work with L1C as 
well. Just note that multi-temporal image analysis 
requires radiometric calibration with sen2cor to 
convert them to L2A (tutorial).  
 
As both datasets are still compressed in the zip 
files and cover a large area, it is not advised to 
open the bands in their current state, because it 
takes a considerable time until SNAP loads the 
raster. If you still want to check the data before 
proceeding double-click on any band to view the 
raster data.  
 
Another way to identify the location of your study 
area within the product (required for the next step), 
you can use the World View or World Map (to see 
its full extent on a base map) or open the Quicklook 
for a preview of the dataset in an RGB color 
representation. 

 

Figure 5: Product Explorer and World Map 

 
Note: If you miss any items in your user interface you can activate them in the menu under View and Tool 
Windows. 
 
A couple of steps are required before both products can be merged in one stack:  
 
Sentinel-1:  1. Subset 
 2. Radiometric Calibration  
 3. Speckle Filtering 
 4. Range Doppler Terrain Correction / Projection into UTM coordinate system of Sentinel-2 
 
Sentinel-2: 1. S2 Resampling 
 2. Subset 
 
 
The subset is performed to clip both products on a common area and to reduce the amount of data to be 
processed. 

https://earth.esa.int/web/sentinel/user-guides/sentinel-2-msi/product-types/level-2a
https://step.esa.int/main/third-party-plugins-2/sen2cor/
https://www.youtube.com/watch?v=VNG1KRcUzao
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In a first step, select one band of the Sentinel-2 
product in the Product Explorer and select the 

Geo-Coding tool   from the menu bar. A 
new window will open (Figure 6) which shows 
you the coordinate reference system of the 
dataset.  
 
Sentinel-2 products are stored in the 
corresponding UTM zone in which they are 
located. This projection is based on metric units 
(instead of degrees) and divides the earth into 
60 zones with a width 6d of longitude. The UTM 
zone of the Sentinel-2 product in this tutorial is 
shown in the Geo-Coding window: Here, it is 
zone 32 North, as indicated in the line 
highlighted in Figure 6:  
 
   PROJCS["WGS 84 / UTM zone 32N" 
 

This means, the Sentinel-1 data (currently 
unprojected) should be projected into the same 
coordinate reference system. 

 

Figure 6: Geo-Coding of Sentinel-2 

 

Preprocessing of Sentinel-1 

Create a Subset 

 
To reduce the loaded data to the area of interest, 
select the Sentinel-1 product in the Product Explorer 
and open the open the Subset operator (under 
Raster). A separate window might open (“Creating 
thumbnail image”), but this takes quite a long time, 
so it is ok to Cancel this window.  
 
Switch to the Geo Coordinates tab and enter the 
following numbers (Figure 7): 
 

▪ North latitude bound: 48.498 
▪ West longitude bound:  9.058 
▪ South latitude bound: 49.10 
▪ East longitude bound:  9.50 

 
Confirm with Run and repeat the step for the second 
S1 image.  
 

 

Figure 7: Sentinel-1 subset 

 
A new product is shown in the Product Explorer, starting with subset_0_of_S1B. This product is only of 

temporary nature and lost after SNAP is closed. Yet, it can be used as an input for the next step so that 

only the subset area is radiometrically calibrated.  

https://en.wikipedia.org/wiki/Universal_Transverse_Mercator_coordinate_system
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Radiometric calibration 

 
Radiometric calibration converts backscatter intensity as received by the sensor to the normalized radar 
cross section (Sigma0) as a calibrated measure taking into account the global incidence angle of the image 
and other sensor-specific characteristics. This makes radar images of different dates, sensors, or imaging 
geometries comparable.  
 
Open the Calibration operator (under Radar > Radiometric) and use the subset which was created in the 
previous step as an input.  
 
Select a suitable output folder and enter S1_20190818 as the output name. All other settings can be left 

on default. SNAP uses the image metadata to calibrate the image as described in this documentation. After 
completion, the output product is added to the Product Explorer. 
 
 

 

Figure 8: Radiometric Calibration 

 
 

Speckle Filtering 

 
Speckle is a systematic effect emerging from positive and negative contributions of surfaces to the 
measured backscattered signal. It is often described as “salt and pepper” effect which complicates the 
interpretation and analysis of the image. A series of speckle filters exist, all have their pros and cons and it 
is often a good idea to test the different filters and the effect of their parameter settings to find the 
configuration which is best for the application.  
 
Extensive reviews and comparisons of speckle filters are provided by Dong et al. (2000), Touzi (2002), and 
Lee et al. (2009).  
In this tutorial ,the Lee Sigma filter published by Lee et al. (2009), which uses two different window sizes to 
estimate the presence and intensity of speckle (). It minimizes speckle while maintaining sharp edges where 
they can be detected.  
 
The filter can be found under Radar > Speckle Filtering > Single Product Speckle Filtering.  

https://sentinel.esa.int/web/sentinel/radiometric-calibration-of-level-1-products
https://ieeexplore.ieee.org/abstract/document/861654
https://ieeexplore.ieee.org/abstract/document/1166598
https://www.tandfonline.com/doi/abs/10.1080/02757259409532206
https://ieeexplore.ieee.org/document/4689358
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Figure 9: Lee Sigma speckle filter 

 
 

 

Figure 10: Sentinel-1 image before (left) and after (right) speckle filtering  
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Conversion to dB scale 

 

As highlighted by the statistics tool , the values of 
Sigma0_VV roughly range between 0 and 2380, with a 
mean of 0.219 (Figure 11, top). This means that a very 
small proportion of very bright pixels distorts the actual 
value distribution. This is not ideal in a statistical sense 
and makes the image very dark, because values of 
smaller than 1 have similar grey values.  
 
To achieve a more normal distribution of values, the log 
function is applied to the radar image. It translates the 
pixel values into a logarithmic scale and yields in higher 
contrasts, because the bright values are shifted towards 
the mean while dark values become stretched over a 
wider color range (Figure 11, bottom). 
 
The value range of calibrated dB data is -35 to +10 dB.   
 

 

 

Figure 11: Image statistics of power (top) and logarithmic (bottom) scale  
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To convert VV polarization into dB scale right-click on the filtered bands and select Linear to/from dB. This 
creates a new virtual band for with the extension _db. Repeat this for the VH polarization and compare the 
products (Figure 12).  
 
This step is not ultimately required, and it does not change the information content of the image, but it is 
advisable when image contrasts matter.  
 

 

Figure 12: Sentinel-1 Sigma VV before (left) and after (right) conversion to dB scale 

 
 

Terrain Correction 

Terrain Correction will geocode 
the image by correcting SAR 
geometric distortions using a 
digital elevation model (DEM) 
and producing a map projected 
product. 
 
Geocoding converts an image 
from slant range or ground 
range geometry into a map 
coordinate system. Terrain 
geocoding involves using a 
Digital Elevation Model (DEM) 
to correct for inherent geometric 
distortions, such as 
foreshortening, layover and 
shadow (Figure 13). More 
information on these effects is 
given in the ESA radar course 
materials.  

 

Figure 13: Geometric distortions in radar images (Braun 2019) 

https://earth.esa.int/web/guest/missions/esa-operational-eo-missions/ers/instruments/sar/applications/radar-courses/content-3/-/asset_publisher/mQ9R7ZVkKg5P/content/radar-course-3-slant-range-ground-range
https://earth.esa.int/web/guest/missions/esa-operational-eo-missions/ers/instruments/sar/applications/radar-courses/content-3/-/asset_publisher/mQ9R7ZVkKg5P/content/radar-course-3-slant-range-ground-range
hdl.handle.net/10900/91317
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Open the Range Doppler Terrain Correction operator (under Radar > Geometric > Terrain Correction) 
and select the filtered product as input product.  In the Processing Parameters tab chose the two dB 
products as Source Bands and select SRTM 1Sec HGT (AutoDownload) as input DEM.  
 
As we terrain correct the data in dB scale, bilinear resampling of logarithmic data will lead to false 
backscatter values. Therefore, we select NEAREST_NEIGHBOUR as Image Resampling Method. 
Alternatively, the conversion to dB could be done after terrain correction.  
 
Select UTM zone 32N as the Map Projection and click on Run to start the terrain correction. SNAP now 
establishes a connection to an external elevation database to download all SRTM tiles required to fully 
cover the input dataset. The output is a terrain corrected and geocoded Sentinel-1 product in dB scale.  
 
 

 

Figure 14: Range Doppler Terrain Correction 
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Create ratio band (optional) 

 
To reduce the imbalance of bands (2 for Sentinel-1, 13 for Sentinel-2), a ratio is calculated between the two 
polarizations using the Band Maths operator (Figure 15). Note: As the data was transformed into dB scale, 
any ratio becomes a difference according to the laws of logarithm. Enter Sigma0_ratio_db as an input name, 
uncheck the option “Virtual (save expression only, don’t store data) and enter the following expression 
(optionally via Edit Expression):   
 
Sigma0_VV_db – Sigma0_VH_db 

 

A new band is created in the product S1_20190818_Spk_TC. Click File > Save Product to make the 
changes permanent. Afterwards, an RGB composite can be created from these three bands (Figure 16) to 
visualize the results. The radar product is now ready to be merged with other data.  
 

 
Figure 15: Sentinel-1 polarization ratio 

 

Figure 16: RGB of Sentinel-1 

 
Figure 17: RGB composite in db scale of VV (red), VH (green) and VH-VH (blue)  

https://people.richland.edu/james/lecture/m116/logs/properties.html
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Preprocessing of Sentinel-2 

Import the product 

 
Extract the file S2A_MSIL2A_20190818T103031_N0213_R108_T32UNV_20190818T135455.zip 

which was downloaded from the Copernicus hub as described earlier in this tutorial. A new folder ending 
with .SAFE is generated which contains the metadata file to correctly load the raster stack into SNAP.  
 
Use File > Import > Optical Sensors > Sentinel-2 > S2-MSI L2A (alternatively S2-MSI L1C if no L2A is 
available), select the file MTD_MSIL2A.xml (Figure 18) and confirm with Import Product.  

 

 

Figure 18: Import of Sentinel-2 product as subset 

 

Create a subset 

 
A subset allows to reduce the amount of data to be processed in the following. Select the Sentinel-2 product 
in the Product Explorer and navigate in the menu Raster > Subset… 
A separate window might open (“Creating thumbnail image”), but this takes quite a long time, so it is ok to 
Cancel this window.  
 
In the Spatial Subset tab Switch to the Geo Coordinates tab and enter the following numbers: 
 

▪ North latitude bound: 48.95 
▪ West longitude bound:  9.0 
▪ South latitude bound: 48.70 
▪ East longitude bound:  9.40 

 
In the Band Subset tab only select the spectral bands (excluding B8A, Figure 19, right). Un-check all quality 
indicators and other bands which follow in the list, so they will not be part of the output product.  
 
Note: It is easier to click Select none and then check the boxes for the 12 main bands.  
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Figure 19: Sentinel-2 subset 

 
  
Confirm with OK. A new product is shown in the 
Product Explorer, starting with subset_S2A. As it 

is only a virtual product, so now we save it with  
File > Save Product as >  
 S2_20190818_subset.dim 

 
This can now take a while because both previously 
defined steps (Resampling and Subset) are now 
finally applied to the original zipped Sentinel-2 
product (Figure 20).  

 
Figure 20: Saving the virtual S2 product 
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Merge the products 
 
The two datasets are now prepared to be merged in 
a stack. They  

• have the same spatial resolution (10 meters) 

• have a similar spatial extent  

• are projected in the same coordinate reference 
system (UTM zone 32 N)  

• are both stored physically under the names 
 

o S1_20180818_Spk_TC.dim 
o S2_20180818_subset.dim 

 
To get rid of the temporary products in the SNAP 
workspace and to release some memory, it is good 
to clear the Product Explorer at this point of the 
analysis with File > Close All Products and only 
open these two products again.  
 
The workspace should now look as demonstrated in 
Figure 21: The Sentinel-1 product has three bands 
(VV, VH and ratio) in dB scale and is of slightly lager 
coverage (this will be resolved in the following step).  
 
The Sentinel-2 product has 12 bands (B1-B12).  
 
You can double-click on the raster bands to open 
them and check if they contain data. This should 
now take only a few seconds because the size of 
the subsets is now considerably smaller than the 
original product (Figure 2).  
 
The next step is to stack these two datasets which 
means to bring both into one common product 
which can then be analyzed.  
 
We use Sentinel-1 as the reference1 product 
because its geolocation accuracy is very high after 
Range Doppler Terrain Correction.  

 

Figure 21: Prepared S1 and S2 products 

 
In this tutorial, we use the Collocation operator (under Raster > Geometric Operations > Collocation) which 
requires one reference product which determines the extent, pixel size and pixel registration of the output 
product, and one or more secondary products which will be clipped and resampled accordingly.  

 

Open the Collocation operator and select the Sentinel-1 product as the reference. Use the  button to 
add the Sentinel-2 with Add product(s)… to the list of the secondary products (Figure 22). Select Bilinear 
interpolation resampling for the resampling method. 
 
Enter 20190818_S1S2 as the target product name and confirm with Run. A new product is created which 

contains the three radar bands and 11 multispectral bands. This is the most important step for image fusion, 
because it allows a range of different methods to utilize the information content of both products in the 
following.  

 
1 We support the statement of the executive committees of WInSAR and COMET to exchange the inappropriate terminology in all 

InSAR-related fields. Accordingly, the former "master/slave" will be replaced by "reference/secondary" in future versions of SNAP. 

https://comet.nerc.ac.uk/about-comet/insar-terminology/
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Figure 22: Collocation of Sentinel-2 (reference) and Sentinel-1 (secondary) 

 
In the output product all optical bands are marked with _M and 
their corresponding wavelength (as retrieved from the 
metadata).  
 
This is automatically done to avoid naming conflicts and can be 
modified (or completely disabled) under Renaming of Source 
Product Components of the Collocation tool (Figure 22).  
 
The collocationFlags band is an indicator for the presence 

of the input products. The raster is 1 where both images are 
present. As the extent Sentinel-1 image was larger than the 
extent of Sentinel-2 image the common area is only a part of the 
output product (Figure 24).  
 
This band is helpful for subsequent operations because it allows 
to limit the raster to the common area.  
 
Note: The Collocation module does not support multi-resolution 
products as reference. If you want to have Sentinel-2 as the 
reference product, you must run the S2 Resampling Operator 
first.  

 
Figure 23: Merged stack of Sentinel-1 

and Sentinel-2 band 
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Figure 24: Collocation Flags of the merged product 
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Suggestions for analyses of the merged product 

Visual interpretation 

 
Figure 25 shows a true color image compared to a false color composite with red=S2-B4, green=S2-B3 
and blue=S1-VV. Such combinations reveal patterns which are not visibly by optical data only.  
 

 

Figure 25: True color (left) and false color (right) composite 

 
Try different combinations of the bands and also change the contrast stretch of in the Color Manipulation 
tab to enhance different structures in the image.   
 

 

Figure 26: RGB composite of red=S2_B9, green=S2_B5, blue=S1_VH  
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Mask Manager (basic use) 

The Mask Manager   allows to apply logic or mathematic expressions on the pixels of an image product 
to see which of them fulfill certain conditions. A raster product (or RGB composite) must be opened in the 
current view for the tools of the Mask Manager to become active.  
 

In a first step, we create a mask for the common area of both input products using this button  
In the expression dialogue, enter the expression (make sure you activate Show bands and Show single 
flags):  
 
collocationFlags == 1 

 
 

 

Figure 27: Definition of a term to create a mask in the Mask Manager 

 
This creates a mask which is true for the common area and false for the area outside the Sentinel-2 extent. 
It will appear as red transparent area in the currently opened raster. Name and color can be changed in the 
list of masks (Figure 28). Let’s call this mask “analysis” because it defines the pixels of interest, as they 
contain both radar and optical information.  
 
Note: To change the expression of a mask, double-click on Maths and the Expression editor opens again. 
Changes in the Description field have no consequences.  
 
 

 

Figure 28: List of masks in the Mask Manager 

 
Once you created a mask, select the product and make the changes permanent with File > Save product.  
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Principal component analysis 

 
To illustrate the increased information content of the newly generated stack, a principal component analysis 
(PCA) can be performed on the product. It is a technique which identifies redundancies and differences in 
a stack of bands and transforms them into new uncorrelated bands (principal components) with have a 
maximized information content. Accordingly, the first principal component (PC1) represents the maximum 
proportion of variance from the original dataset. The remaining variation is expressed by PC2, PC3 and so 
on. More information can be found here.  
 
Open the Principal Component Analysis operator (under Raster > Image Analysis). Select the image bands 
(all except for the collocationFlags) as Source bands and use the mask “analysis” which was created in 
the previous step as ROI mask name. Also check Remove non-ROI-pixels to exclude all pixels which are 
only covered by the Sentinel-1 image.  
 
To reduce the processing time, set the Maximum component count to 5 (the standard setting -1 means 
that 13 components are calculated for 14 input bands). Start the processing with Run. 
 
Note that a PCA can take a considerable amount of time, especially for large raster images and a high 
number of components.  
 
Figure 29 shows an example of how a PCA can contain both radar and optical information. The red object 
shows the bright stadium roof which has high radar backscatter. 
 
 

  

Figure 29: Principal Component Analysis of red=PC1, green=PC3, blue=PC5 

 
 
 
 
 

https://wiki.landscapetoolbox.org/doku.php/remote_sensing_methods:principal_components_analysis
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Working with Vectors 

Create a new vector container called “forest_AOI” using New Vector Data Container . It will appear in 
the Layer Manager (currently not filled with a geometry, but already defined, Figure 30).  
 

 

Figure 30: Creation of new vector containers 

 
 
If you want to digitize geometries of multiple classes, it is important 
that you first define them as vector data containers as previously 
explained and then select the folder “Vector data” in the Layer 
manager, as displayed in Figure 30.  
 

Once you select the Polygon Drawing Tool  and click in the 
map, you will be asked which of the vector containers you want to 
edit or fill with geometries (Figure 31). This allows to digitize 
multiple polygons which belong to the same class (container) and 
to effectively manage vectors of multiple classes.  
 
Select a container and proceed with OK. You can then digitize 
polygons and finish with a double-click. You can modify or delete 

existing polygons using the Selection tool  (Figure 32). In this 
tutorial, a polygon is created covering a homogenous forest area.  
 

 

 

Figure 31: Selection of a vector 
data container for digitization 

 
Figure 32: Editing existing vectors  
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Histogram and Statistics 

 
The histogram gives information about the value distribution of a raster. It is a tool to understand the spectral 
characteristics (SAR backscatter or calibrated reflectance) of a surface, instead of simply extracting values 
at a single pixel.  
 
To get a histogram of the forest area, which was previously digitized, select one raster band in the Product 

Explorer and click Histogram . A new window opens with an empty plot. Check the option Select ROI 

mask, select the polygon “forest_AOI” from the drop down menu and confirm with Refresh View  to load 
the histogram (Figure 33).  
 

  

Figure 33: Histogram of digitized polygons for Sentinel-1 VV (left) and Sentinel-2 B5 (right) 

 
The histogram shows that the forest values largely range between -10 and -5 in the S1 VV db band and 
between 0.035 and 0.07 in the S2 B5 band. This helps to understand the interaction of specific surfaces in 
selected wavelengths and polarizations. Note: if you can’t reload the histogram with the Refresh View 
button, slightly change the #Bins parameter to allow SNAP to recompute the image statistics.  
 

To get a more quantitative understanding of these relationships the Statistics tool  can be used. It lists 
descriptive statistics of a band or a selected region. Check Use ROI mask(s) and select “forest_AOI” from 
the list to limit the analysis to the digitized polygon (Figure 34).  
Sigma is the standard variation of all pixels within the polygon. The Median is more robust towards outliers 
than the arithmetic Mean. P90 stands for the 90% percentile which means that 90 % of the pixels within the 
digitized polygon are smaller than -12.9731. This is a valuable information for image thresholding to 
discriminate classes. You get even more percentiles with a right-click > Copy Data to Clipboard.  
 

 
Figure 34: The Statistics tool for quantitative analysis of images or selected ROIs  
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Mask Manager (advanced use) 

 
The Mask Manager not only serves as a mask for operators, as shown in the previous example, but also 
allows to systematically analyze the information one of multiple images at once, for example to determine 
the spectral response of certain surfaces or to find thresholds for the discrimination of defined landcover 
classes.  
 
Based on the information retrieved from the Histogram and Statistics tool, expressions can be formulated 
which include both criteria from the optical and microwave spectrum. Together they allow the precise 

delineation of specific surfaces. Make new expressions  as defined in Table 1 and Figure 35: 
 

Table 1: Expressions for the definition of classes 

name of the mask color expression 

agr_no-crops blue B1_S > 0.035 AND Sigma0_VH_db_M <= -16.919 

urban red B1_S > 0.035 AND Sigma0_VH_db_M > -16.919 

forest green B1_S <= 0.035 AND B4_S <= 0.025 

agr_crops yellow B1_S <= 0.035 AND B4_S > 0.025 

 

 

Figure 35: Definition of classes in the Mask Manager 

 
It is important that the mask descriptions are not overlapping. It is however also possible to select two 

masks and combine them with logical expressions: Union (OR) , Intersection (AND) , difference 

, or complement . Figure 36 shows how the result of the mask definitions looks like.  
 

 

Figure 36: Masking of landcover classes with the Mask Manager  
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Scatter Plot 

 
A scatter plot compares values of two datasets in a cartesian 
coordinate system. It is a good way to analyze how pixel 
values of one raster correspond to pixel values of another 
raster. Each point in the scatter plot represents a pair of 
values – one from raster 1 (x-axis) and one from raster 2 (y-
axis). The relationship between both raster products is then 
described by the shape and extent of the created point 
cloud. 
 
We want to analyze if radar information is linked to 
vegetation. For this reason, we compute the Normalized 
Difference Vegetation Index (NDVI) based on the red and 
infra-red band of the Sentinel-2 data. It ranges between -1 
and 1, where negative values indicate water and high values 
are an indicator for vegetation health and vitality.  
 
This is done with the Band Maths by entering the formula 
 

(B5_S - B4_S) / (B5_S + B4_S) 

 
Make sure you un-check the Virtual option (Figure 37) so 
that the NDVI band will be physically written on the hard 
drive. This ensures quicker access to the pixel values.  

 

Figure 37: Calculation of the NDVI 

 
 

 

Figure 38: NDVI of the study area 

 
 

First, we compute a Scatter Plot   for the entire image. For the x-axis select Sigma0_VV_db_M and for 

the y-axis select the newly generated NDVI band. Click Refresh View  to load the plot (Figure 39). 
 
It is often advisable to adjust the minimum and maximum values of both axes for a better visualization of 
the graph. Here we selected -25 to 25 for the radar data (x-axis) and -0.5 to 1 for the NDVI (y-axis). At first 
glance, there is no direct relationship between both raster bands: the point cloud has no specific shape.  
 
But there are some areas where pairs of pixel values are more frequent (yellow) than others (black). 

https://en.wikipedia.org/wiki/Normalized_difference_vegetation_index
https://en.wikipedia.org/wiki/Normalized_difference_vegetation_index
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Figure 39: Scatter Plot between Sigma0 VV db (x) and NDVI (y) for the entire image 

 
 
The same applies for the VH-band (Figure 40, left) and the ratio image (Figure 40, right) 
 

 

Figure 40: Scatter Plot between Sigma0 VH db and ratio (x) and NDVI (y) for the entire image 

 
 
These patterns are not surprising, because the NDVI is only valid for vegetation areas. To restrict the scatter 
plot to natural areas, a mask must be created which excludes urban areas. 
 
This can be done in the Mask Manager using the expression 
 
NOT urban AND analysis 

 
The first (NOT urban) part indicates that every pixel which is inside the urban mask, is not part of the new 

mask. The second part (AND analysis) applies to the mask generated at an earlier stage which includes 

all pixels covered by both Sentinel-1 and Sentinel-2.  
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This new mask is named vegetation and then used as ROI for a scatter plot as demonstrated in Figure 41. 
This scatter plot shows a slight positive correlation, indicating that areas with a high NDVI also have larger 
Sigma0 VH db values (blue dotted trend line, inserted outside SNAP).  
 

 

Figure 41: Sigma0 VH db (x-axis) in relation to NDVI (y-axis) for vegetated areas 

 
 

Profile Plot 
 

The Profile Plot tool  allows to plot the values along a digitized line by a line graph with a defined pixel 
radius (box size). It helps to understand how much surfaces differ in selected bands (Figure 42). SNAP only 
allows to display one band at a time, but the data can be exported via right-click > Copy Data To Clipboard. 
This allows to analyze the data along the profile in external tools, such as MS Excel. This helps to identify 
the bands which are most important to delineate a class and also to find suitable class thresholds.  
 

 

Figure 42: Profile plot across four agricultural fields for band 4 of Sentinel-2  



Synergetic use of radar and optical data 

  

28 

Figure 43 shows pixel values along the digitized lines of both radar and optical raster bands. It highlights 
that band 4 of Sentinel-2 and VH polarization of Sentinel-1 have higher contrasts than band 1 or VV 
polarization. A suitable threshold to discriminate between bare and vegetated fields lies at 0.1 reflectance 
of band 4, or accordingly, at -18 dB backscatter intensity of VH polarization.  
 

 

Figure 43: Profile plot across four fields for Sentinel-2 (left y axis) and Sentinel-1 (right y-axis) 

 

Unsupervised classification 

 
An unsupervised classification is a good way to identify 
and aggregate pixels with similar features.  
 
Open the K-Means Cluster Analysis under Raster > 
Classification > Unsupervised Classification and select 
your merged product stack as input product. 
 
In the second tab, select all bands as source bands, 
except for the “collocationFlags” because they store no 
information which is relevant here. Select the “analysis” 
mask as ROI-mask to limit the classification on the 
pixels which are covered by both Sentinel-1 and 
Sentinel-2 data. Confirm with Run. 
 
This can take some minutes because the classifier now 
undertakes 30 iterations with random cluster centers of 
the multi-dimensional feature space to find pixels of 
similar properties. More information.  
 
These clusters do not necessarily represent reasonable 
classes of landcover, but they are homogenous 
regarding their pixel characteristics.  
 
Figure 45 shows a potential result of the k-means 
clustering with colors assigned and cluster centers 
described in the Color Manipulation tab.  

 

Figure 44: Unsupervised clustering of both 
optical and radar information 
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Figure 45: Result of the k-means clustering of Sentinel-1 and Sentinel-2 data 

 

Scatter Plot with Mask Manager 

 
Once a scatter plot is created, you can right-click in the plot area and activate Select Mask 
‘scatter_plot_area’ from the menu. You can now select areas in the scatter plot by holding the left mouse 
button down and drawing a circle in the plot area (highlighted by the blue dotted ellipse in Figure 46).  
 
All pixels which lie in the selected area will be highlighted red in the map. Additionally, a new mask 
‘scatter_plot_area’ is placed in the Mask Manger (and can be modified there). To stop the selection of pixels 
in the Scatter Plot right-click and deactivate  Select Mask ‘scatter_plot_area’ again.  
 

 

Figure 46: Selection of pixels in the Scatter Plot  
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For more tutorials visit the Sentinel Toolboxes website 
 

http://step.esa.int/main/doc/tutorials/ 
 
 
 
 
 
 
 

 
 

Send comments to the SNAP Forum 
 

http://forum.step.esa.int/ 
 

http://step.esa.int/main/doc/tutorials/
http://forum.step.esa.int/

