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Interferometry Tutorial 
The goal of this tutorial is to provide novice and experienced remote sensing users with step-by-step 
instructions on interferometric processing of Radarsat-2 products to generate a digital elevation model 
(DEM).  
 

Background  

What is Interferometry? 

Interferometric synthetic aperture radar (InSAR) exploits the phase difference between two complex radar 
SAR observations taken from slightly different sensor positions and extracts information about the earthôs 
surface. 
 
A SAR signal contains amplitude and phase information. The amplitude is the strength of the radar 
response and the phase is the fraction of one complete sine wave cycle (a single SAR wavelength). The 
phase of the SAR image is determined primarily by the distance between the satellite antenna and the 
ground targets. 
 
By combining the phase of these two images after coregistration, an interferogram can be generated whose 
phase is highly correlated to the terrain topography. The remaining variation in the interferogram can be 
attributed to surface changes which occurred between the two image acquisition dates, as well as unwanted 
atmospheric effects. In this tutorial, surface heights and landforms are derived from an image pair of two 
Radarsat-2 products. 
 
For an introduction to interferometric concepts, please see ESAôs InSAR Principles: Guidelines for SAR 
Interferometry Processing and Interpretation  (ESA TM-19). 
 
 

Preparation  

Download the Data 

The data used in this tutorial is provided by MDA and can be downloaded from this page: 
https://mdacorporation.com/geospatial/international/satellites/RADARSAT-2/sample-data  
 
You find download links of two Radarsat-2 UltraFine products (located in Phoenix, USA; Figure 1) at the 
bottom of the page under ñInterferometric Ultra-Fine Pairò: 
 
Á Phoenix_RS2_UltraFine12_20080528_HH_SLC  ZIP 279.66 MB 

Á Phoenix_RS2_UltraFine12_20080504_HH_SLC  ZIP 278.73 MB 

 
As some of the required steps are computationally intensive, it is good to store the data at a location which 
offers good reading and writing speed. If your computer has an internal SSD, processing should be done 
there to ensure best performance. Network drives or external storage devices are not recommended. Also, 
paths which include special characters should be avoided. In this tutorial, the data is stored under 
C: \ Temp\ R2_InSAR \ . 

 
Please extract the data and have a look at the License Agreement  (PDF) inside the extracted folder.  
 
The data has a spatial resolution of 1.8 x 2.6 meter and covers an area of 22 x 23.5 kilometers. More 
information on product characteristics of Radarsat-2 is given here. 

http://www.esa.int/esaMI/ESA_Publications/SEM867MJC0F_0.html
http://www.esa.int/esaMI/ESA_Publications/SEM867MJC0F_0.html
https://mdacorporation.com/geospatial/international/satellites/RADARSAT-2/sample-data
https://en.wikipedia.org/wiki/Solid-state_drive
https://www.pcigeomatics.com/geomatica-help/references/gdb_r/RADARSAT-2.html
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Figure 1: Location and extent of the Radarsat -2 data used in this tutorial  

 

Notes on Data Ordering 

Radarsat-2 data is commercial and can be ordered via the 
Earth Observation Data Management System  of the CSA. 
Also, MDA is an official distributor.  
 
When ordering interferometric pairs of Radarsat-2, make 
sure to select Single Look Complex (SLC) data products of 
the same track with minimal temporal difference between 
their acquisition times and with the definitive orbit data. 

 

Figure 2: Check "Definitive Orbit Data"  

 
The definitive orbit data is required to obtain accurate enough results for interferometry. Definitive orbits 
are made available 3 - 5 days after the image acquisition. 
 

Install snaphu 

This tutorial can entirely be done within SNAP. Yet, as an external software package, snaphu (statistical-
cost network-flow algorithm for phase unwrapping) has to be installed separately. For more information on 
this tool, please visit https://web.stanford.edu/group/radar/softwareandlinks/sw/snaphu/. 
 
To install the plugin in SNAP, go to Plugins (under the Tools menu, Figure 3) and search for ñSNAPHU 
Unwrappingò und the Available Plugins tab. Select it and click Install . 
 

https://www.asc-csa.gc.ca/eng/satellites/radarsat2/order-contact.asp
https://gsiportal.mdacorporation.com/gc_cp/#/map
https://web.stanford.edu/group/radar/softwareandlinks/sw/snaphu/
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Figure 3: The Plugins interface  

 
You will be asked to proceed with ñNextò and restart SNAP. This creates a menu entry for snaphu 
unwrapping in the Interferometry menu. 
 
After you have restarted SNAP, you need to install the snaphu bundles as well. Go to Manage External 

Tools in the Tools menu. Select ñSnaphu-unwrappingò and click Edit the selected operator    to open 
the configuration (Figure 4). Select a suitable Target Folder (here C: \ GIS) where snaphu will be installed 

and proceed with Download and Install Now . You will then get a confirmation ñBundle was installed in 
location C:\GIS\snaphu-v1.4.2_win64ò (this may differ according to version, path and operating system).  
 

 

Figure 4: Installation of the snaphu bundles   
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Open the Product s 
Use File > Import > SAR sensors > RADARSAT-2 
to open the dialogue for file selection. Navigate to 
the extracted folders and select the product.xml  

file and confirm with Import Product .  
 
In the Products View you will see the opened 
products. Each Radarsat-2 product consists of 
Metadata, Vector Data, Tie-Point Grids, Quicklooks 
and Bands (which contains the actual raster data, 
represented by i_ HH, q_HH as the real and 

imaginary parts of the complex radar product and 
the resulting intensity as demonstrated in Figure 5).  
 
Double-click on the Intensity_ HH band to view 

the raster data (Figure 6). Depending on the 
capabilities of your computer, this might take a 
while.  
 
To identify the location of the area of interest within 
the entire product, you can use the World View or 
World Map (to see its full extent on a base map) or 
open the Quicklook for a preview of the dataset. 
 
The World View or World Map menus are also a 
good way to check if your image belong to the same 
relative orbit (required for interferometry).  
 
Note: If you miss any items in your user interface 
you can activate them in the menu under View and 
Tool Windows.   

Figure 5:  Product Explorer and World Map  

 
 

 

Figure 6: Preview of the R2 SM product   



Radarsat-2 Interferometry Tutorial

  

6 

Coregistration  
To exploit the phase difference of the acquisitions, a stack containing both products must be created first. 
Coregistration makes use of image statistics to align both products at sub-pixel accuracy. Conventional 
Stripmap radar products can be coregistered the Coregistration operator (under Radar > Coregistration).  
 
Load the two R2 products to the ProductSet-Reader tab (Figure 7, left) and increase the Number of GCPs 
to 4000 in the Cross-Correlation tab (Figure 7, right). Furthermore, select Show Residuals  in the Warp tab 
and click Run  to start the coregistration. Depending on the size of the products and the number of GCPs, 
this can take a while. In this tutorial, the output product is called R2_Stack.dim . 

 

  

Figure 7: Coregistration of Radarsat -2 products  

 
After the coregistration is completed, it is advisable to visually check the quality of the stack. This can be 
done by an RGB representation of the reference and secondary1 product which shows if the images are 
correctly aligned. Select the reference for red and green and the secondary image for blue (Figure 8) 2.  
 
 

  

Figure 8: Generation of an RGB image  

 

 
1 We support the statement of the executive committees of WInSAR and COMET to exchange the inappropriate terminology in all 

InSAR-related fields. Accordingly, the former "master/slave" will be replaced by "reference/secondary" in future versions of SNAP. 
2 https://www.scientificamerican.com/article/end-of-the-rainbow-new-map-scale-is-more-readable-by-people-who-are-color-blind/  

https://comet.nerc.ac.uk/about-comet/insar-terminology/
https://www.scientificamerican.com/article/end-of-the-rainbow-new-map-scale-is-more-readable-by-people-who-are-color-blind/
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Zoom in to an area with distinct surfaces, for example the border between agricultural fields. The RGB 
image should be clear and sharp and not be dominated by one of the images (yellow [red+green] for the 
reference or blue for the secondary image). The only exception are changes in landcover or scattering 
mechanisms which occurred in the time between the first and the second image acquisition (Figure 9).  
 

 

Figure 9: RGB of a s uccessful (top ) vs. failed (bottom , empty secondary  image ) coregistration  

 

To check the perpendicular baseline, select the coregistered stack, open the InSAR Stack   tool and 
switch to the Baselines tab (Figure 10). As shown, the perpendicular baseline is 439.80 meters.  
 

 

Figure 10: InSAR Stack tool  

 

Interferogram Formation and Coherence Estimation  
An interferogram is formed by cross multiplying the reference image with the complex conjugate of the 
secondary image. The amplitude of both images is multiplied while the phase represents the phase 
difference between the two images. 
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The interferometric phase of each SAR image pixel would depend only on the difference in the travel paths 
from each of the two SARs to the considered resolution cell. Accordingly, the computed interferogram 
contains phase variation ◖ from several contributing factors, most importantly the flat-earth phase ◖flat (earth 
curvature), the topographic phase ◖DEM (topographic surface of the earth), atmospheric conditions ◖atm 
(humidity, temperature and pressure change between the two acquisitions), and other noise ◖noise (change 
of the scatterers, different look angle, and volume scattering ), and lastly the eventual surface deformation 
occurred between the two acquisitions ◖disp (Equation 1).  
 
A more detailed explanation is given by Roca et al. (1997), and in the documents compiled by ESA: InSAR 
Principles: Guidelines for SAR Interferometry Processing and Interpretation (ESA TM-19). 
 
 

 ◖ = ◖DEM + ◖flat + ◖disp + ◖atm + ◖noise  (1) 

 
 

 

Figure 11: Contributors to SAR interferometric phase  

 
 
Traditional SAR interferometry tries to estimate the contribution from the earthôs surface (◖flat and ◖DEM) 
which is considered equal for both image acquisitions and derive the heights of the topography (Equation 
2; ESA TM-19A, chapter 2.2; ESA TM-19B, chapter 3).  
 

 

 ◖DEM = ◖ - ◖flat - ◖disp + ◖atm + ◖noise  (2) 

 
 

This works best if atmospheric contributions and other noise is kept as small as possible because they are 
hard to estimate and if there is no elevation change ◖disp between the two image acquisitions. It is therefore 
advisable to use images from the dry season and with a suitable perpendicular baseline. More hints on the 
selection of suitable image pairs for InSAR DEM generation are given in ESA TM-19B, chapter 1.3). This 
source names an optimum perpendicular baseline of 150 - 300 m.  
 
Besides the interferometric phase, the coherence between the reference and the secondary image is 
estimated as an indicator for the quality of the phase information. Basically, it shows if the images have 
strong similarities and are therefore usable for interferometric processing. Loss of coherence can produce 
poor interferometric results and is caused by temporal (over vegetation and water bodies), geometric (errors 
or inaccuracies in the orbit metadata) and volumetric decorrelation  (potential scattering mechanisms of 
voluminous structures, such as complex vegetation or dry surfaces).  
 
Coherence is calculated as a separate raster band and shows how similar each pixel is between the 
secondary and reference images in a scale from 0 to 1. Areas of high coherence will appear bright. Areas 
with poor coherence will be dark. In the image, vegetation is shown as having poor coherence and buildings 
have very high coherence. 
 
  

https://earth.esa.int/workshops/ers97/program-details/speeches/rocca-et-al/
http://www.esa.int/esaMI/ESA_Publications/SEM867MJC0F_0.html
http://www.esa.int/esaMI/ESA_Publications/SEM867MJC0F_0.html
http://www.esa.int/esapub/tm/tm19/TM-19_ptA.pdf
http://www.esa.int/esapub/tm/tm19/TM-19_ptB.pdf
http://www.esa.int/esapub/tm/tm19/TM-19_ptB.pdf
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To compute the interferogram and the coherence bands, apply the Interferogram Formation operator (under 
Radar > Interferometric > Products). Select the coregistered stack you generated in the previous step as 
an input and make sure to check the boxes: 
 
Á Subtract flat -earth phase : The flat-earth phase is the phase present in the interferometric signal 

due to the curvature of the reference surface. The flat-earth phase is estimated using the orbital 
metadata information and subtracted from the complex interferogram. 

Á Include coherence estimation : This produces a coherence band in the output calculated based 
on a window of 10 x 3 pixels in range/azimuth direction based on equation 1.13 in ESA TM-19C. 

 
Please do not  check ñSubtract topographic phaseò, because this is the information if interest.    
 
 

 

Figure 12: Interferogram Formation  

 

The resulting product will contain the interferogram (Phase_ifg _IWé) and the coherence (coh_IW_... ) 

as separate bands (Figure 13). Double click them to check for their quality.  
 
The interferogram is displayed in a rainbow color scale ranging from -ˊ to +ˊ and contains variations from 
topography, atmosphere and potential surface deformation (considered zero). The patterns, also called 
fringesò represent a full 2ˊ cycle and appear in an interferogram as cycles of arbitrary colors, with each 
cycle representing half the sensorôs wavelength (Figure 13).  
 
The coherence shows the areas where the phase information is coherent, which means that it can be used 
to measure topography (as in this tutorial) or deformation (includes removing the topographic phase). While 
large areas show coherence values above 0.5, agricultural areas are dark and have low coherence (below 
0.3). Accordingly, phase information over agricultural areas is not usable here. If low coherence areas are 
too dominant in the image, the later unwrapping will fail and produce faulty or random results.  
 

https://www.esa.int/esapub/tm/tm19/TM-19_ptC.pdf
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Figure 13: Interferogram (top) and coherence (bottom ) 

 

Multilooking  
Multilooking allows to decrease the spatial 
resolution of SAR data without losing the 
complex information contained in the 
interferogram. It is not a mandatory step but 
helps to reduce the size of the processed 
data while increasing the quality of the data 
because noise is reduced. The number of 
looks has to be decided according to the level 
of noise, the extent of the dataset and the 
scale of the patterns of interest.   
 
Select the interferogram product and open 
the Multilooking operator (under Radar > 
Utilities). The only thing to adjust is the 
Number of Range Looks to 2. The Number of 
Azimuth Looks will automatically be updated 
accordingly (as long as GR Square Pixel is 
checked, both numbers are equally 
increased). The resulting ground range 
resolution will be 4.17 meters in the bottom 
field (Figure 14).  
 

 

Figure 14: Multilooking of the interferogram  
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Goldstein Phase Filtering  
Interferometric phase can be corrupted by noise from temporal and geometric decorrelation, volume 
scattering, and other processing errors. Phase information in decorrelated areas cannot be restored, but 
the quality of the fringes existing in the interferogram can be increased by applying specialized phase filters, 
such as the Goldstein filter which uses a Fast Fourier Transformation (FFT) to enhance the signal-to-noise 
ratio of the image.  
 
A filtered phase image is required for a proper unwrapping in the subsequent step. A detailed description 
of this filter and its parameters is given in the publication of Goldstein & Werner (1998).  
 
Apply the Goldstein Phase Filtering (under Radar > Interferometric > Filtering) to the multilooked image. If 
many artificial objects are in the image, you can reduce the Adaptive Filter Exponent. The output is a filtered 
phase image (Figure 15), the coherence is not affected.  
 

 

Figure 15: Interferogram  before (left) and after (right) Multilooking and Goldstein phase filtering  

 

Phase Unwrapping  
In the interferogram, the interferometric phase is ambiguous and only known within the scale of 2ˊ. To be 
able to relate the interferometric phase to the topographic height, the phase must first be unwrapped. The 
altitude of ambiguity is defined as the altitude difference that generates an interferometric phase change of 
2ˊ after interferogram flattening. 
 
Phase unwrapping solves this ambiguity by integrating phase difference between neighboring pixels. After 
deleting any integer number of altitudes of ambiguity (equivalent to an integer number of 2ˊ phase cycles), 
the phase variation between two points on the flattened interferogram provides a measurement of the actual 
altitude variation (Figure 16). Accordingly, unwrapped results should be interpreted as a relative 
height/displacement between pixels of two images.  

https://agupubs.onlinelibrary.wiley.com/doi/abs/10.1029/1998GL900033



