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Polarimetric Tutorial 

The goal of this tutorial is to provide novice and experienced remote sensing users with step-by-step 
instructions on working with Radarsat-2 data with the Sentinel-1 Toolbox.  In this tutorial you will process a 
quad-pol Radarsat-2 product and produce polarimetric classifications of the data. 

For an introduction to polarimetric concepts, please see the "Radar Polarimetry" chapter of the 
"Fundamentals of Remote Sensing" tutorial from the Canadian Centre for Remote Sensing (CCRS). 
Furthermore, the theoretical Polarimetry Tutorial by ESA is highly recommended. 

SNAP supports polarimetric analyses for SLC products of many quad-pol radar satellites, such as Radarsat-
2, TerraSAR-X, or ALOS PALSAR 1 & 2.  

The functionalities demonstrated in this tutorial depend on the availability of four channels: HH + HV + VH 
+ VV. This means, they cannot be applied to dual-pol satellites, such as Sentinel-1 or ENVISAT ASAR. Yet,
some limited functionality is also provided for dual-pol SLC products, such as the dual-pol HA-Alpha
Decomposition or  the unsupervised Pottier dual-pol classification.

Download the Product 

Yet, to make the quad-pol data accessible for testing, the following page offers to download sample data in 
accordance with the distributors, such as ALOS-2, Radarsat-2, and ALOS-1 which are supported by the S1 
Toolbox (Figure 1). https://ietr-lab.univ-rennes1.fr/polsarpro-bio/san-francisco/   
Besides these sensors, TanDEM-X is supported in SNAP which operated in polarimetric mode for a short 
phase, but these data are not openly available for download.  

Figure 1: Download of sample quad-pol radar data 

All datasets offered on this site cover the city of San Francisco because it has been widely used as a 
reference area for the development of new polarimetric techniques. In this tutorial, we download the 
RADARSAT-2 dataset which has a file size of 550 MB in zipped form and about 790 in unzipped form. 
Most of the steps in this tutorial can be as well applied to the ALOS-2 and ALOS-1 dataset as well.  

http://www.nrcan.gc.ca/earth-sciences/geomatics/satellite-imagery-air-photos/satellite-imagery-products/educational-resources/9579
https://www.nrcan.gc.ca/maps-tools-publications/satellite-imagery-air-photos/remote-sensing-tutorials/fundamentals-remote-sensing-introduction/9363
https://earth.esa.int/web/polsarpro/polarimetry-tutorial
https://ietr-lab.univ-rennes1.fr/polsarpro-bio/san-francisco/
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As some of the required steps are computationally intensive, it is good to store and extract the data at a 
location which offers good reading and writing speed. If your computer has an internal SSD, processing 
should be done there to ensure best performance. Network drives or external storage devices are not 
recommended. Also, paths which include special characters should be avoided. In this tutorial, the data is 
stored under C:\Temp\R2\. 

 

Open the Products 
 
Use File > Import > SAR sensors > RADARSAT-2 to open the 
dialogue for file selection. Navigate to the extracted folders and 
select the product.xml file and confirm with Import Product.  

 
In the Products View you will see the opened products. Each 
Radarsat-2 product consists of Metadata, Vector Data, Tie-Point 
Grids, Quicklooks and Bands (which contains the actual raster 
data, represented by i_HH, q_HH as the real and imaginary parts 

of the complex radar product and the resulting intensity as 
demonstrated in Figure 2).  
 
Double-click on the Intensity_HH band to view the raster data 

(Figure 3). Depending on the capabilities of your computer, this 
might take a while.  
 
To identify the location of the area of interest within the entire 
product, you can use the World View or World Map (to see its full 
extent on a base map) or open the Quicklook for a preview of the 
dataset. 
 
Note: If you miss any items in your user interface you can activate 
them in the menu under View and Tool Windows.  

 

Figure 2:  Product Explorer  

https://en.wikipedia.org/wiki/Solid-state_drive
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Figure 3: Preview of the R2 product  
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Create a Subset 
 
To reduce the loaded data to the area of interest, select each of the two products and open the open the 
Subset operator (under Raster). A separate window might open (“Creating thumbnail image”), but this takes 
quite a long time, so it is ok to Cancel this window.  
 
Enter the following pixel coordinates (Figure 4): 
 

▪ Scene start X: 400 
▪ Scene start Y:  7000 
▪ Scene end X: 2300 
▪ Scene end Y:  12000  

 
Confirm with Run. A new product is shown in the Product Explorer, starting with subset_0_of_. This 

product is only of temporary nature and lost after SNAP is closed. To permanently store it, right-click on the 
products, select Save Product As… and save them in BEAM DIMAP format under the name 
R2_subset.dim 

 
 

 

Figure 4: Creation of a subset 
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Calibration 
 
To properly work with the SAR data, the data should first be calibrated. Calibration radiometrically corrects 
a SAR image so that the pixel values truly represent the radar backscatter of the reflecting surface. It is 
therefore essential for quantitative use of SAR data. 
 
The corrections that get applied during calibration are mission-specific, therefore the software will 
automatically determine what kind of input product you have and what corrections need to be applied based 
on the product’s metadata.  
 
Open the Calibration operator (under Radar > Radiometric) and select the newly created subset as an 
input. The target product will be the new file you will create (R2_subset_Cal.dim). Also select the 

directory in which the target product will be saved to. 
 
If you don’t select any source bands, then the calibration operator will automatically select all real and 
imaginary (i and q) bands. 
 

Important: For polarimetric processing the data must be complex. By default, the calibration 
operator will produce real sigma0 bands. To produce complex output, check mark the Save 
in complex parameter. 

 
 

 

Figure 5: Complex calibration of the Radarsat-2 product 

 

Confirm with Run to start the processing. The output product will appear in the Product Explorer and can 
now be used for the polarimetric tools which are shortly introduced in the following.   
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Polarimetric processing 
 
In order to properly exploit the information within polarimetric data, you will need processing tools that 
convert that data into more useable forms for analysis.  
 
Note: Geocoding of the product, such as conducted by Range Doppler Terrain Correction, is usually 
conducted as a last step in order to preserve the original pixel values for polarimetric analysis as long as 
possible. It is explained at a later point of this tutorial. 
 
SNAP includes the following polarimetric tools 
(found under Radar > Polarimetric): 

▪  
▪ Polarimetric Matrix Generation 
▪ Polarimetric Speckle Filtering 
▪ Polarimetric Decompositions 
▪ Polarimetric Classification 
▪ Orientation Angle Correction 
▪ Polarimetric Parameters 
▪ Cross Channel SNR Correction 
▪ Compact Polarimetry 

 
 
Each module comes with a Help section which 
describes the purpose and usage of the tool. The 
reader is advised to consult the help section for 
operators which are not explained in the following.   

Figure 6: Help section of SNAP 

 

 

Figure 7: Polarimetric tools in SNAP  
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Polarimetric Matrix Generation 

 
Polarimetric datasets can be translated into different matrix representations which contain a re-organized 
form of the information for later analysis (Cloude & Pottier 1996). 
 
All the polarimetric tools work with either Coherency (T) or Covariance (C) matrices as input. Starting from 
a Quad Pol SLC product, you may use the Matrix Generation operator to convert the product into one of 
the following matrices: 
 

▪ Covariance matrix C2 
▪ Covariance matrix C3 
▪ Covariance matrix C4 
▪ Coherency matrix T3 
▪ Coherency matrix T4 

 
For simplicity, any polarimetric operator also takes the calibrated SLC products as input. In such a case, 
the input quad-pol product will automatically be converted to a T3 matrix. 
 
The Coherency matrix T3 is often preferred 
because its elements allow a physical interpretation 
(odd-bounce, even-bounce, diffuse, etc.) while the 
Covariance matrix C3 is an incoherent polarimetric 
representation relating to second order statistics of 
scattering matrix elements 
 
Use the Matrix Generation operator when you would 
like to explicitly select which matrix to use. After 
generation of the matrix, the original bands (HH + 
HV + VH + VV) are no longer in the product, 
because they have been replaced by the matrix 
notations, e.g. C11, C22 and C33.  
 
These can then be used for the creation of an RGB 
image (Figure 8). The differences between T3 and C3 
are exemplified in Figure 9.  

 

Figure 8: RGB image of the C3 matrix 

 

 

Figure 9: RGB images of the Covariance (C3, left) and Coherency (T3, right) matrix  

https://ieeexplore.ieee.org/abstract/document/485127
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Polarimetric Speckle Filter 

 
To clean up some of the speckle inherent in SAR images, you can apply a speckle filter. When working 
with a single polarized detected or SLC image, you may use the conventional speckle filters found in the 
SAR Processing menu. However, for full polarimetric data, there are polarimetric speckle filters available 
that take advantage of all bands and preserve the complex information. 
 
The following filters can be selected from the menu for polarimetric speckle filtering: 

▪ Boxcar 
▪ Improved Lee Sigma 
▪ Refined Lee 
▪ Intensity Driven Adaptive Neighborhood (IDAN) 

 

 

Figure 10: Polarimetric Speckle Filter 

 

 

Figure 11: Unfiltered T3 matrix (left) compared to Refined lee (middle) and IDAN (right) filter  
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Polarimetric Decomposition 

 
Polarimetric decompositions allow the separation of different scattering contributions and can be used to 
extract information about the scattering process. The following polarimetric decompositions are available: 
 

▪ Sinclair 
▪ Pauli 
▪ (Generalized) Freeman-Durden 
▪ Yamaguchi 

▪ Van Zyl 
▪ Cloude 
▪ H-a Alpha 
▪ Touzi 

 
To produce a decomposition, select the T-matrix product as input and 
chose from the drop-down menu in the Polarimetric Decomposition 
operator, for example the Freeman-Durden Decomposition.  
 
The Window Size defines the kernel over which the decomposition is 
calculated. The standard is 5 x 5 pixels. It is good practice to include 
the name of the decomposition and the kernel size in the target name 
for later recognition.  
 
The output product will consist of three bands (or four for the Yamaguchi 
decomposition) representing certain scattering mechanisms, for 
example double bounce (red), volume scattering (green) and surface 
scattering (blue) as displayed in Figure 12, which can again be 
displayed as an RGB image (Figure 13, example from Vancouver).  

 

Figure 12: Result of the FD 
decomposition 

 
 

 

Figure 13: Scattering mechanisms in the Freeman-Durden Decomposition  
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As all created products originate from the same dataset (e.g. R2_subset_Cal_T3.dim), they have the 

exact same dimensions (number of columns and rows, and pixel size). This allows to make use of their 
bands simultaneously in the Band Maths operator or in the RGB view generator. For example, the Alpha 
band of the Touzi decomposition can be imported combined with the red component of the Pauli 
decomposition and the volume component of the Freeman Durden decomposition, as demonstrated in 
Figure 14 and Figure 15 (left). 
 

 

Figure 14: Import of bands of other products in the RGB view generator 

 

The same applies for the Scatter Plot tool  which compares two raster datasets at a pixel basis in a 
cartesian coordinate system. In Figure 15 (left) volume scattering of the Yamaguchi decomposition is 
represented by the x axis and volume scattering of the Freeman Durden decomposition by the y axis.  
 
This allows to analyze how both decompositions are different and which pixels are affected: Right-click in 
the plot > Select mask ‘scatter_plot_area’ to define an area in the plot (displayed as red ellipse). The 
pixels inside the ellipse are then colored red in the image view.  
 
  

  

Figure 15. Combinations of decompositions in the RGB view (left) and the Scatter Plot (right)  
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Unsupervised Classification 

 
Using the speckle filtered T3 product as input, we will now process the unsupervised polarimetric 
classification to group similar pixels into classes. Unsupervised classification does not rely on user specified 
input or predefined classes to be matched. Instead, it automatically determines what classes exist in the 
data and how best each pixel can be grouped. 
 
Select the Polarimetric Unsupervised Classification module (in Radar > Polarimetric > Polarimetric 
Classification). In the Processing Parameters tab, select the H Alpha Wishart classification (Figure 16) 
and confirm with Run. When the processing completes, your new classification results product will have a 
single band with several regions each belonging to one of nine classes. 
 

 

Figure 16: Unsupervised Wishart classification 

 
You may change the default colors for each class within the color manipulation tool window. Use the pull-
down control on the color to select a new color. Use the export and import buttons on the right-hand side 
to save and load color look-up tables. 
 

 

Figure 17: Unsupervised Wishart classification – result  
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Both the Cloude-Pottier and the Wishart classifiers are based on the use of the Entropy (H) / Alpha (α) 
plane. The Wishart classifier will continue to compute the centers of the nine clusters, and then reclassify 
the pixels based on their Wishart distances to cluster centers. 
 
The classes can be interpreted according to the H-α classification plane. To understand their distribution, 
first calculate the H-A-Alpha Quad Pol Decomposition, generating Entropy, Anisotropy and Alpha (Figure 

18). Then open one of the created bands (e.g. Entropy), start the H-α Alpha Plot tool  (under View > 

Tool Windows > Radar) and load the graph by clicking Refresh View  (Figure 19).  
 

 

Figure 18: H-α classification  

 

 

Figure 19: H-α classification plane 
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Note: SNAP also offers to perform the H- classification on dual-pol products (such as provided by Sentinel-
1), but because of the lack of co-pol information (HH), it is of limited informative value. This is compared 
and discussed in many studies, for example by Xie et al. (2015), or Ji & Wu (2015). 

Compact Polarimetry 

 
The previous processing steps all referred to quadrature or fully polarimetric SAR data which requires that 
the transmitted and received polarizations are orthogonal pairs. In contrast to this concept, compact 
polarimetry (CP) transmits circular polarization (at 45 degree or shifted in phase by 90 degree) and receives 
two orthogonal, mutually coherent linear polarizations. A detailed description is given in Charbonneau et al. 
(2010): Compact polarimetry: Overview and applications assessment. 
 
This special configuration is currently supported by only few missions, but SNAP allows to simulate compact 
polarimetric products from quad-pol data to test its potential for different applications.  
 
Open the CP Simulation and select the calibrated product as an input. As we want a right circular output, 
select R2_subset_Cal_cpRC as target name. In the second tab, select Right Circular Hybrid Mode and 

the Covariance Matrix C2 as output format (Figure 20).  
 
 

  

Figure 20: Simulation of compact polarimetric products 

 
 
The output is the complex covariance matrix with the elements C11 and C22. These can be input for the 
estimation for the CP Stokes Parameters operator, which can be used to describe partially polarized 
electromagnetic waves in terms of the degree of polarization, as suggested by Stokes (1901). The output 
is a product containing the actual Stokes parameters (g0, g1, g2 and g3), as well as all parameters selected 

in the operator (Figure 21, left).  
 
As different decompositions were designed for compact polarimetric data, the m-chi decomposition 
developed by Raney et al. (2012) is calculated in the following using the CP Decomposition operator.  
 

https://www.tandfonline.com/doi/abs/10.1080/2150704X.2015.1026954
https://www.mdpi.com/2072-4292/7/6/7447
https://www.tandfonline.com/doi/abs/10.5589/m10-062?journalCode=ujrs20
https://www.tandfonline.com/doi/abs/10.5589/m10-062?journalCode=ujrs20
https://www.cambridge.org/core/books/mathematical-and-physical-papers/on-the-composition-and-resolution-of-streams-of-polarized-light-from-different-sources/A021426E1F3E9BD366E8E1F967FBE3CE
https://agupubs.onlinelibrary.wiley.com/doi/full/10.1029/2011JE003986
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Figure 21: Calculation of Stokes parameters (left) and RGB of g0, g1 and g2 (right)  

 

  

Figure 22: M-Chi decomposition (left) and RGB of red, green and blue components (right)  
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Terrain Correction 
Terrain Correction will geocode the image by correcting SAR geometric distortions using a digital elevation 
model (DEM) and producing a map projected product. 
 
Geocoding converts an image from slant range or ground range geometry into a map coordinate system. 
Terrain geocoding involves using a Digital Elevation Model (DEM) to correct for inherent geometric 
distortions, such as foreshortening, layover and shadow (Figure 23). More information on these effects is 
given in the ESA radar course materials.  
 
 

 

Figure 23: Geometric distortions in radar images (Braun 2019) 

 

Open the Range Doppler Terrain Correction operator (under Radar > Geometric > Terrain Correction). 
Select the any of the polarimetric products as an input in the first tab (here: Pauli decomposition).  
 
In the Processing Parameters tab, select SRTM 1Sec HGT (AutoDownload) as input DEM (Figure 24).  
 
Please be aware that SRTM is only available between 60° North and 54° South. If your area lies outside 
this coverage (https://www2.jpl.nasa.gov/srtm/coverage.html), you can use one of the other DEMs with 
AutoDownload option or use an external DEM (just make sure it stored as a GeoTiff and projected in 
geographic coordinates / WGS84).  
 
If you want to export the data as a KMZ file to view it in Google Earth WGS84 must be selected as Map 
Projection. It is based on geographic coordinates (latitude and longitude). For the later use in a geographic 
information system (GIS) a metric map projection, such as UTM (Automatic) could be selected as well.  
 
If no Source Band is selected, all bands of the input product are geometrically corrected. As the polarimetric 
data potentially contains information on the water surface, we can disable Mask out areas without 
elevation, so water areas will not be removed in the output product.  
 
Click on Run to start the terrain correction. SNAP now establishes a connection to an external elevation 
database to download all SRTM tiles required to fully cover the input dataset.   
 

https://earth.esa.int/web/guest/missions/esa-operational-eo-missions/ers/instruments/sar/applications/radar-courses/content-3/-/asset_publisher/mQ9R7ZVkKg5P/content/radar-course-3-slant-range-ground-range
hdl.handle.net/10900/91317
https://www2.jpl.nasa.gov/srtm/coverage.html


Radarsat-2 Polarimetry Tutorial

  

17 

  

Figure 24: Range Doppler Terrain Correction 

 
 
The output is a geocoded SAR product (Figure 25, left) and can be used for further analyses. You can also 
convert it to a KMZ file which can be opened in Google Earth to view the data on a satellite image base 
map by selecting File > Export > Other > View As Google Earth KMZ (Figure 25, right)  
 

 

Figure 25: Geocoded Pauli decomposition in SNAP (left) and Google Earth (right)  
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Suggestions for further analyses 

Correlative Plot  

 
The Correlative Plot view offers to compare values of a selected raster with external data, for example 
values which were independently collected at selected locations in the area of interest. In this case, we 
want to compare the building density with polarimetric radar measures.  
The building density was calculated for a radius of 100 meters based on building footprints provided by 
OpenStreetMap and extracted at 134 points at regular intervals for a subset of the area (Figure 26).   
 

 

Figure 26: Stratified random sampling for the calculation of building density 

 
These points are stored as an ESRI Shapefile which is attached to this document. Extract the zip file at a 
suitable location and import these points by selecting the terrain corrected Pauli decomposition from the 
previous step) in the Product Explorer and navigating to Menu > Vector > Import > ESRI Shapefile.  
Note: You can only import shapefiles if the name of a product (not a band within) is selected in the Product 
Explorer Open the downloaded file in the subsequent dialogue and confirm with Open.  
 
The points now occur as white crosses on the opened image. Feel free to change their styling by selecting 

it the Layer Manager and opening the Layer Editor . It should now look like displayed in Figure 27 
 

 

Figure 27: Point vector data imported into SNAP  

https://download.geofabrik.de/north-america/us/california.html
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Now open the Correlative Plot view  and click on a raster band within the product the Product Explorer, 
e.g. Pauli_r. Select building_density_100m_SNAP_subset as Point data source and dens for the Data 
field. The correlative plot view shows the values of the raster on the y-axis and the values of the point 
attributes on the x-axis (Figure 28).  
 
You can also display the linear regression which best fits this trend by activating Show Regression line. 
The linear regression indicates a positive linear relationship between both variables with a coefficient of 
determination (R²) of 0.72. This means 72 % of the variance of the building density could be explained by 
the red component of the Pauli decomposition (indicating double bounce). In turn, the green (volume 
scattering) and blue (surface scattering) components only have an R² of 0.1 and 0.35 respectively.  
 

 

Figure 28: Correlative Plot – scatterplot view 

 
Of course, this relationship is only valid for land areas. We will therefore make a simpl classification of major 
surface types in the next step.  
 
 

Working with the Mask Manager 

 

The Mask Manager   allows to apply logic or mathematic expressions on the pixels of an image product 
to see which of them fulfill certain conditions. A raster product (or RGB composite) must be opened in the 
current view for the tools of the Mask Manager to become active.  
 
We use the (terrain corrected) Yamaguchi decomposition for a test of the mask manager. In a first step, we 

create a water mask, using this button . In the expression dialogue (Figure 29), we enter this term:  
 
Yamaguchi_vol_g <= -18  
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Figure 29: Usage of the mask manager 

 
This creates a mask which is true for all pixels with values smaller or equal -18 in the green Yamaguchi 
component (initially colored in red) and zero for all other pixels (transparent). Double-click the entry in the 
Color column to change its color to blue and se the name to “water” (Figure 30).  
 

 

Figure 30: Water mask 

 
Note: To change the expression of a mask, double-click on Maths and the Expression editor opens again. 
Changes in the Description field have no consequences.  
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Combined expressions in the Mask Manager 

 

Now, we create an “urban” mask by adding another mask  with the following expression:  
 
Yamaguchi_vol_g > -18 AND Yamaguchi_dbl_r > -15 AND Yamaguchi_dbl_r 

 

• The first part (volume > -18) makes sure that the urban mask does not contain any pixel from the 
water mask.  

• The second part (double > -15) selects all pixels with high double bounce 

• The third part (Yamaguchi) removes all pixels with NoData values 
 
 
The third mask “vegetation” shall contain all remaining pixels. We define it using this expression: 
 
NOT urban AND NOT water AND Yamaguchi_dbl_r 

 

• The first part (not urban) excludes all urban pixels 

• The second part (not water) excludes all water areas 

• The third part (Yamaguchi) again removes all pixels with NoData values 
 
We then have three masks which are mutually exclusive (no pixel is assigned to more than one class) and 
represent the major landcover classes in the image (Figure 31). 
 

 

Figure 31: Definition of landcover classes in the Mask Manager 

 

 

Figure 32: Yamaguchi decomposition (left) and landcover classes (right)  
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Export correlative plot data 

 
The chart in Fehler! Verweisquelle konnte nicht gefunden werden. was created in MS Excel and 
compares values of the red Freeman Durden component (indicating double bounce) with the building 
density extracted at these points. It was created using the Correlative Plot view, as previously described. 
The actual values of the raster band and the point attributes can be viewed and extracted by clicking Switch 

to Table View  . This displays the points as a table including the latitude, longitude and raster values 
(Freeman_dbl_r_mean) and the point values (dens_ref) as displayed in Figure 33. 
 
You can export these data as a txt file by right-clicking in the table and selecting Copy Data to Clipboard.  
 
 
 

 

Figure 33: Correlative Plot – table view  

 
The plot indicates a linear relationship and the R² of 0.96 underlines a large agreement between the building 
density and the red component of the Freeman Durden decomposition. To apply this relationship to the 
entire image, the regression formula must be structured in a way that the building density is the dependent 
y variable and the raster is the independent (or explanatory) x variable.  
 

 

Figure 34 Relationship between FD double bounce (x) and building density (y)  

y = 2,7524x + 62,485
R² = 0,9657
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Transfer of masks between products 

 
We want to apply the regression from Figure 34 to the urban areas of the radar image so that we can have 
an estimate on building density based on FD double bounce. 
 
First, we must transfer the urban mask from the Yamaguchi product to the Freeman Durden product. This 
can be done by opening the Band Maths of the Freeman Durden product. 
 
Enter mask_urban as the name for the new band and remove the Virtual option. 
 
In the Expression Editor switch to the Yamaguchi decomposition product, as shown in Figure 35. This works 
because both products have exactly the same size and number of colums/rows (because they were treated 
similar in the Range Doppler Terrain correction).  
 
You can then select the mask $x.urban as the expression (only visible if you select Show masks).  

 

 

Figure 35: Import of the urban mask into the FD product 

 
Once you confirm with OK, the Freeman Durden product has a new band: mask_urban. Make these 
changes permanent by selecting File > Save Product.  
 

 

Figure 36: Freemann Durden decomposition  
with urban mask generated from the Yamaguchi decomposition  
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Applying a linear regression 

 
We now want to use the relationship between from Figure 34 to predict the building density in the Freeman 
Durden decomposition product. As this was only tested for urban areas, we use the mask transferred in the 
previous step.  
 
Right-click the terrain corrected Freeman Durden product and open the Band Maths.  
Enter building_density as the name for the new band and remove the Virtual option. Open the Expression 
Editor as shown in Figure 37 to create the following expression: 
 
2.7524 * Freeman_dbl_r + 62.485 

 

 

Figure 37: Applying a linear regression to a band 

 
Confirm with OK and make the new band permanent 
by selecting File > Save Product.  
 
Lastly, as this regression was only valid for urban 
areas, we now use the band “mask_urban” to serve 
as a valid pixel expression.  
 
Open the band properties of building_density and 
enter mask_urban in the Valid-Pixel Expression as 

shown in Figure 38. This makes all pixels transparent 
which lay outside the masked urban areas.  
 
Open the new raster and select a suitable color scale 
in the Color Manipulation tab to visualize it.  
 
All geocoded products (projected to WGS84) can 
be exported as a KMZ file to view them in Google 
Earth with File > Export > Other > View As 
Google Earth KMZ (Figure 39). 

 

Figure 38: Editing the valid-pixel expression 

https://www.google.com/earth/download/gep/agree.html
https://www.google.com/earth/download/gep/agree.html


Radarsat-2 Polarimetry Tutorial

  

25 

 

Figure 39: Building density exported to Google Earth 

 
 
 

 

 
 

For more tutorials visit the Sentinel Toolboxes website 
http://step.esa.int/main/doc/tutorials/ 

 
 

Send comments to the SNAP Forum 
http://forum.step.esa.int/ 

http://step.esa.int/main/doc/tutorials/
http://forum.step.esa.int/
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building_density_100m_SNAP_subset.prj

GEOGCS["GCS_WGS_1984",DATUM["D_WGS_1984",SPHEROID["WGS_1984",6378137.0,298.257223563]],PRIMEM["Greenwich",0.0],UNIT["Degree",0.0174532925199433]]






building_density_100m_SNAP_subset.qpj

GEOGCS["WGS 84",DATUM["WGS_1984",SPHEROID["WGS 84",6378137,298.257223563,AUTHORITY["EPSG","7030"]],AUTHORITY["EPSG","6326"]],PRIMEM["Greenwich",0,AUTHORITY["EPSG","8901"]],UNIT["degree",0.0174532925199433,AUTHORITY["EPSG","9122"]],AUTHORITY["EPSG","4326"]]







building_density_100m_SNAP_subset.shp





building_density_100m_SNAP_subset.shx



