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Interferometry Tutorial 
The goal of this tutorial is to provide novice and experienced remote sensing users with step-by-step 
instructions on interferometric processing with Sentinel-1 IW products for DEM generation.  

Background 

What is Interferometry? 
Interferometric synthetic aperture radar (InSAR) exploits the phase difference between two complex SAR 
images taken from slightly different sensor positions and extracts information about the earth’s surface. 
 
A SAR signal contains amplitude and phase information. The amplitude is the strength of the radar 
response and the phase is the fraction of one complete sine wave cycle (a single SAR wavelength). It is 
primarily determined by the distance between the satellite antenna and the ground targets. 
 
By combining the phase of two images after coregistration, an interferogram can be generated whose 
information is highly correlated to topography. However, there are many other contributions to the 
interferogram which potentially decrease the quality of the resulting elevation product, such as atmospheric 
disturbances, unwrapping errors and decorrelation due to surface changes.  
 
Further reading: InSAR Principles: Guidelines for SAR Interferometry Processing and Interpretation  
 
To cite this tutorial, and for a comprehensive introduction to the generation of digital elevation models with 
Sentinel-1 please refer to this review paper:   
• Braun, A. (2021): Retrieval of digital elevation models from Sentinel-1 radar data – open applications, 

techniques, and limitations. Open Geosciences, 13(1), 532-569. doi:10.1515/geo-2020-0246 
 

Sentinel-1 Interferometric Wide Swath Products 
The Interferometric Wide (IW) swath mode is the main acquisition mode over land for Sentinel-1. It acquires 
data with a 250 km swath at 5 m by 20 m spatial resolution (single look). IW mode captures three sub-
swaths using Terrain Observation with Progressive Scans SAR (TOPSAR). With the TOPSAR technique, 
in addition to steering the beam in range as in ScanSAR, the beam is also electronically steered from 
backward to forward in the azimuth direction for each burst, avoiding scalloping and resulting in 
homogeneous image quality throughout the swath. 
 
TOPSAR mode replaces the conventional ScanSAR mode, achieving the same coverage and resolution 
as ScanSAR, but with a nearly uniform SNR (Signal-to-Noise Ratio) and DTAR (Distributed Target 
Ambiguity Ratio). 
 
IW SLC products consist of three sub-swaths (Figure 1, red labels) image per polarization channel, for a 
total of three (single polarizations) or six (dual polarization) images in an IW product. Each sub-swath image 
consists of a series of bursts (Figure 1, white labels), where each burst has been processed as a separate 
SLC image. The individually focused complex burst images are included, in azimuth-time order, into a single 
sub-swath image with black-fill demarcation in between, similar to ENVISAT ASAR Wide ScanSAR SLC 
products. 
 
More information on Sentinel-1 IW products is provided here: https://sentinel.esa.int/web/sentinel/user-
guides/sentinel-1-sar/acquisition-modes/interferometric-wide-swath. 
 
The data used in this tutorial lies in eastern Turkey and includes the city of Erzincan and its surrounding 
landscapes. Figure 2 shows the extent of the Sentinel-1 data (red) and of the subset used in this tutorial 
(blue).  

http://www.esa.int/esaMI/ESA_Publications/SEM867MJC0F_0.html
https://doi.org/10.1515/geo-2020-0246
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/acquisition-modes/interferometric-wide-swath
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/acquisition-modes/interferometric-wide-swath
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Figure 1: Sub-swaths (red) and bursts (white) of S1 IW products 

 

 
Figure 2: Extent and location of the data  
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Preparation 

Selection of suitable images 
A crucial step for a successful DEM generation is the selection of an image pair with suitable properties. 
Among others, favorable conditions include: 
 
• Short temporal baseline: The time between the first and the second image should be kept as short as 

possible to reduce the risk of temporal decorrelation of the phase. Whenever surfaces change between 
the first and the second acquisition, the signal will be out-of-phase and no longer exploitable (Figure 3, 
right). This happens over vegetation and water areas, but also under changing moisture conditions, 
moving objects ect. Especially C-band radar (Sentinel-1) is prone to temporal decorrelation because of 
the comparable short wavelength. Smaller areas of decorrelations are tolerable but large parts of the 
image should produce an interferogram with clearly visible fringes and high coherence (see chapter 
“Interferogram Formation and Coherence Estimation”). Accordingly, generating DEMs from 
Sentinel-1 over vegetation areas will result in bad quality. If you have strong seasonality, try to find 
image pairs at times of minimum vegetation cover.  
 

• Suitable perpendicular baseline: The distance between the satellites’ positions at the time of image 
acquisition should be between 150 and 300 meters (ESA TM-19B, chapter 1.4). This grants an angle 
between both acquisitions which allows to retrieve topographic variations from parallax-like effects:  
targets of different heights are displaced relative to each other in the two images based on their altitude 
(Rosen et al. 2000). If the perpendicular is too small, these topographic effects on the differential phase 
are not pronounced enough. With too large baselines, the coherent phase is increasingly different, also 
leading to decorrelation. 
The Sentinel-1 mission was mainly designed for the retrieval of deformations (DInSAR) and not for 
DEM generation (Geudtner et al. 2016). Most of the baselines between two consecutive images are 
below 30 meters. Image pairs with short temporal baselines and large perpendicular baselines 
can be hard to find.  
 
A helpful tool to identify the baseline of two images and to find suitable image pairs is provided by the 
Alaska Satellite Facility: ASF Baseline tool 
 

• Suitable atmospheric conditions: Water vapor in the atmosphere causes phase delays and potentially 
decreases the quality of the measurement. It is therefore advisable to select images acquired during 
dry periods and to make sure that no rainfall occurred during both image acquisitions.  

 
 

 
Figure 3: Image geometry and phase decorrelation (Braun 2019)  

http://www.esa.int/esapub/tm/tm19/TM-19_ptB.pdf
http://www.grapenthin.org/teaching/geop572_2015/download/Rosen_etal_2000_InSAR.pdf
https://ieeexplore.ieee.org/abstract/document/7559247
https://baseline.asf.alaska.edu/#/baseline
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Download the Data 
The data used in this tutorial can be downloaded from the Copernicus Open Access Hub at:  
https://scihub.copernicus.eu/dhus (login required, registration is free) 
 
Search for the two product IDs and download them:  
S1B_IW_SLC__1SDV_20190702T032447_20190702T032514_016949_01FE47_69C5 
S1A_IW_SLC__1SDV_20190708T032532_20190708T032559_028020_032A14_33CA 
 
As some of the required steps are computationally intensive, it is good to store the data at a location which 
offers good reading and writing speed. If your computer has an internal SSD, processing should be done 
there to ensure best performance. Network drives or external storage devices are not recommended. Also, 
paths which include special characters should be avoided. In this tutorial, the data is stored under 
C:\Temp\S1_InSAR_DEM\. 

Install snaphu 
This tutorial can entirely be done within SNAP. Yet, as an external software package, snaphu (statistical-
cost network-flow algorithm for phase unwrapping) has to be installed separately. For more information on 
this tool, please visit https://web.stanford.edu/group/radar/softwareandlinks/sw/snaphu/. 
 
To install the plugin in SNAP, go to Plugins (under the Tools menu, Figure 4) and search for “SNAPHU 
Unwrapping” in the Available Plugins tab. Select it and click Install. 
 

 
Figure 4: The Plugins interface 

 
You will be asked to proceed with “Next” and restart SNAP (Figure 5). This creates a menu entry for snaphu 
unwrapping in the Interferometry menu. 

https://scihub.copernicus.eu/dhus
https://en.wikipedia.org/wiki/Solid-state_drive
https://web.stanford.edu/group/radar/softwareandlinks/sw/snaphu/
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Figure 5: Installation of the snaphu plugin 

 
After you have restarted SNAP, you need to install the snaphu bundles as well. Go to Manage External 
Tools in the Tools menu. Select “Snaphu-unwrapping” and click Edit the selected operator   to open 
the configuration (Figure 6). Select a suitable Target Folder (here C:\GIS) where snaphu will be installed 
and proceed with Download and Install Now. You will then get a confirmation “Bundle was installed in 
location C:\GIS\snaphu-v1.4.2_win64” (this may differ according to version, path and operating system).  
 

 
Figure 6: Installation of the snaphu bundles  
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Open the Products 
Use the Open Product button in the top toolbar 
and browse for the location of the downloaded data. 
Select the two zip files and press Open Product.  
 
In the Products View you will see the opened 
products. Each Sentinel-1 product consists of 
Metadata, Vector Data, Tie-Point Grids, Quicklooks 
and Bands (which contains the actual raster data, 
organized by polarization and sub-swath as 
demonstrated in Figure 1).  
 
As the data is still compressed in the zip file and 
each sub-swath covers a large area, it is not advised 
to open the bands in their current state, because it 
takes a considerable time until SNAP loads the 
raster. If you still want to check the data before 
proceeding double-click on the Intensity_IW1_VV 
band to view the raster data.  
 
Another way to identify the location of your study 
area within the product (required for the next step), 
you can use the World View or World Map (to see 
its full extent on a base map) or open the Quicklook 
for a preview of the dataset in an RGB color 
representation. 
 
Note: If you miss any items in your user interface 
you can activate them in the menu under View and 
Tool Windows.  
 
The World View or World Map menus are also a 
good way to check if your image belong to the same 
relative orbit (required for interferometry) and if they 
are shifted along-track, as it is the case here. It is 
not a problem for interferometry but needs to be 
taken into account in the next step (TOPS Split).   

Figure 7: Product Explorer and World Map 
 

Check baseline information 
As already indicated in the introduction, the quality which can be expected from DEM generation strongly 
depends on the properties of the two images, most importantly the position of the satellites at the time of 
acquisition. Their relative distance is called the perpendicular baseline (Figure 3). The larger this 
difference, the more details will be contained in the computed interferogram with respect to elevation 
changes. As shown in Figure 8, a perpendicular baseline of 151 meters will result in a higher density of 
fringe patterns and therefore be more suitable to describe terrain changes than baselines of 67 m or 27 m.  
 
The time between the first and the second image is called the temporal baseline. The shorter this period 
(at best 6 or 12 days for Sentinel-1) the lower is the loss of interferogram quality due to phase decorrelation, 
especially over natural surfaces. As shown in Figure 9, longer temporal baselines lead to bad interferogram 
quality. At these areas, no reliable height information cannot be extracted. If these areas become too 
dominant in the interferogram, no DEM can be extracted in general. 
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Figure 8: Effect of the perpendicular baseline on the interferogram (Braun 2021) 

 

 
Figure 9: Effect of the temporal baseline on the interferogram (Braun 2021) 

 
 
To check the baseline information of your image pair, open Radar > Interferometric > InSAR Stack 
Overview. First, click on “Add Opened” to load the two Sentinel-1 products into the list at the top. Their 
acquisiton date, track and orbit should now be displayed. 
Secondly, click “Overview” to load their metadata. The list at the bottom should then show information on  
• perpendicular baseline (Bperp) [meters] 
• temporal baseline (Btemp) [days] 
• the modelled cohererence [0-1] 
• height ambiguity [meters] how many meters of height difference are represented by one color cycle in the interferogram 
• the mean Doppler centroid frequency difference 

 

https://doi.org/10.1515/geo-2020-0246
https://doi.org/10.1515/geo-2020-0246
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Figure 10: InSAR Stack Overview 

 

Coregistration 
To exploit the phase difference of the acquisitions, a stack containing both products must be created first. 
Coregistration makes use of image statistics to align both products at sub-pixel accuracy. While 
conventional Stripmap radar products can be coregistered within one step, S1 TOPSAR products require 
a series of steps, because of their special form of acquisition (Figure 1).  
 
SNAP offers to combine all these steps within the S-1 TOPS Coregistration with ESD operator, but this 
processing chain consumes a lot of memory. In this tutorial, the single steps to correctly coregister the 
products are performed individually and successively.  
 

TOPS Split 
S-1 TOPS Split is applied to the data to select only those bursts which are required for the analysis. They 
are marked in blue in Figure 1. Currently, each Sub-Swath is processed separately. Note: If the area of 
interest covers several Sub-Swaths, they have to be merged with the S-1 TOPS Merge operator after the 
Sub-Swaths were debursted.  
 
To reduce the loaded data to the area of interest, open the S-1 TOPS Split operator (under Radar > 
Sentinel-1 TOPS) and select sub-swath IW2 and VV polarization in the Processing Parameters.  
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Because the two products are shifted along-track (Figure 7), different bursts have to be selected for each 
product. Reduce the bursts by dragging the grey triangles towards the middle as defined in the following 
table:  
 

Input product Subswath Polarisation Bursts  Output name 
S1B_IW_SLC__1SDV_20190702… IW2 VV 3 - 5 S1B_20190702_split 
S1A_IW_SLC__1SDV_20190708… IW2 VV 1 - 3 S1B_20190708_split 

 
Use the preview to check the location of the selected area (Figure 11). Confirm with Run and repeat the 
step for the second S1 image.  
 

 
Figure 11: TOPS Split 

 

Applying Orbit Information 
 
Orbit auxiliary data contain information about the position of the satellite during the acquisition of SAR 
data. They are automatically downloaded for Sentinel-1 products by SNAP and added to its metadata with 
the Apply Orbit File (under the menu point Radar) operator. 
 
The Precise Orbit Determination (POD) service for Sentinel-1 provides restituted orbit files and precise 
Orbit Ephemerides (POE) orbit files. POE files cover ca. 28 hours and contain orbit state vectors at intervals 
of 10 seconds intervals. Files are generated one file per day and are delivered within 20 days after data 
acquisition. 
If precise orbits are not yet available for your product, restituted orbits can be selected which may not be 
as accurate as the Precise orbits but will be better than the predicted orbits available within the product. 
 
Execute the operator for both split products as generated in the previous step (Figure 12).  
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Figure 12: Apply Orbit File 

 

Back Geocoding and Enhanced Spectral Diversity 
The S-1 Back Geocoding operator (under Radar > Coregistration > Sentinel-1 TOPS Coregistration) 
coregisters the two split products based on the orbit information added in the previous step and information 
from a digital elevation model (DEM) which is downloaded by SNAP.  
 
Add the products of the two dates (ending with “_split_Orb”) to the file list in the ProductSet-Reader tab and 
select SRTM 1Sec HGT (AutoDownload) in the Back-Geocoding tab (Figure 13).  
 
Please be aware that SRTM is only available between 60° North and 54° South. If your area lies outside 
this coverage (https://www2.jpl.nasa.gov/srtm/coverage.html), you can use one of the other DEMs with 
AutoDownload option or use an external DEM (just make sure it stored as a GeoTiff and projected in 
geographic coordinates / WGS84).  
 

  
Figure 13: Back Geocoding 

 
To increase the quality of the coregistration you apply the S-1 Enhanced Spectal Diversity (ESD) operator 
(under Radar > Coregistration > Sentinel-1 TOPS Coregistration) on the stack generated by the Back 
Geocoding. It applies range and azimuth shift corrections to the secondary image. 
  

https://www2.jpl.nasa.gov/srtm/coverage.html
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Note: This operator is only needed when you select more than one burst. If you only selected one burst in 
the TOPS Split step, you do not need the ESD operator.  
 
After the coregistration is completed, it is advisable to visually check the quality of the stack. This can be 
done by an RGB representation of the reference and secondary1 product which shows if the images are 
correctly aligned. Select the reference for red and green and the secondary image for blue (Figure 14) 2.  
 

  
Figure 14: Generation of an RGB image 

 
Zoom in to an area with distinct surfaces, for example the border between land and water. The RGB image 
should be clear and sharp and not be dominated by one of the images (yellow [red+green] for the reference 
or blue for the secondary image). The only exception are changes in landcover or scattering mechanisms 
which occurred in the time between the first and the second image acquisition (Figure 15).  
 
 

 
 

 
Figure 15: Successful (top) vs. failed (bottom) coregistration in an RGB image  

 
1 We support the statement of the executive committees of WInSAR and COMET to exchange the inappropriate terminology in all 
InSAR-related fields. Accordingly, the former "master/slave" will be replaced by "reference/secondary" in future versions of SNAP. 
2 https://www.scientificamerican.com/article/end-of-the-rainbow-new-map-scale-is-more-readable-by-people-who-are-color-blind/  

https://comet.nerc.ac.uk/about-comet/insar-terminology/
https://www.scientificamerican.com/article/end-of-the-rainbow-new-map-scale-is-more-readable-by-people-who-are-color-blind/
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Interferogram Formation and Coherence Estimation 
An interferogram is formed by cross multiplying the reference image with the complex conjugate of the 
secondary. The amplitude of both images is multiplied while the phase represents the phase difference 
between the two images. 
 
The interferometric phase of each SAR image pixel would depend only on the difference in the travel paths 
from each of the two SARs to the considered resolution cell. Accordingly, the computed interferogram 
contains phase variation 

https://earth.esa.int/workshops/ers97/program-details/speeches/rocca-et-al/
http://www.esa.int/esaMI/ESA_Publications/SEM867MJC0F_0.html
http://www.esa.int/esaMI/ESA_Publications/SEM867MJC0F_0.html
http://www.esa.int/esapub/tm/tm19/TM-19_ptA.pdf
http://www.esa.int/esapub/tm/tm19/TM-19_ptB.pdf
http://www.esa.int/esapub/tm/tm19/TM-19_ptB.pdf
https://ieeexplore.ieee.org/abstract/document/6351183
https://ieeexplore.ieee.org/abstract/document/6946711
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Because of the predominantly short perpendicular baselines and the comparably quick 
decorrelation of C-band SAR data, repeat-pass interferometry for DEM generation is 
challenging, especially over vegetated areas. So please be aware that, despite the higher 
spatial resolution, phase decorrelation will lead to errors and the resulting elevation data is 
not of better quality than of freely available DEMs, such as SRTM or AW3D30, in most cases.  

 
 
Coherence is calculated as a separate raster band and shows how similar each pixel is between the 
secondary and reference images in a scale from 0 to 1. Areas of high coherence will appear bright. Areas 
with poor coherence will be dark. In the image, vegetation is shown as having poor coherence and buildings 
have very high coherence. 
 
To compute the interferogram and the coherence bands, apply the Interferogram Formation operator (under 
Radar > Interferometric > Products). Select the coregistered stack you generated in the previous step as 
an input and make sure to check the boxes: 
 

 Subtract flat-earth phase: The flat-earth phase is the phase present in the interferometric signal 
due to the curvature of the reference surface. The flat-earth phase is estimated using the orbital 
metadata information and subtracted from the complex interferogram. 

 Include coherence estimation: This produces a coherence band in the output calculated based 
on a window of 10x3 pixels in range/azimuth direction based on equation 1.13 in ESA TM-19C. 

 
Please do not check “Subtract topographic phase”, because this is the information if interest.    
 

 
Figure 17: Interferogram Formation 

 
 
The resulting product will contain the interferogram (Phase_ifg_IW…) and the coherence (coh_IW_...) 
as separate bands (Figure 18). Double click them to check for their quality.  

https://www.usgs.gov/centers/eros/science/usgs-eros-archive-digital-elevation-shuttle-radar-topography-mission-srtm-1-arc?qt-science_center_objects=0#qt-science_center_objects
https://www.eorc.jaxa.jp/ALOS/en/aw3d30/index.htm
https://www.esa.int/esapub/tm/tm19/TM-19_ptC.pdf
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The interferogram is displayed in a rainbow color scale ranging from -
topography, atmosphere and potential surface deformation (considered zero). The patterns, also called 

appear in an interferogram as cycles of arbitrary colors, with each 
cycle representing half the sensor’s wavelength.  
 
To derive a DEM of sufficient quality, these fringes must be visible throughout the entire image. 
Areas of phase decorrelation appear as noise in the interferogram.  
 
The coherence shows the areas where the phase information is coherent, which means that it can be used 
to measure topography (as in this tutorial) or deformation (includes removing the topographic phase). While 
large areas show high coherence (above 0.6), river valleys are dark and have low coherence (below 0.3). 
Accordingly, phase information over low coherence areas will not produce correct elevation measures. If 
low coherence areas are too dominant in the image, the later unwrapping will fail and produce faulty or 
random results.  
 
 

 
Figure 18: Interferogram (top) and coherence (bottom) 

 
 

   
 

Figure 19: Histogram of interferogram (left) and coherence (right)  
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TOPS Deburst 
To remove the seamlines between the single bursts, the S-1 TOPS Deburst operator (under Radar > 
Sentinel-1 TOPS) is applied to the interferogram product. It does not require any user input (Figure 20). 
The output contains the same bands as the input, but with merged bursts according to their zero Doppler 
time. More information on this step is provided in the Sentinel-1 User Guide.  
 

 
Figure 20: TOPS Deburst (left) and Goldstein phase filtering (right) 

 

Goldstein Phase Filtering 
Interferometric phase can be corrupted by 
noise from temporal and geometric 
decorrelation, volume scattering, and other 
processing errors. Phase information in 
decorrelated areas cannot be restored, but 
the quality of the fringes existing in the 
interferogram can be increased by applying 
specialized phase filters, such as the 
Goldstein filter which uses a Fast Fourier 
Transformation (FFT) to enhance the signal-
to-noise ratio of the image. This is required 
for a proper unwrapping in the subsequent 
step. A detailed description of this filter and 
its parameters is given in the publication of 
Goldstein & Werner (1998).  
 
Apply the Goldstein Phase Filtering (under 
Radar > Interferometric > Filtering) to the 
debursted image. The output is a filtered 
phase image, the coherence is not affected.  

 
Figure 21: Interferogram before (left) and after (right) 

Goldstein phase filtering 

https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/acquisition-modes/interferometric-wide-swath
https://agupubs.onlinelibrary.wiley.com/doi/abs/10.1029/1998GL900033
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Create a Subset 
During the previous processing steps, empty pixels at the edge of the interferogram might have been 
introduced, for example in areas which are not covered by both input images. To crop these areas, the 
Subset (under Raster) operator can be used. This not only reduces the size of the processed data in the 
subsequent steps, but also prevents later unwrapping errors. Select the filtered product, start the Subset 
operator, enter the following pixel coordinates (Figure 22), and confirm with Run.  
 

 Scene start X: 1000 
 Scene start Y:  50 
 Scene end X: 25000 
 Scene end Y:  2750 

 
 

 
Figure 22: Creating a subset 

 
 

 
Figure 23: Interferogram before (top) and after (bottom) creating the subset 
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A new product is show in the Product Explorer, starting with subset_0_of_ for each subset. These 
products are only of temporary nature and lost after SNAP is closed. To permanently store them, right-click 
on the products, select Save Product As… and save them in BEAM DIMAP format under the name 
20190708_20190702_split_Orb_Stack_esd_ifg_deb_flt_subset 
 

Phase Unwrapping 

able to relate the interferometric phase to the topographic height, the phase must first be unwrapped. The 
altitude of ambiguity is defined as the altitude difference that generates an interferometric phase change of 

 
 
Phase unwrapping solves this ambiguity by integrating phase difference between neighboring pixels. After 
deleti
the phase variation between two points on the flattened interferogram provides a measurement of the actual 
altitude variation (Figure 24). Accordingly, unwrapped results should be interpreted as a relative 
height/displacement between pixels of two images.  
 
 
 

 
Figure 24: Principle of phase unwrapping 

 
 
For optimal unwrapping results it is recommended to filter the interferogram as done in the previous step 
and eventually apply multi-looking (under Raster > SAR Utilities). As the fringe patterns are quite fine scaled 
(Figure 21), no multi-looking is applied in this case.  
 
The quality and reliability of unwrapped results very much depends on the input coherence. Reliable results 
can only be expected in areas of high coherence. Although no definite threshold exists, a minimum 
coherence of 0.3 is suggested.  
 
Unwrapping in SNAP follows three distinct steps:  
 

1. Export of the wrapped phase (and definition of the parameters)  
2. Unwrapping of the phase (performed outside SNAP by snaphu) 
3. Import of the unwrapped phase back into SNAP 

 
Because snaphu is an independent software (see under the section “Install snaphu” at the beginning of this 
document), the unwrapping is executed outside SNAP, but the plugin allows to call this execution, so no 
command line processing is required any longer.  
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Depending on the capabilities of the system, the unwrapping can take a considerable amount of time. 
However, snaphu supports multi-threading which means that the computation can be distributed over 
multiple processor cores. This has to be defined during the export.  

Export 
The Export operator (under Radar > Interferometric > Unwrapping) converts the interferogram (as the 
wrapped phase) into a format which can be read by snaphu. Furthermore, a couple of parameters can be 
selected which affect the unwrapping process and stored in a configuration file which is accessed by 
snaphu.  
 
The source product is the subset created in the previous step. In the SnaphuExport tab, select your working 
directory as the target folder (here: C:\Temp\S1_InSAR_DEM). If the selection of the directory does not 
work, simply copy and paste the path of your working directory into the text field. Select TOPO as Statistical-
cost mode and select 200 pixels for Row Overlap and Column Overlap. Depending on the number of 
processors of your computer, you can also increase the Number of Processors variable.  
 
Note: You can neglect the eventual error message (Error: [NodeId: SnaphuExport Please add a target 
folder]. It will go away once you switch tabs or hit Run, as long as you have entered a valid target folder.  
 
To learn about the meaning and impact of all parameters, please consult the official documentation.  
 
 

 
Figure 25: Snaphu export 

 
Hit Run to start the export. A directory is created in your working directory with the same name as the 
product you selected as an input (here: 20190708_20190702_split_Orb_Stack_esd_ifg_deb_flt_subset). 
Inside this folder, you find:  
 

 the coherence: image (*.img) and metadata (*.hdr) 
 the wrapped phase: image (*.img) and metadata (*.hdr) 
 the unwrapped phase: only the metadata (*.hdr), because the image (*.img) is first to be created 

by snaphu in the next step.  
 a configuration file (snaphu.conf) containing the parameters defined in the export operator 

https://web.stanford.edu/group/radar/softwareandlinks/sw/snaphu/snaphu_man1.html
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Unwrapping with snaphu 
Once the product is exported correctly, the unwrapping can be started from within SNAP, by calling the 
Snaphu-unwrapping operator (under Radar > Interferometric > Unwrapping). As an input product, select 
the subset which was created before the export from the drop-down menu. For the output folder in the 
Processing Parameters tab you can activate Display execution output and select the folder which was 
created during the export (here: 20190708_20190702_split_Orb_Stack_esd_ifg_deb_flt_subset). To 
start the unwrapping, click Run. SNAP then sends the command stored in snaphu.conf to the snaphu.exe 
which creates the raster image belonging to the unwrapped phase metadata.  
 

 
Figure 26: Unwrapping with the snaphu plugin 

 
Note: If the tool is not executed by clicking Run, go to Manage External Tools in the Tools menu. Select 
“Snaphu-unwrapping” and click Edit the selected operator   to open the configuration and enter the 
export directory in the variable USERPROFILE under the System Variables tab. Confirm with OK and start 
the Snaphu-unwrapping operator again.  
 

 
Figure 27: System variables of the snaphu plugin  
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Note that unwrapping can take a considerable amount of time. To break the raster into smaller chunks, 
snaphu divides it by standard into 10 rows and 10 columns, leading to a total of 100 tiles to be unwrapped. 
These tiles are merged afterwards based on the selected pixel overlap (here 200 pixels). A progress bar 
will inform you about the remaining time. The calculation is completed when the progress reaches 100% 
and the output states “Finished tool execution in … seconds”. You can then close the operator.  
 
Alternative option: If the unwrapping does not work with the plugin from within SNAP, snaphu can also be 
started from the command line. It can be downloaded from the following page which also contains 
instruction for its manual execution: https://step.esa.int/main/third-party-plugins-2/snaphu/  
 

Import 
The opened unwrapped phase does not have any metadata or geocoding. The Snaphu import (under Radar 
> Interferometric > Unwrapping) converts the it back into the BEAM DIMAP format and adds the required 
metadata from on the wrapped phase product as they have the same geometry. The Snaphu import needs 
the following tabs:  
 

 1-Read-Phase: Here, you select the subset of the interferogram (before the export) from the drop-
down menu. 

 2-Read-Unwrapped-Phase: Select the  icon to open a file menu and navigate to the export 
directory. Select the *.hdr file of the unwrapped phase (here UnwPhase_ifg_[…].hdr). Note: 
The error message will then vanish if you proceed to the next tab.  

 3-SnaphuImport: Leave the option “Do NOT save Wrapped interferogram in the target product” 
unchecked, because it is required in the later step.  
4-Write: To store the imported unwrapped band in a separate product (recommended), add ‘_unw’ 
to the output name (here: 20190708_20190702_split_Orb_Stack_esd_ifg_deb_flt_subset_ ) and 
click Run. 

 
A new product is added to the Product Explorer which contains the wrapped interferogram 
(Phase_ifg_IW…), the coherence (coh_IW_...) and the unwrapped phase generated with snaphu (here: 
UnwPhase_ifg_IW2_VV_08Jul2019_02Jul2019)  
 
Double click on the unwrapped phase to see if the unwrapping was successful. It should be a smooth raster 
with little variation except for the areas of expected deformation (Figure 28). All fringe patterns are 
summarized to absolute changes (Figure 24). Unwrapping errors can occur in areas of low coherence and 
in urban areas with many vertical objects.  
 
If you notice strange grid-like patterns in your unwrapped results, you can change the amount of tile columns 
and rows in the export (or directly in the snaphu.conf file) and run the unwrapping again. Just make sure 
you delete the unwrapped phase (UnwPhase_ifg_[…].img) and the temporary files in the export 
directory before you restart the unwrapping. Sometimes it is also favorable to switch the statistical cost-
mode from DEFO to SMOOTH or the initial method from MCF to MST and compare the outputs.  
 

https://step.esa.int/main/third-party-plugins-2/snaphu/
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Figure 28: Phase before (top) and after (bottom) unwrapping 

 

Phase to Elevation 
The unwrapped phase is now a continuous raster but 
not yet a metric measure. To convert the radian units 
into absolute heights, the Phase to Elevation operator 
(under Radar > Interferometric > Products) is applied. 
It translates the phase into surface hewights along the 
line-of-sight (LOS) in meters. The LOS is the line 
between the sensor and a pixel. A DEM is used to put 
the elevation values in the correct level.   
 
In the Processing Parameters tab, select SRTM 1Sec 
HGT (AutoDownload) as input DEM.  
 
The operator is applied to the unwrapped phase which 
was imported in the last step. It produces an output 
which looks similar to the unwrapped phase (slightly 
different predefined color ramp), but now each pixel 
has a metric value indicating its height above sea level.  
 

You can plot a Histogram  to check the frequency 
distribution of the values (Figure 30). 
 

 
Figure 29: Phase to Elevation 
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Figure 30: Histogram of the elevation raster 

 
Note: The original phase and coherence bands are not automatically copied into the resulting raster of the 
Phase to Elevation operator. If they are needed in the final product, they can be added via the Band Maths 
operator (right-click on the elevation product and select Band Maths).  
 
Call the new raster which is to be generated coherence and uncheck the “Virtual” option (Figure 31, left). 
Open the Band Maths Expression Editor by clicking Edit Expression. You can now switch between 
products which have the same dimensions (rows and columns) in the Band Maths Expression Editor and 
double-clicking the coherence band of a previous product to add it to the expression window (Figure 31, 
right). Confirm with OK (twice) to apply the calculation.  
 
The coherence band is now part of the elevation product. Save it by selecting File > Save Product in the 
menu.  
 

 
Figure 31:  Transfer of bands between products 
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You can digitize a line and use the Profile Plot tool   to visualize single elevation patterns and their value 
ranges (Figure 32). This is also a good way to check also the amount of noise in the lower coherence areas. 
Smooth lines indicate good results while sawtooth patterns are often caused by phase decorrelation.  
 

 
Figure 32: Profile plot the created elevation  

 

Terrain Correction 
Terrain Correction will geocode the image by correcting SAR geometric distortions using a digital elevation 
model (DEM) and producing a map projected product. 
 
Geocoding converts an image from slant range or ground range geometry into a map coordinate system. 
Terrain geocoding involves using a Digital Elevation Model (DEM) to correct for inherent geometric 
distortions, such as foreshortening, layover and shadow (Figure 33). More information on these effects is 
given in the ESA radar course materials.  
 
 

 
Figure 33: Geometric distortions in radar images (Braun 2019) 

 

https://earth.esa.int/web/guest/missions/esa-operational-eo-missions/ers/instruments/sar/applications/radar-courses/content-3/-/asset_publisher/mQ9R7ZVkKg5P/content/radar-course-3-slant-range-ground-range
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Open the Range Doppler Terrain Correction operator 
(under Radar > Geometric > Terrain Correction). Select 
the elevation product as an input in the first tab.  
 
In the Processing Parameters tab, select SRTM 1Sec 
HGT (AutoDownload) as input DEM.  
 
If you want to export the data as a KMZ file to view it in 
Google Earth WGS84 must be selected as Map 
Projection. It is based on geographic coordinates 
(latitude and longitude). For the later use in a 
geographic information system (GIS) a metric map 
projection, such as UTM (Automatic) could be selected 
as well.  
 
If no Source Band is selected, all bands of the input 
product are geometrically corrected.  
 
If you want to compare the quality of the InSAR DEM, 
you can select DEM as a further output. This writes the 
SRTM data used for Terrain Correction to a separate 
elevation band. The Sentinel-1 DEM will then be 
named elevation_VV and the SRTM data is named 
elevation. This option is, however, just for 
comparison and not mandatory.  

 
Figure 34: Range Doppler Terrain Correction 

 
Click on Run to start the terrain correction. SNAP now establishes a connection to an external elevation 
database to download all SRTM tiles required to fully cover the input dataset.  
 
Double click on the output to view the geocoded elevation raster (Figure 35). 
 

 
Figure 35: Terrain corrected and geocoded elevation raster 
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Export to Google Earth 
All geocoded products (projected to WGS84) can be exported as a KMZ file to view them in Google 
Earth.  
 
Select a suitable color scale and color ramp in the Color Manipulation tab and then chose File > Export > 
Other > View As Google Earth KMZ 
 
Select an output directory and a suitable filename and confirm with Safe. Open the kmz file in Google 
Earth to view the location of the elevation patterns on the satellite image base map (Figure 36).  
 
 

 
Figure 36: Result exported to Google Earth 

 
  

https://www.google.com/earth/download/gep/agree.html
https://www.google.com/earth/download/gep/agree.html
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Comparison with SRTM 
 
Open the file elevation_VV.img (inside the _TC.data folder) into a GIS (e.g. QGIS) and compute a 
hillshade representation. You might need to set the z-value to 0.000015 (because data projected in WGS84 
is based on degrees and the height is given in meters). The coherence layer will give you an indication on 
where your data is of good quality and where there can be phase errors: This is mainly mainly within 
agricultural and urban areas, as well as at slopes in the radar shadow (facing southeast).  
 
 
 

 
 

 
 

 
Figure 37: Hillshade of S1 DEM (top) and SRTM (middle); and coherence (bottom)  

https://www.qgis.org/
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Troubleshooting 
Problem Example Explanation / Solution 
The interferogram 
looks bad. 
No fringes are 
visible 

 

Decorrelation of the phase, probably 
because of surface changes between 
both acquisitions (vegetation cover).  
Things to try: Search image pairs 
• with a shorter temporal baseline 
• from the dry season 
• with a larger perpendicular 

baseline (above 150)  
Please also see the hints in section 
“Selection of suitable images” 

A trend (ramp) 
superimposes the 
topographic fringes 

 

The estimation of the flat-earth phase 
was not correct.  
Things to try (in the Interferogram 
Generation step): 
• increase the Degree of flat-earth 

polynomial 
• increase the Number of flat-earth 

estimation points 
• increase the Orbit interpolation 

degree 
Strange phase 
jumps in the 
interferogram 

 

Some slopes might be too steep for 
the given wavelength.  
Things to try: 
• Use images of a different flight 

direction: ascending instead of 
descending (or vice versa) 

• Use images with a larger 
perpendicular baseline.  

Please also see the hints in section 
“Selection of suitable images” 

The interferogram 
contains straight 
lines with phase 
jumps 

 

During the unwrapping, the total raster 
is divided into smaller parts (tiles), by 
standard 10x10. They are merged in 
the end. If this fails, such lines appear: 
Things to try: Repeat the unwrapping 
• with a smaller number of tiles 
• with larger tile overlap 
• with SMOOTH instead of TOPO 
• with MST instead of MCF 

The Goldstein 
phase filter 
introduces cross-
like patterns (often 
over urban areas)  

 

If the moving window is dominated by 
a single bright pixel, the FFT of the 
Goldstein phase filter is blurred by 
sidelobes which cause these patterns.  
Things to try:  
• Reduce the Adaptive Filter 

Exponent to 0.3 or lower. 
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For more tutorials visit the Sentinel Toolboxes website 
 

http://step.esa.int/main/doc/tutorials/ 
 
 

 
 

Send comments to the SNAP Forum 
 

http://forum.step.esa.int/ 
 

http://step.esa.int/main/doc/tutorials/
http://forum.step.esa.int/
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