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Exporting of data from SNAP 
 
The goal of this document is to demonstrate how data processed in SNAP can be used in other software 
for image processing or geospatial analysis, such as ArcGIS or QGIS.  
This is required, whenever processing tools or algorithms are required which are not covered by SNAP. 
However, there are a number of important things to consider for the selection of a suitable data export. 
 

Export to GeoTiff 

Selection of data 

Raster bands or entire stacks can be exported to the GeoTiff fomat, a widely used standard which stores 
both raster values and the geocoding of data. Once a raster product is loaded and displayed in SNAP, this 
can be done via the menu: 
 
File > Export > GeoTIFF 

 
The subsequent dialogue allows to define the spatial extent and the desired bands as shown in Figure 1. 
Especially when you work with Copernicus data, make sure to only select the bands you really need, 
because many of the mask layers and quality indicators are included unless you de-select them in the Band 
Subset tab (right side). You will see how the size of the target product changes when you include or exclude 
certain bands. Confirm with OK and Export Product to start the conversion to GeoTiff.  

 

Figure 1: Export of a Sentinel-2 raster stack 

 
Things to note 

• The file size of a GeoTiff raster stack is larger than the sum of img rasters contained in the BEAM 
DIMAP product. This maybe of relevance when working with large file volumes. Alternatives are given 
in chapter “Direct use of BEAM DIMAP products”. 

• Many of the metadata used in SNAP are not read from the GeoTiff when it is loaded in another 
software. This is especially important for Sentinel-2 data (illustrated in Figure 2) 

• The data type of the raster might change during the export (e.g. from Float 32 bit to Integer 16 bit). 
Your raster values will change accordingly. This is important when you work with spectral signatures 
or thresholds because they might not be the same after the export.  

 
These points also apply to other formats, such as ENVI, HDF5, or JP2000.  

https://gdal.org/drivers/raster/gtiff.html
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Figure 2: Sentinel-2 metadata in SNAP 

 
As shown in Figure 2, Sentinel-2 data is physically stored as 16 bit Integer (full numbers), but displayed 
as 32 bit Float (reflectance in decimal numbers, ranging between 0 and 1 in theory, see the histogram), 
because SNAP applies the Scaling factor of 1.0E4 (=10.000) to the data. This might also apply for the 

wavelength (required for the Spectrum View ), the Valid Pixel Expression (excludes invalid pixels) and 
others are not part of the exported GeoTIFF when it is opened in another software. The same applies for 
the contrast selected in the Color Manipulation window or the order of bands of an RGB view.  
 

 

Figure 3: Sentinel-2 data exported as GeoTiff and opened in QGIS  
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As shown in Figure 3, the exported GeoTIFF opened in QGIS is interpreted as 16 bit Integer and all bands 
range between 0 and 10.000. To get the reflectance values as displayed in SNAP, the Scaling factor as 

shown in the band’s Information  window ( Figure 2) has to be applied manually, for example by dividing 
the raster values by 10.000 in the raster calculator.  

Notes on contrast 

Software packages handle the display of raster values differently. SNAP automatically stretches colors over 

95% of the value range of a band ( ), but this might not be the case in QGIS or ArcMap. To get good 
visual contrasts in QGIS, open the Layer Properties under Symbology. Select “Stretch to MinMax” and 
select “Cumulative count cut” as under Min / Max Value Settings (Figure 4). The same applies for ArcGIS 
which uses a similar percent clip as SNAP (Figure 5), but also not as a default setting. Without these settings 
the image can appear rather dark. However, it is important to understand, that these enhancements do not 
affect the pixel values of the raster, but only change which colors are assigned to them for display.  
 

 
Figure 4: Visual contrast adjustment in QGIS 

 

 
Figure 5: Visual contrast adjustment in ArcGIS  
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Export to CSV 
Whenever pixel values of images or regions of interest are required for statistical analysis, the CSV export 
is an option. It can be found in the menu under  
 
File > Export > GeoTIFF 

 
and writes a list of all pixels of one or multiple bands (allows the same selection of subset area and bands 
as in Figure 1) to a text file, as well as their x and y coordinates. This requires an immense amount of data 
and is mostly not necessary, because there are tools which allow more specific export.  
 

Export of pixels within a polygon 

If only statistics of a certain area of the image are required, a polygon can be digitized, and the values 
underneath are exported by right-clicking > Export Mask Pixels. In the next dialogue, the mask of interest 
(here geometry) has to be selected and in the last step, additional options, such as headers or tie-points 
(only required if you know that you need them) can be set. After clicking Write to File a text file is created 
which contains the x and y position of a pixel, their coordinates, as well as the pixel values of the different 
bands (Figure 6). This allows a systematic evaluation of the pixel values outside SNAP, for example in MS 
Excel (Figure 7). A detailed description on how to load tabular data stored as text into Excel is given here.  
 

 

Figure 6: Export of Mask pixels to CSV 

 

 

Figure 7: Box plots for selected bands under the digitized polygon  

https://www.ablebits.com/office-addins-blog/2014/05/01/convert-csv-excel/
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Pin Manager 

The Pin Manger  is a useful tool to export values of selected pixels for systematic comparison. After 
digitizing pins (and optionally assigning class names and colors), the raster values can be extracted with 

the filter icon  Filter pixel data to be displayed in table. The bands are then added as columns as 

shown in Figure 8 which can then be exported with Export selected data to text file .  
 
An example of the file structure of the exported pixel values is shown in Figure 9. Please note that the data 
is separated by tabulators, so the headers might not look aligned with their columns in a simple text editor, 
but the structure allows the clean ingestion in statistic programs, such as MS Excel, SPSS or Orange. If the 
data was labelled, classifiers can be trained based on the table, for example by searching ideal thresholds 
to separate the classes based on the selected bands (an example is given here). Note that it might be 
necessary to remove the first 6 lines so that the first line is the header of the column (starting with “Name”). 
 

 

Figure 8: Extraction of pixel values under pins 

 

 

Figure 9: Exported table of pixel values under pins 

  

https://www.youtube.com/watch?v=D6zd7m2aYqU
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Export to Google Earth 
 
Google Earth is a freely available software to visualize spatial information on satellite image backgrounds. 
Vector data is loaded as kml (Keyhole Markup Language) files. SNAP supports the export to Google Earth 
by using the KMZ format which additionally allows the storage of raster information. These can be shared 
to people which are not familiar with geographic information systems (GIS), but still want to allocate the 
produced image product and interpret it based on the underlying satellite image information. This can be 
done by opening a band or RGB image and selecting  
 
File > Export > Other > View as Google Earth KMZ 

 
The following points are important here: 

• The data must be projected in WGS84 (not UTM or other coordinate reference systems). Select 
Raster > Geometric > Reprojection if your data does not have the requested projection.  

• The current image view is exported as it is displayed. That means the zoom and extent, as well as 
color adjustments have to be defined in advance.  

• There is an upper size limit of 2 GB and the export fails if this file size is exceeded. To avoid this, 
resampling to a lower resolution is recommended before exporting, also zooming to the smallest 
area necessary.  

• For some graphic cards, the kmz is only displayed in Google Earth when zooming very close to the 
data. Check the 3D View options of Google Earth to test if changes of the Graphics Mode or 
Antialiasing help to avoid this.  

 
 

 

Figure 10: Radar image exported to Google Earth  

https://www.google.com/intl/de_ALL/earth/versions/#download-pro
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Direct use of BEAM DIMAP products 
 
In many cases, it is not necessary to export raster data to another format, because the BEAM DIMAP format 
is compatible with many other programs and can directly be loaded into QGIS, ArcGIS or others. This not 
only reduces the chance for errors which occur during the conversion, but also avoids the writing of large 
files with the same information content.  
Each BEAM DIMAP product which was written in SNAP consists of two parts – a .dim file and a .data folder. 
Both have the same name and must be stored inside the same directory, so SNAP reads them as one 
product. 
 

 
 

• .dim file: xml structure containing all metadata of the original product, such as sensor name, acquisition 
date, but also all the processing history in SNAP (including all applied tools and selected parameters) 
is stored in here.  

• .data folder: Depending on the product this folder contains the following elements: 
o vector_data folder: If you digitized or imported vectors in SNAP, they are stored in here 
o tie-point grids folder: If the product contains tie-point grids, they are stored inside this folder 
o .img files of each raster band belonging to the product 
o .hdr files of each raster band, storing header information (product name, rows, columns, file type, 

data type, storage type, band name, coordinate reference, wavelength, etc.) 
 
The .img files are ENVI compatible and can be directly loaded into QGIS or ArcMap. As shown in Figure 
11, each band of the raster product is stored as an img file of the same name as displayed in SNAP.  
 

 
Figure 11: Bands in SNAP (left) Files inside the .data folder of the BEAM DIMAP product (right)  

https://www.brockmann-consult.de/beam/doc/help/general/BeamDimapFormat.html
https://gdal.org/drivers/raster/envi.html
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As shown in Figure 12, the .img files can be loaded and displayed in QGIS or ArcGIS without exporting into 
a different file format. However, the contrast (see chapter “Notes on contrast”) has to be set accordingly.  
 

 

Figure 12: img file of Band 2 of aSentinel-2 product loaded into QGIS (left) and ArcGIS (right) 

 
As all raster bands are stored separately in the .data folder, a stack can be created with 

• Menu >Raster > Miscellaneous > Merge (QGIS) 

• Toolbox > Data Management Tools > Raster > Raster Processing > Composite Bands (ArcGIS). 
An example is given in Figure 14.  

 
In case of thematic raster products, such as classifications, the name of the file in the .data folder is either 
LabelledClasses.img or class_indices.img. Again, colors defined in SNAP are not exported with the data. 
When it is loaded in QGIS or ArcGIS, it is displayed as a continuous greyscale raster by default, so the 
symbology has to be changed to “Paletted/Unique values” (QGIS, left) or “Unique” (ArcGIS, right) as shown 
in Figure 13. This allows to define individual colors for each pixel value, as shown in Figure 15.  
 

 

Figure 13: Assignment of discrete colors to raster values 
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Figure 14: Creation of a raster stack from img files 

 
 

 

Figure 15: Display of classified data in QGIS 
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For more tutorials visit the Sentinel Toolboxes website 
 

http://step.esa.int/main/doc/tutorials/ 
 
 
 
 
 
 
 
 

 
 

Send comments to the SNAP Forum 
 

http://forum.step.esa.int/ 
 
 

http://step.esa.int/main/doc/tutorials/
http://forum.step.esa.int/

